T-Mobile and Pinephone Pro in the US
#1
Question 
When I first got my Pinephone Pro a little over two weeks ago, I removed my T-Mobile SIM card from my old phone, and inserted it in my Pinephone Pro. I enabled mobile data by setting the APN to fast.t-mobile.com in the phone's settings, and I recall that it seemed to work until I also enabled MMS by setting MMSC to http://mms.msg.eng.t-mobile.com/mms/wapenc in the Spacebar texting program. I was able to send MMSs, but at some point thereafter, data stopped working. Editing/deleting/recreating the APN setting, rebooting, and removing/reinserting the SIM all did not help, so I put the SIM back in my old phone. I was also disappointed that YouTube videos in the Angelfish browser skipped (even over Wi-Fi), and were therefore basically unwatchable/unlistenable. I didn't get a chance to test the Pinephone Pro again until yesterday.

Well yesterday and today... data and MMS suddenly work fine. There are two reception symbols in the status bar, and one has a little "L" on it. I don't know what the "L" stands for, but I presume that symbol is for mobile data, because it gets replaced by a Wi-Fi symbol when Wi-Fi is enabled (which must mean the reception symbol without an L is for regular voice coverage). And YouTube videos suddenly play at 1080p in Angelfish over mobile data and Wi-Fi with no skipping now, which is great. However, on the phone's pull-down quick settings menu, the "Mobile Data" button usually says "Off", even when the "Mobile Data" switch is enabled deeper inside the "Cellular Network" settings, the symbol with the "L" is in the status bar, Wi-Fi is off, and data appears to be working. I'm inclined to chalk that up to Plasma Mobile being buggy (as it has plenty of other UI bugs).

Unfortunately, outgoing voice quality is awful. On a call between the Pinephone Pro with T-Mobile and an iPhone with Metro (which is owned by T-Mobile), the iPhone can be heard fine on the Pinephone Pro, but listening on the iPhone the Pinephone Pro sounds like it's at a harsh noise concert. Yes, this is with muting one microphone or going to separate locations to make sure there is no feedback loop. I'm worried there could be a hardware problem with the Pinephone Pro's microphone, and if so I don't know if the Factory Test Build for Hardware Checking would detect it since the mic technically "works", but I'm going to try running the FTB. Also, the phone died when it said the battery was 33% full.

1) Has anyone else used a Pinephone Pro with T-Mobile in the US, and can you comment on your experience?
2) Might upgrading to biktorgj's custom modem firmware alleviate any of the issues I've experienced?
3) Might changing out Manjaro + Plasma Mobile for Gentoo + Wayland + SXMO alleviate anything?
(My x86 laptop runs Gentoo + Wayland + Sway, and I already have experience cross-compiling for ARM for a Raspberry Pi).
  Reply
#2
The "L" stands for "LTE", i.e. 4G (= 4th generation) technology. That is the fastest and most modern the PinePhone Pro (and also the original PinePhone) will support, so it is a good sign if you see an "L".
  Reply
#3
The problem of outgoing audio sounding like a feedback loop appears to be unrelated to carrier. I have read speculation about it being caused by the mic being sensitive, and/or the mic audio somehow being routed twice somewhere in the software stack. The only thing that worked for me on stock firmware was turning the input volume down to 0% in audio settings.
  Reply
#4
Try playing around with your alsamixer settings, as I did for my original PinePhone: https://forum.manjaro.org/t/original-pin...ing/153873. If you find any setting that makes the sound better on the Pro, please report your findings.
  Reply
#5
(12-14-2023, 04:42 PM)jydoxcen Wrote: Unfortunately, outgoing voice quality is awful. On a call between the Pinephone Pro with T-Mobile and an iPhone with Metro (which is owned by T-Mobile), the iPhone can be heard fine on the Pinephone Pro, but listening on the iPhone the Pinephone Pro sounds like it's at a harsh noise concert. Yes, this is with muting one microphone or going to separate locations to make sure there is no feedback loop. I'm worried there could be a hardware problem with the Pinephone Pro's microphone, and if so I don't know if the Factory Test Build for Hardware Checking would detect it since the mic technically "works", but I'm going to try running the FTB. Also, the phone died when it said the battery was 33% full.
The latest update just "broke" my phone again. The other person complaining about an echo.

(12-14-2023, 04:42 PM)jydoxcen Wrote: 1) Has anyone else used a Pinephone Pro with T-Mobile in the US, and can you comment on your experience?
I am your guy.

Device: PinePhone 32Gig (Used for building packages)
Device: PinePhonePro (Daily driver)
OS: DanctNIX Arch with Phosh
Carrier: USA - Patriot Mobile (T-Mobile SIM)

See this post for a complete install and setup.
https://forum.pine64.org/showthread.php?tid=18192

See this post for my experience on functionally 
https://forum.pine64.org/showthread.php?...#pid118783

(12-14-2023, 04:42 PM)jydoxcen Wrote: 2) Might upgrading to biktorgj's custom modem firmware alleviate any of the issues I've experienced?
YES! see my YouTube channel. Make sure you get the correct ADSP for T-Mobile
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Question Pinephone Pro for a Debian user? primesocial 2 130 04-15-2024, 03:01 AM
Last Post: zetabeta
  PinePhone Pro silver lining, it’s fast, real damn fast ashoka232 0 465 03-20-2024, 01:45 AM
Last Post: ashoka232
  PinePhone Pro Black Screen CrimsenRaven 2 358 03-16-2024, 11:40 AM
Last Post: tmoj
  PinePhone Pro Review tmoj 2 617 03-14-2024, 07:14 AM
Last Post: tmoj
  Can't boot Pinephone Pro into Factory Test Build for Hardware Checking jydoxcen 3 694 02-17-2024, 04:04 AM
Last Post: fxc
Question Phone call with the pinephone pro dfs 5 4,192 02-10-2024, 09:54 PM
Last Post: Kevin Kofler
  Average Joe review of Pinephone Pro (March 2023) alaraajavamma 6 10,207 01-06-2024, 11:32 AM
Last Post: mikehenson
  Pinephone Pro Screen Protector jydoxcen 11 1,377 12-21-2023, 07:58 AM
Last Post: zetabeta
  Pinephone Pro does not start with RE button pressed c0ssan 10 5,321 09-28-2023, 09:21 AM
Last Post: R0bbi3Mack
  Is my pinephone pro worth resurrecting? tckosvic 5 2,965 09-14-2023, 06:48 AM
Last Post: DaForest

Forum Jump:


Users browsing this thread: 1 Guest(s)