changing from bullseye to bookworm to install mmsd-tng
#1
I'm trying to change from the bullseye repository to the bookworm, and I'm getting an error about the repository being unsigned. In /etc/apt/sources.list.d/mobian.list

I changed

deb http://repo.mobian-project.org/ bullseye main non-free

to

deb http://repo.mobian-project.org/ bookworm main non-free

but now when I run

apt update

I get

Hit:1 http://deb.debian.org/debian bullseye InRelease
Get:2 http://repo.mobian-project.org bookworm InRelease [32.4 kB]
Err:2 http://repo.mobian-project.org bookworm InRelease
  The following signatures were invalid: EXPKEYSIG 951D61F2BC232697 Mobian Project <admin@mobian-project.org>
Reading package lists... Done
W: GPG error: http://repo.mobian-project.org bookworm InRelease: The following signatures were invalid: EXPKEYSIG 951D61F2BC232697 Mobian Project <admin@mobian-project.org>
E: The repository 'http://repo.mobian-project.org bookworm InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Does anyone know what might cause this?
  Reply
#2
Possibly this issue:

https://forum.pine64.org/showthread.php?tid=16856
  Reply
#3
debian and mobian changed some policies, so practically "non-free-firmware" is required.

files probably should look similar to this:
Code:
mobian@mobian:~$ cat /etc/apt/sources.list
deb http://deb.debian.org/debian bookworm main non-free contrib non-free-firmware
mobian@mobian:~$ cat /etc/apt/sources.list.d/mobian.list
deb http://repo.mobian.org/ bookworm main non-free non-free-firmware contrib

yes, there was possible leak of signing keys in the past. so, mobian changed signing keys.
  Reply
#4
it seems that mobian does not have "non-free-firmware". but mobian may have it in the future. in my knowledge some software components of mobian and pinephone is not open source.

debian is different story.
  Reply
#5
See: https://blog.mobian-project.org/posts/20...-firmware/
  Reply
#6
(04-02-2023, 05:33 PM)Kevin Kofler Wrote: See: https://blog.mobian-project.org/posts/20...-firmware/

Interesting... I added "non-free-firmway" to  /etc/apt/sources.list and  /etc/apt/sources.list.d/mobian.list, but "apt update" still fails with the same error. Zebulon Walton, the thread you linked had a lot of ideas, but they eventually converged on running " apt-get dist-upgrade" first. I did that, and it succeeded, however, running apt upgrade afteward still failed. That seems really strange to me, that the more rigorous update would succeed whereas the lighter one failed.
  Reply
#7
(04-05-2023, 10:26 PM)jyoung Wrote:
(04-02-2023, 05:33 PM)Kevin Kofler Wrote: See: https://blog.mobian-project.org/posts/20...-firmware/

Interesting... I added "non-free-firmway" to  /etc/apt/sources.list and  /etc/apt/sources.list.d/mobian.list, but "apt update" still fails with the same error. Zebulon Walton, the thread you linked had a lot of ideas, but they eventually converged on running " apt-get dist-upgrade" first. I did that, and it succeeded, however, running apt upgrade afteward still failed. That seems really strange to me, that the more rigorous update would succeed whereas the lighter one failed.

if you get same error, then probably keys are still missing.

Code:
curl -s https://repo.mobian.org/mobian.gpg | sudo tee /etc/apt/trusted.gpg.d/mobian.gpg
# or
wget -O - https://repo.mobian.org/mobian.gpg |  sudo tee /etc/apt/trusted.gpg.d/mobian.gpg

other hand, you could manually download https://repo.mobian.org/mobian.gpg file and copy it to /etc/apt/trusted.gpg.d/mobian.gpg . root or sudo is required.

i have a bad feeling that updating packages afterwards may be complicated, so i suggest aptitude.
  Reply
#8
(04-06-2023, 02:04 PM)zetabeta Wrote:
(04-05-2023, 10:26 PM)jyoung Wrote:
(04-02-2023, 05:33 PM)Kevin Kofler Wrote: See: https://blog.mobian-project.org/posts/20...-firmware/

Interesting... I added "non-free-firmway" to  /etc/apt/sources.list and  /etc/apt/sources.list.d/mobian.list, but "apt update" still fails with the same error. Zebulon Walton, the thread you linked had a lot of ideas, but they eventually converged on running " apt-get dist-upgrade" first. I did that, and it succeeded, however, running apt upgrade afteward still failed. That seems really strange to me, that the more rigorous update would succeed whereas the lighter one failed.

if you get same error, then probably keys are still missing.

Code:
curl -s https://repo.mobian.org/mobian.gpg | sudo tee /etc/apt/trusted.gpg.d/mobian.gpg
# or
wget -O - https://repo.mobian.org/mobian.gpg |  sudo tee /etc/apt/trusted.gpg.d/mobian.gpg

other hand, you could manually download https://repo.mobian.org/mobian.gpg file and copy it to /etc/apt/trusted.gpg.d/mobian.gpg . root or sudo is required.

i have a bad feeling that updating packages afterwards may be complicated, so i suggest aptitude.

That works, the update went through, without any complaints! I am having some weird problems now, though. My audio book player (cozy) won't play through the headphones. I'm guessing this is probably not related to the earlier issue, but any ides there?
  Reply
#9
(04-09-2023, 08:06 AM)jyoung Wrote: ...

That works, the update went through, without any complaints! I am having some weird problems now, though. My audio book player (cozy) won't play through the headphones. I'm guessing this is probably not related to the earlier issue, but any ides there?

as a hint, could be relate to the gstreamer versus pipewire. i don't know specific advises at the moment.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Struggle to install LibreOffice on the PinePhone Peter Gamma 49 29,263 06-13-2024, 05:50 PM
Last Post: Peter Gamma
  Install OS Permanently ismkdc 1 1,509 03-20-2023, 01:13 PM
Last Post: fxc
  install packages pamac anbox neithan76 0 782 07-18-2022, 07:13 AM
Last Post: neithan76
  Beta support: MMS on chatty/mmsd on Modem Manager - help/testing wanted! kop316 201 196,475 03-24-2022, 03:16 AM
Last Post: as365n4
  Streamlined jmms install amindfv 1 1,782 10-29-2021, 07:04 AM
Last Post: TRS-80
  Python3 Bridge SMS/MMS to Matrix using Modem Manager and MMSD FutureBucket 3 4,286 02-10-2021, 08:09 PM
Last Post: kop316
  Anbox: install Google Services sonic 0 2,012 02-07-2021, 04:45 AM
Last Post: sonic
  Install OS directly to eMMC? tahayassen 11 16,670 10-10-2020, 03:56 PM
Last Post: electricprism
  Changing the boot loader Boern 1 3,351 04-12-2020, 11:22 AM
Last Post: wibble

Forum Jump:


Users browsing this thread: 1 Guest(s)