Endeavour OS on Pbpro
(12-31-2022, 01:52 PM)Malcolm Wrote:
(12-23-2022, 08:47 PM)rfm83 Wrote:
(12-23-2022, 06:47 PM)wdt Wrote: OK, is there an extlinux/extlinux.conf or a boot.scr/boot.txt
are the contents right? especially the paths?
is there an initrd and if you examine the contents does it seem to be right?
and it is worth looking at the dtb,
this is something that can be swapped for a different one (but same hardware & close to same kernel ver)
BTW, the paths are all relative to the config file, mounting happens in inityes 

The script was actually failing due to a missing package (pv). After scrolling up the terminal I could see that things were failing. Now I am able to boot from the SD card. However, the calamares installer is not responsive. Buttons don't work so I'm not able to proceed. Sometimes it even boots into a black screen.

I was working on this last night and encountered the same issue with an unresponsive calamares installer. I stumbled across a goofy workaround by dumb luck and thought I'd share. The following steps worked for me when installing to an SD card or the emmc. Note that I have tow-boot installed on SPI.

Boot into the calamares environment that's mostly unresponsive. From here the only thing that actually worked was the Network utility in the tray. Be sure to set up your wifi connection here before proceeding further.
Switch to a new tty session(Ctrl+Alt+F2/F3/etc)
From the console there, just run 'startx'
At this point it booted a new graphical session where calamares/terminal/file manager all worked as they should.
Install as you like and just follow instructions.

FWIW, I was using the latest pbp image from their test-images/releases on github, and just writing that to sd or emmc with either dd or a tool like gnome-disks. With that method, once booted, the calamares install just sets up the installation wherever you've written the image and booted it from.

I hope that's useful. I can't speak for any other errors people are encountering.
Good workaround. It works for me as well after restarting Calamares with 'startx'. The install worked fine after that. 
Thanks for your help.
Some issues noticed after the install:

1. Keyboard keys on the right side of keyboard (U, I, O, P) are actually typing the numbers or symbols in blue. This is for the US keyboard ANSI
2. Wireless card not detected after a reboot(issue with kernel 6+ even with other distros like Manjaro)
3. Usb-c to HDMI not working

Possibly Related Threads…
Thread Author Replies Views Last Post
  Pbpro is sluggish flatulent_piney 3 3,529 02-15-2021, 11:04 AM
Last Post: User 17828
  power light blinking during charge when pbpro is off Idaho 0 1,839 01-04-2021, 10:53 AM
Last Post: Idaho

Forum Jump:

Users browsing this thread: 1 Guest(s)