Troubleshooting incoming SMS/MMS
#1
Question 
I have a new PinePhone 1.2b with the stock Manjaro + Plasma Mobile, and one of the first things I tried (after phone calls!) was text messaging in Spacebar.  It worked fine for sending a text, but a simple plaintext reply never showed up on the PinePhone.

I see some old threads and mentions elsewhere about troubleshooting this with ModemManger and mmcli, but ModemManager is mysteriously not running for me.  Have times changed and there's some other way I should be investigating this, or is it unexpected that ModemManger isn't running?  I've flailed around and tried to get it going (see below) but maybe I'm barking up the wrong tree.

Code:
# mmcli -L
error: couldn't find the ModemManager process in the bus

# systemctl status ModemManager
● ModemManager.service - Modem Manager
     Loaded: loaded (/usr/lib/systemd/system/ModemManager.service; disabled; vendor preset: disabled)
     Active: inactive (dead)

# systemctl start ModemManager
# systemctl status ModemManager
● ModemManager.service - Modem Manager
     Loaded: loaded (/usr/lib/systemd/system/ModemManager.service; disabled; vendor preset: disabled)
     Active: active (running) since Fri 2022-05-13 16:17:00 EDT; 2s ago
   Main PID: 4593 (ModemManager)
      Tasks: 7 (limit: 3275)
     Memory: 12.6M
     CGroup: /system.slice/ModemManager.service
             ├─4593 /usr/bin/ModemManager
             └─4600 /usr/lib/qmi-proxy

May 13 16:17:03 plasma-mobile ModemManager[4593]: <info>  [base-manager] modem for device '/sys/devices/platform/soc/1c1b000.usb/usb2/2-1' successfully >
May 13 16:17:03 plasma-mobile ModemManager[4593]: [/dev/cdc-wdm0] Opening device with flags 'version-info, proxy'...
May 13 16:17:03 plasma-mobile ModemManager[4593]: [/dev/cdc-wdm0] created endpoint
May 13 16:17:03 plasma-mobile ModemManager[4593]: [/dev/cdc-wdm0] Checking version info (25 retries)...
May 13 16:17:03 plasma-mobile ModemManager[4593]: Cannot read from istream: connection broken
May 13 16:17:03 plasma-mobile ModemManager[4593]: [/dev/cdc-wdm0] QMI endpoint hangup: removed
May 13 16:17:03 plasma-mobile ModemManager[4593]: <info>  [base-manager] couldn't check support for device '/sys/devices/platform/soc/1c10000.mmc/mmc_ho>
May 13 16:17:03 plasma-mobile ModemManager[4593]: [/dev/cdc-wdm0] Opening device with flags 'version-info, proxy'...
May 13 16:17:03 plasma-mobile ModemManager[4593]: [/dev/cdc-wdm0] created endpoint
May 13 16:17:03 plasma-mobile ModemManager[4593]: [/dev/cdc-wdm0] Checking version info (25 retries)...
# mmcli -L

No modems were found
  Reply
#2
I've made a bit of progress and answered some of my own questions.  In Plasma Mobile I have eg25manager and ofonod running instead of ModemManager, so, I can use ofonoctl instead of mmcli.  I found a gitlab issue about exactly this problem (I'm also on Verizon) over with the UBPorts folks:

https://gitlab.com/ubports/community-por...issues/184

This sounds very much like what's happening to me.  I can see a log entry show up for ofonod each time an incoming text message *should* arrive that says "Unable to decode PDU."  I guess my options are to pursue this some more via oFono, or switch gears and try a different software stack instead (assuming ModemManager would work?)
  Reply
#3
You should probably update then - Plasma Mobile has moved from ofono to ModemManager recently.
  Reply
#4
(05-15-2022, 05:45 AM)wibble Wrote: You should probably update then - Plasma Mobile has moved from ofono to ModemManager recently.

That should have been my first thought.  Thanks!

I just followed along with Manjaro's docs and did a sudo pacman -Syu, and that's churning along, but is there anything mobile-specific I should be doing here?  I can't seem to find any docs for Plasma Mobile specifically, just Manjaro itself.

Thanks for your help.
  Reply
#5
I haven't used Manjaro so can't be much help there - I don't know if the package manager will take care of everything or whether manual changes will be needed. I was just following an upstream issue with plasma mobile and saw the migration from ofono to ModemManager a while back. Since it's a relatively recent change of telephony backend they may have regressions still to fix.
  Reply
#6
Thumbs Up 
Thanks for your input anyway.  It seemed like it updated Manjaro but then the Spacebar app wouldn't let me do anything at all SMS-related.  And then on Manjaro + Phosh (via https://xnux.eu/p-boot-demo/ on an SD card) the Chats app works fine for SMS in both directions.  So, there's still something goofy about the state of the preinstalled Manjaro, but I have a working alternative to play with and I'd consider my problem essentially solved.

Thanks!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  No incoming SMS. Outgoing SMS, calls and data working. HardwarePunk 3 1,077 11-20-2021, 12:53 AM
Last Post: HardwarePunk
  Outgoing calls/sms work, incoming don't user12345 2 1,709 04-12-2021, 10:11 AM
Last Post: user12345

Forum Jump:


Users browsing this thread: 1 Guest(s)