Discover crashing (terminal output included).
#1
Manjaro-Plasma installed from the "Factory Image 202203111950" to the eMMC. Discover worked at first but then broke. Running from the GUI apps menu shows the start splash for a while then nothing; running from the terminal gives a segfault error. I think an update by pacman -Syu from the terminal is what broke discover but I'm not completely sure about that.

I have the output from running plasma-discover $> out.txt in the terminal.

Code:
qrc:/qml/DiscoverWindow.qml:116:19: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 15. Use 'sequences: [ <key> ]' to bind to all of them.
kf.kirigami: Units.devicePixelRatio is deprecated (since 5.86): This returns 1 when using Qt HiDPI scaling.
kf.kirigami: Units.wheelScrollLines is deprecated (since 5.86): Use Qt.styleHints.wheelScrollLines instead
file:///usr/lib/qt/qml/org/kde/kirigami.2/PageRow.qml:674:5: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 14. Use 'sequences: [ <key> ]' to bind to all of them.
file:///usr/lib/qt/qml/org/kde/kirigami.2/PageRow.qml:670:5: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 13. Use 'sequences: [ <key> ]' to bind to all of them.
QObject::startTimer: Timers cannot have negative intervals
qrc:/qml/DiscoverPage.qml:42:37: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 15. Use 'sequences: [ <key> ]' to bind to all of them.
org.kde.plasma.libdiscover: error loading "fwupd-backend" "Cannot load library /usr/lib/qt/plugins/discover/fwupd-backend.so: (libfwupd.so.2: cannot open shared object file: No such file or directory)" QJsonObject({"IID":"org.kde.muon.AbstractResourcesBackendFactory","archreq":0,"className":"FwupdBackendFactory","debug":false,"version":331520})
adding empty sources model QStandardItemModel(0xaaaabb016450)
file:///usr/lib/qt/qml/org/kde/kirigami.2/private/PrivateActionToolButton.qml:74:5: QML Binding: Binding loop detected for property "value"
kf.kirigami: Units.wheelScrollLines is deprecated (since 5.86): Use Qt.styleHints.wheelScrollLines instead
kf.kirigami: Units.devicePixelRatio is deprecated (since 5.86): This returns 1 when using Qt HiDPI scaling.
file:///usr/lib/qt/qml/org/kde/kirigami.2/BasicListItem.qml:273:18: QML QQuickItem*: Binding loop detected for property "implicitWidth"
file:///usr/lib/qt/qml/org/kde/kirigami.2/GlobalDrawer.qml:333:17: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "preferredHeight"
file:///usr/lib/qt/qml/org/kde/kirigami.2/AbstractApplicationWindow.qml:282:5: QML Binding: Not restoring previous value because restoreMode has not been set.
This behavior is deprecated.
You have to import QtQml 2.15 after any QtQuick imports and set
the restoreMode of the binding to fix this warning.
In Qt < 6.0 the default is Binding.RestoreBinding.
In Qt >= 6.0 the default is Binding.RestoreBindingOrValue.

file:///usr/lib/qt/qml/org/kde/kirigami.2/GlobalDrawer.qml:354:13: QML ColumnLayout: Binding loop detected for property "height"
file:///usr/lib/qt/qml/org/kde/kirigami.2/GlobalDrawer.qml:354:13: QML ColumnLayout: Binding loop detected for property "height"
QQuickItem::stackBefore: Cannot stack QQuickItem(0xaaaabb2c9d10, parent=0xaaaabab0d0a0, geometry=0,0 0x0) before QQuickPopupItem(0xaaaaba95a9d0), which must be a sibling
file:///usr/lib/qt/qml/org/kde/kirigami.2/GlobalDrawer.qml:333:17: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "preferredHeight"
file:///usr/lib/qt/qml/org/kde/kirigami.2/AbstractApplicationWindow.qml:282:5: QML Binding: Not restoring previous value because restoreMode has not been set.
This behavior is deprecated.
You have to import QtQml 2.15 after any QtQuick imports and set
the restoreMode of the binding to fix this warning.
In Qt < 6.0 the default is Binding.RestoreBinding.
In Qt >= 6.0 the default is Binding.RestoreBindingOrValue.
And then it segfaults.

Searching the web I've not been able to find much useful. https://forum.kde.org/viewtopic.php?t=173712 reported what might be the same issue, including the error about fwupd, but got no solution.

I tried reinstalling plasma-discover and packagekit but no help. I don't know where the relevant configuration files are either.
  Reply
#2
So I have a workaround for this! Based on what another user reported at https://forum.pine64.org/showthread.php?tid=16488 , if the default language is not set as American English then Discover crashes.

So seems like there's a misconfiguration or a bug with the localisation. It's a mild annoyance for me (I had tried to set British English), but a more serious issue for someone who wants their phone in another language entirely.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Can't install software via Discover or Terminal Kimberley van Buyten 2 141 06-10-2022, 02:13 AM
Last Post: shulamy
  "Emergency" terminal on pinephone (with default setup) altulke 5 331 05-03-2022, 12:42 PM
Last Post: altulke
  Pacman vs. Discover jojuma 3 1,033 11-30-2021, 10:48 AM
Last Post: ryo
  Discover Error every boot pmprog 0 461 11-01-2021, 03:55 AM
Last Post: pmprog
  How can I update Manjaro ARM w/ Phosh using Terminal? danimations 6 878 10-24-2021, 11:58 PM
Last Post: danimations
  Terminal/bash suddenly stops inputting characters? Rainer 2 1,363 06-06-2021, 01:31 PM
Last Post: Dog House Dave
  Ensure Up To Date - Manjaro Plasma Discover Package Manager Sources Linux2thabone 0 894 05-05-2021, 11:15 AM
Last Post: Linux2thabone
  Included dock not working thelawnoob 1 1,064 04-30-2021, 06:35 PM
Last Post: donniedice

Forum Jump:


Users browsing this thread: 1 Guest(s)