Modem Dead?
#1
Hey all,

     I have been using my PinePhone quite consistently now for months now and have been enjoying the experience.  I had to run out and buy a cheap flip phone though out of necessity because it seems my modem may have died.

I have tried resetting the device, even letting it sit off for a while, and messing with the physical switches, but to no avail.  The cellular icon is grayed out and has a slash through it, and the mobile options have completely disappeared from settings.

Has anyone had this issue, and is there a fix, or do I need a new mobo?

grimlok
  Reply
#2
(03-04-2022, 09:09 PM)grimlok Wrote: Hey all,

     I have been using my PinePhone quite consistently now for months now and have been enjoying the experience.  I had to run out and buy a cheap flip phone though out of necessity because it seems my modem may have died.

I have tried resetting the device, even letting it sit off for a while, and messing with the physical switches, but to no avail.  The cellular icon is grayed out and has a slash through it, and the mobile options have completely disappeared from settings.

Has anyone had this issue, and is there a fix, or do I need a new mobo?

grimlok

command "lsusb". if modem is alive you should see something maybe "ID 05c6:9008 Qualcomm, Inc. Gobi Wireless Modem (QDL mode)", "EC25 LTE Modem"  or something else. if nothing, then it's a bad sign it's dead.

https://github.com/Biktorgj/quectel_eg25_recovery
however, possibly using usb_boot you may be able to boot into edl mode and fix it. it's somewhat difficult and it does not guarantee anything.
  Reply
#3
(03-04-2022, 09:09 PM)grimlok Wrote: Hey all,

     I have been using my PinePhone quite consistently now for months now and have been enjoying the experience.  I had to run out and buy a cheap flip phone though out of necessity because it seems my modem may have died.

I have tried resetting the device, even letting it sit off for a while, and messing with the physical switches, but to no avail.  The cellular icon is grayed out and has a slash through it, and the mobile options have completely disappeared from settings.

Has anyone had this issue, and is there a fix, or do I need a new mobo?

grimlok

What distro have you been using? Stable or unstable branch? Done any updates before it disappeared?
Have you tried another distro (SD card)?

As zetabeta indicated, hopefully it is showing in lsusb.

If it is, have you checked logs?
sudo journalctl -b | grep modem
sudo journalctl -b | grep modemmanager
sudo journalctl -b | grep eg25-manager

If showing in lsusb and distro is using mmcli, turn it on
mmcli -m any -e
check eg with
mmcli -m any --messaging-list-sms
mmcli -m any --command='AT+QCFG="ims"'

Telephony is broken for me in current Plasma Mobile stable and unstable since the switch to ModemManager, though it never really worked that with with ofono before. I imagine you'd see the modem in lsusb though.
eg25-manager (if used) controls the modem too so try restarting it / checking logs:
sudo systemctl restart eg25-manager

I remember the modem vanishing on Mobian (probably doesn't apply here but you never know) after updates to eg25-manager. I was using my modified config file and have placed it in /etc/eg25-manager to avoid it being changed after updates. But the original file had changed and was no longer compatible with eg25-manager (checked with diff). After changing the new config file as required and rebooting / restarting eg25-manager, everything worked again.

Not sure any of this will help, the eg25-manager config file thing did make the modem disappear for me, to my surprise.
Hope others may be able to help if it doesn't show on lsusb.
Pinephone v1.2 UBports CE. Adelaide, Australia using Amaysim SIM (Optus network, non-VoLTE) with Mobian SD card.
Manjaro Plasma Mobile on EMMC.
  Reply
#4
Can you communicate with the modem using atinout in a terminal?

Something like:

Code:
atinout - /dev/ttyUSB2 out.txt << EOF
        > AT
        > EOF
        cat ./out.txt # should output OK
  Reply
#5
Yeah, the modem is dead.  It doesn't show up at all.  I have decided that I will just let sleeping dogs lie, and went out and got a cheep flip phone.  I've also decided I'd rather have a dumb phone rather than a smartphone anyways.

Thank you all for your help though.

Peace to you.
  Reply
#6
Possibly a sim card problem ?
The modem does seem to "disappear" whenever there is a sim card problem.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  digitizer dead Uturn 0 68 06-18-2022, 01:56 AM
Last Post: Uturn
  firmware udate Quectel EG25-G modem alwi 3 244 06-18-2022, 01:32 AM
Last Post: user641
  Phone Dead Already? MarsColonist 3 208 06-16-2022, 10:04 AM
Last Post: wibble
  The modem does not recognize Korean SIM cards (what?) bdicewk 9 283 06-13-2022, 04:12 AM
Last Post: zetabeta
  Modem Hardware bad? Not ready for 5g?? linux76 8 1,172 05-31-2022, 06:41 PM
Last Post: SwordfishII
  Modem in failed state, not sending/receiving SMS brb78 5 709 03-31-2022, 08:37 AM
Last Post: wibble
  Dead Microphone? Pulsar 4 1,415 02-16-2022, 12:58 PM
Last Post: mysociallife
  Question regarding modem AntonReiser 21 3,908 02-14-2022, 12:23 PM
Last Post: vap0rtranz
Question Powering the modem after turning off the smartphone Mikoduso 3 846 02-04-2022, 04:06 PM
Last Post: grwlf
Question Modem shield feklee 3 991 12-13-2021, 01:06 PM
Last Post: feklee

Forum Jump:


Users browsing this thread: 1 Guest(s)