pcmanfm root permission error
Hi All

I have installed pcmanfm file manager and have a problem opening a folder as root.
As I have used this program for years on the BeagleBone Black and never had any issues, I can't seem to make the .desktop file work as expected.
Where-ever I have searched the solution being put forward is as follows.

1: create a file in /.local/share/file-manager/actions
    call it root.desktop and put the following in it.

Quote:[Desktop Entry]
Name = Open as Root
Tooltip = Open the folder as root
Icon = terminal
Profiles = on_folder;

[X-Action-Profile on_folder]
Name = Open as Root
MimeTypes = inode/directory;
SelectionCount = 1
Schemes = file;
Exec = gksudo pcmanfm %f

I edited the last line to "sudo pcmanfm %f"
When I restart and run pcmanfm there is an additional line in the menu "Open Folder as Root"
There is no confirming message and when I perform a file copy to that folder , there is a permissions error.

I seem to have the same problem with Xfe which has an option in Tools/New Root window.
So I suspect there are global permission errors, however all the usual sudo install , update etc all work correctly.

Hopefully someone can shed some light on this.


EDIT: I don't seem to get email notifications of replies, bu ticked the boxes when I wrote the email ??
This is probably due to you running a Wayland environment (as opposed to X11). Phosh and Plasma Mobile both run on Wayland. Here it says a root instance is not possible under Wayland (but "admin mode" is). I never tried pcmanfm or bothered with trying to open graphical applications as root (which is also not recommended because of various security implications), so I cannot give you more specific help. But you could try fiddling with the hints given here to maybe make it work with Wayland.

(E-mail notifications on this forum are known to be quite buggy unfortunately.)
Hi All

Thanks for your reply kqinut, but the options quoted in the link don't exist in the non-qt version of pcmanfm.

So, I concluded that perhaps I should stick to Wayland apps, ie: thunar.
Same problem, even when I do ;  sudo su   and then thunar, i get lengthy warnings and the app wont run.

Sounds like a conspiracy to me, as if even developers or users of Beta devices are not intelligent enough to understand the dangers.

So now the only way to do any file moving as root, I have to take the sd out and plug it into another computer.
Debian or Mint both will let me do it.

Not wasting any more time trying to find a file manager that will allow root access. 

Many thanks for your replies.

Sorry, I didn't know there are different versions of pcmanfm. Anyway, best way to handle files owned by root or other users is via the terminal, no need to do it on another computer. As for the security implications of running graphical apps as root, see the warning on the top of the page of this ArchWiki entry about the topic and follow the linked quote if you want to get deeper into it, no conspiracy about it and also no real need to do it in the first place, especially not for developers. If, however, you are determinded to run graphical apps as root under Wayland, check out the ArchWiki article or the second link I posted before.
Hi All

I browsed for Wayland file managers, Thunar and Dolphin showed up.

That second link worked with Thunar but not with Dolphin.
Will also test Nemo.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Error while dist upgrade PostmarketOS shellchocolat 0 550 03-16-2023, 02:56 AM
Last Post: shellchocolat
  ROOT CavRic-1974 10 6,444 01-11-2022, 08:19 AM
Last Post: CavRic-1974
  Where is the fix for CVE-2021-31698 (Code execution as root via AT commands)? Timeo 1 1,470 12-08-2021, 04:23 AM
Last Post: wibble
  Wrong PIN error lordearl 3 3,944 09-20-2021, 03:19 AM
Last Post: mcdanielmark473
  mmc_erase: group start error -110, status 0x0 gab 1 1,992 06-26-2021, 07:00 PM
Last Post: 8bit

Forum Jump:

Users browsing this thread: 1 Guest(s)