Buildroot 2021.08 not booting from SD card
#1
Good evening,

Has anyone been able to get the recent versions of Buildroot working with the rock64_defconfig? 

As of this writing, it pulls in the following:

All I can get on the UART console is the following:
Code:
U-Boot SPL 2021.07 (Nov 06 2021 - 16:11:06 -0500)
Trying to boot from MMC1
mmc_load_image_raw_sector: mmc block read error
Trying to boot from MMC2
mmc_load_image_raw_sector: mmc block read error
SPL: failed to boot from all boot devices
### ERROR ### Please RESET the board ###

I've tried with more recent 5.13.x kernels as well, but no matter what, I'm not able to get past this point.  There is no eMMC connected, only the SD card.  Armbian seems to boot from the SD card just fine.

Any help would be appreciated!
  Reply
#2
Hello,
the linux-kernel does not matter with this output. Your rock64 has mastered to boot the spl (the idbloader-part of u-boot, at 0x8000 offset), but can not find the  u-boot.itb on mmc1.
Did you write it at 0x40000 offset of  your mmc?
# dd if=u-boot.itb of=/dev/mmcblk0 seek=512 bs=512

Did you overwrite it with the first partition of your mmc? You should leave about 2M at the start of the mmc for u-boot. So start your first partition at least at sector 4096, make it an EFI System with vfat and /extlinux/extlinux.conf in it. After that you can worry about your linux-kernel.
Good luck,
hunderteins
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Booting from USB 3 SSD with other drives attached. default_user8 0 1,135 02-20-2020, 08:39 AM
Last Post: default_user8
  Nextcloudpi SD card fills up. default_user8 13 10,160 12-04-2019, 01:30 PM
Last Post: Rocklobster
Rainbow USB3 Detection Issues When Booting Without USB Device Attached Dargmuesli 0 1,340 01-14-2019, 11:26 AM
Last Post: Dargmuesli
  Rock64 - can not connect via store's USB-to-serial nor see (if) booting. jovval 5 3,420 09-06-2018, 07:06 AM
Last Post: jovval
  Tutorial How to write a image in the eMMc card without USB adaptor or serial cable gedas07 2 2,576 08-29-2018, 10:08 AM
Last Post: gedas07
  If you've messed up your eMMC Card - Solved gregb49 11 11,063 07-11-2018, 02:08 PM
Last Post: gregb49
Question LoadTrustBL error when booting pedroz 0 1,071 02-09-2018, 08:35 AM
Last Post: pedroz
  Help with a MicroSD card problem on Rock 64 Jakr 6 5,442 08-13-2017, 03:31 PM
Last Post: jl_678

Forum Jump:


Users browsing this thread: 1 Guest(s)