Enabling secure boot
#1
Hi

I am trying to enable secure boot on Rockpro64, but I cannot burn eFUSEs.

According to RockChip documentation I need to supply 1.8V to EFUSE_VQPS pin,
on Rockpro64 this is handled by setting EFUSE_VQPS_EN_H pin to high, but datasheet
does not mention where this pin is connected.

  1. Has anyone tried enabling secure boot on this board before?
  2. Where is EFUSE_VQPS_EN_H connected?
  3. Where can I find component layout? I have found only board top layout, but I need bottom side.
  Reply
#2
(10-26-2021, 04:13 AM)arturkow Wrote: Hi

I am trying to enable secure boot on Rockpro64, but I cannot burn eFUSEs.

According to RockChip documentation I need to supply 1.8V to EFUSE_VQPS pin,
on Rockpro64 this is handled by setting EFUSE_VQPS_EN_H pin to high, but datasheet
does not mention where this pin is connected.

  1. Has anyone tried enabling secure boot on this board before?
  2. Where is EFUSE_VQPS_EN_H connected?
  3. Where can I find component layout? I have found only board top layout, but I need bottom side.

Please note that burning eFUSE will void warranty by default.
  Reply
#3
(10-26-2021, 12:11 PM)tllim Wrote:
(10-26-2021, 04:13 AM)arturkow Wrote: Hi

I am trying to enable secure boot on Rockpro64, but I cannot burn eFUSEs.

According to RockChip documentation I need to supply 1.8V to EFUSE_VQPS pin,
on Rockpro64 this is handled by setting EFUSE_VQPS_EN_H pin to high, but datasheet
does not mention where this pin is connected.

  1. Has anyone tried enabling secure boot on this board before?
  2. Where is EFUSE_VQPS_EN_H connected?
  3. Where can I find component layout? I have found only board top layout, but I need bottom side.

Please note that burning eFUSE will void warranty by default.

That is not a problem.
  Reply
#4
My board version is v2.1.
  Reply
#5
@tllim Could you provide me info about location of eFUSE testpoint?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  u-boot locked on pine64pro ljones 1 427 09-06-2022, 10:32 AM
Last Post: ljones
  Cannot get my board to boot deutschlmao 11 4,106 09-05-2022, 04:23 PM
Last Post: ljones
  U-BOOT Tutorial hazz 0 468 07-19-2022, 10:48 PM
Last Post: hazz
  Installation Debian on emmc: which U-Boot and where? vongillus 3 1,153 07-02-2022, 09:24 AM
Last Post: dkebler
  enble boot after power loss/restore dkebler 11 3,599 06-22-2022, 09:39 PM
Last Post: dkebler
  ROCKPRO64 PCI SSD SD-boot Install pspgarret 0 578 06-09-2022, 10:56 AM
Last Post: pspgarret
  RockPro64 has no white led, nor will it boot past... AnjinMeili 2 946 05-31-2022, 09:19 AM
Last Post: Rocklobster
  no boot white led flashing moserwi 3 1,501 03-28-2022, 07:26 PM
Last Post: Rocklobster
  Device unable to boot Lunix33 9 5,257 09-23-2021, 01:38 AM
Last Post: LMM
  Flashed SPI, able to ping RP64 but not boot from sdcard/usb korefuji 2 2,008 08-26-2021, 11:41 AM
Last Post: LMM

Forum Jump:


Users browsing this thread: 1 Guest(s)