Installation Debian on emmc: which U-Boot and where?
#1
Hello,

I bought a rockpro64 2.1 with a 32gb emmc module.

I read different wiki pages and ended up installing U-Boot on the spi.

But even if U-Boot works and I could finish the Debian install on emmc (which I did before installing U-Boot), everytime I boot it seems like it doesn't detect anymore emmc. It's says:

Card did not respond to voltage select! : -110

Ok then I thought it's a wrong version of U-Boot so I installed towboot.

But I get the same error.

Any idea what I am doing wrong there?

Thanks
  Reply
#2
try connecting pins 23-25 per the wiki (will bypass spi) and boot sd/emmc with u-boot

Have you tried booting from an sd card? another emmc.
  Reply
#3
(06-18-2022, 08:28 AM)dkebler Wrote: try connecting pins 23-25 per the wiki  (will bypass spi) and boot sd/emmc with u-boot

Have you tried booting from an sd card?  another emmc.

Thanks for your answer. No I didn't try yet to boot an OS from the sd card. I just booted with the sd card to install the OS. I can install an u-boot to the spi and also erase it. What you suggest is to install u-boot on emmc instead of spi right? Do you have any link for this?

Thanks again
  Reply
#4
Here is what I do with a new board. 

0. burn erase and flash disk images to a couple sd cards.  https://github.com/sigmaris/u-boot/releases  (these are not the latest but latest compiled)
1. Jump pin 23-25
2. put erase sd in and boot (have a monitor plugged in and confirm that the spi flash was erased)
3. Now put the sd "flash" one in, as soon as the the board starts to boot from sd card remove the jump (or the flashing won't work). Again confirm that the flashing was completed.  Any errors or message that 0 bytes were flashed means it failed.  It must succeed.
4.  Now you can remove the jumper completely
5.  Now burn an os image to and sd card or emmc.
6.  Put that in and power up and you are on your way.

**Note:** Some of the rockrpo64 boards have a "hardware" bug which is they wont "reset" until the power as been off for about 60 secs.  So if it just sits there and does nothing then unplug from power for at least 60 seconds.  See my and other's posts about this on the forum.  https://forum.pine64.org/showthread.php?tid=16151

# OS Images

The best way to get an image on emmc is not to boot from sd card and xfer but to get a usb-emmc adapter (available from pin64) and put your os image directly on it using your primary computer. 
I have a number of bad emmc cards. They go bad and burning another image on them doesn't fix them. Always try another (new) one if having boot only from emmc issues.

armbian (ubuntu or debian, cli or desktop)
https://www.armbian.com/rockpro64/

dietpi  (debian cli only)
https://dietpi.com/

manjaro (desktop only) - https://github.com/manjaro-arm/rockpro64...s/releases  - I haven't tried these put they look good for desktop install and may have kernel support for the dsi/touch
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  U-BOOT Tutorial hazz 0 109 07-19-2022, 10:48 PM
Last Post: hazz
  enble boot after power loss/restore dkebler 11 1,580 06-22-2022, 09:39 PM
Last Post: dkebler
  ROCKPRO64 PCI SSD SD-boot Install pspgarret 0 203 06-09-2022, 10:56 AM
Last Post: pspgarret
  RockPro64 has no white led, nor will it boot past... AnjinMeili 2 313 05-31-2022, 09:19 AM
Last Post: Rocklobster
  RockPro64 Debian xrdb -- problem connecting emarsh 0 227 05-19-2022, 09:55 AM
Last Post: emarsh
  Flash to eMMC? Barugon 4 627 04-27-2022, 03:10 PM
Last Post: Barugon
  no boot white led flashing moserwi 3 770 03-28-2022, 07:26 PM
Last Post: Rocklobster
  Cannot get my board to boot deutschlmao 10 2,040 03-19-2022, 07:45 PM
Last Post: Rocklobster
  Enabling secure boot arturkow 4 1,386 11-25-2021, 04:57 AM
Last Post: arturkow
  rockpro64 emmc GreyLinux 8 3,169 11-08-2021, 01:56 PM
Last Post: GreyLinux

Forum Jump:


Users browsing this thread: 1 Guest(s)