Modem suddenly not enabled when booting from eMMC
#1
This is kind of strange...

Earlier this morning I used my Pinephone, made a call with no problem. (That's booted off the eMMC with Mobian bookworm and updates as of a few days ago.) Then I turned the phone off since it's only powered up when needed.

Several hours later, this afternoon I booted the phone up to make another call but the cellular indicator in the upper left of the screen had the line drawn through it, and there was no service. As a test, running "mmcli -m 0 --messaging-list-sms" resulted in the message "error: modem not enabled yet". Reseating the SIM in its slot had no effect, and neither did installing current updates as of today.

However, booting up on my "known to work" SD card (Mobian bookworm with updates as of a few weeks ago) brings the modem back online and calls can be made. Using mmcli to check for SMS messages results in "No sms messages were found", as expected.

I do have a few working eMMC images made over the last several weeks so I can try restoring one of those to eMMC. Before taking that hatchet approach, any ideas what's going on here?


[Image: vZg9pmcI_o.jpg]
  Reply
#2
Today I exercised the "nuclear option" and restored my eMMC image backup from October 3rd to my Pinephone. Boots up fine from eMMC now and modem is online. Not sure what happened, but I probably will avoid doing updates for a while.

Speaking of which, how can I turn off automatic checking for updates and the associated popup message? I always run updates from the command line anyway.
  Reply
#3
(10-22-2021, 12:17 PM)Zebulon Walton Wrote: Speaking of which, how can I turn off automatic checking for updates and the associated popup message? I always run updates from the command line anyway.

PackageKit is responsible for that. You can turn off and mask its service, so it won't get activated again by something else at some point:
Code:
sudo systemctl stop packagekit.service
sudo systemctl disable packagekit.service
sudo systemctl mask packagekit.service
You can also remove gnome-software altogether, it's probably the only package depending on PackageKit.

If you still want to use gnome-software, you should be able to disable automatic updates with this change in the dconf database (haven't tried it myself):
Code:
gsettings set org.gnome.software download-updates false
  Reply
#4
Thanks, I'll give that a try!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Mobian virtual keyboard suddenly buggy HLing 1 272 04-22-2022, 01:21 PM
Last Post: HLing
  Phosh modem on/off effectiveness? Zebulon Walton 0 319 01-24-2022, 09:21 AM
Last Post: Zebulon Walton
  Suddenly, nothing but a backlight and a boot logo flash 3x5co 8 929 12-05-2021, 08:24 PM
Last Post: Anna
  Phone suddenly unusable TRS-80 6 824 11-19-2021, 09:46 AM
Last Post: TRS-80
  Wi-Fi adapter suddenly gone missing Zebulon Walton 1 587 11-15-2021, 05:20 PM
Last Post: Zebulon Walton
  More weirdness when booting from eMMC Zebulon Walton 2 772 10-27-2021, 07:06 PM
Last Post: Zebulon Walton
  Cell modem mmd604 12 3,532 10-03-2021, 08:43 PM
Last Post: calinb
  Using the "Modem Manager GUI" bcnaz 0 783 08-02-2021, 06:49 PM
Last Post: bcnaz
  Reboot Modem on Pinephone in Mobian eggmatters 5 3,479 06-17-2021, 02:08 PM
Last Post: eggmatters
  Pinephone not receiving SMS. SMS not showing on modem either. norbear 4 3,038 03-27-2021, 11:43 AM
Last Post: norbear

Forum Jump:


Users browsing this thread: 1 Guest(s)