scp.bin not found, can't complete apt upgrade
#1
I'm running Bookworm on my community edition Pinephone.

For the past couple weeks, every time I've tried a "sudo apt upgrade", it errors out with the error that it can't find /etc/lib/scp.bin.
I've tried running the Software app, it can't download the updates, complains of missing dependencies (but doesn't say what they are),

and now when I try to run apt update, it 404 errors on trixie-security and trixie-updates, then says there's no release file for trixie-security and trixie-updates, therefore they can't be updated securely and are disabled.

I tried sudo apt-get clean followed by sudo apt-get check followed by sudo apt-get -f install

after that it listed some packages that could be removed and then said 0 updated, 0 newly installed, 18 to remove, 380 to upgrade.

so I tried autoremove and got the original error:
md5sum: /usr/lib/crust/scp.bin: no such file or directory
And then I get two errors when the script tries to run scp.bin

Does anyone have any clue what is happening and what I need to do to fix it? Do I have to do a complete re-install? Sad
  Reply
#2
So I've been dinking around ignorantly and discovered something...
whatever script apt upgrade calls runs a script which does
md5sum /usr/lib/crust/scp.bin
which errors our.
/usr/lib/crust on my machine is a symbolic link to the *file* /usr/lib/crust-firmware/pinephone
I'm guessing it should be a symbolic link to /usr/lib/crust-firmware and/or /usr/lib/crust/scp.bin should be a symbolic link to /usr/lib/crust-firmware/pinephone.

I'm not experienced or knowledgeable enough to fix this, however Sad

I seem to have fixed it.
I cded to /usr/lib/crust-firmware
then "cp pinephone scp.bin"
then I unlinked the symlink from /usr/lib/crust
"unlink /usr/lib/crust"
then I linked the directory to the directory
"ln -s /usr/lib/crust-firmware /usr/lib/crust"

Then I did a sudo apt upgrade and the upgrade appears to be proceeding
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  GPS/location services don't work with Maps after Bookworm upgrade Anna 9 2,401 05-26-2022, 03:18 AM
Last Post: biketool
  Firmware upgrade via fwupd user641 3 841 04-24-2022, 11:01 AM
Last Post: yehudac
  Epiphany browser broken after webkit packages upgrade user641 0 119 04-15-2022, 05:20 AM
Last Post: user641
  upgrade results Dinosaur1946 1 407 01-18-2022, 04:47 AM
Last Post: kqlnut
  Cant update and upgrade mobian. mode80 8 3,492 01-06-2022, 04:19 PM
Last Post: bcnaz
  When I set SD card as /home, PP can't complete boot nelstomlinson 4 817 12-27-2021, 03:06 PM
Last Post: nelstomlinson
  wifi adapter not found.. why? b7l3wui26r 3 374 11-29-2021, 10:28 AM
Last Post: beta-user
  Help request: upgrade failed, locked out at decryption passphrase tiikeri 7 1,468 11-27-2021, 07:29 AM
Last Post: zetabeta
  Mobian kernel upgrade user641 4 1,415 11-10-2021, 01:22 PM
Last Post: user641
  Safe to upgrade Bookworm again? nelstomlinson 2 1,079 10-12-2021, 03:45 AM
Last Post: bcnaz

Forum Jump:


Users browsing this thread: 1 Guest(s)