console on SOEDGE Model A Baseboard
#1
I am trying to get the console working on the SOEDGE model A baseboard.

So far:

I have connected 3 different serial console gadgets; 2 with the FT232RL chip and another with the CH340 chip:

Voltage set to 3.3V, Serial port set to 115200 baud, 8N1
GND -> PI-2 GPIO pin 6 (GND on baseboard schematic)
RXD -> PI-2 GPIO pin 8 (UART_TXD on baseboard schematic)
TXD -> PI-2 GPIO pin 10 (UART_RXD on baseboard schematic)

Nothing works.

Pine64 Support Says:


Please inform that the console serial speed setting is 1500000, N, 8, 1. the txd light light keep blinking this means there is console message damping out during SOEdge boot up,  The rxd LED light only light up when there is message send from terminal program to SOEdge.  For further technical questions, please you may post to PINE64 forum or chat room, and the developer there will give you the best advice.

Response:

I have configured the console to 1500000 8N1 in minicom and there is nothing coming from the device.

I have tried it with 2 images available on the wiki (https://wiki.pine64.org/wiki/SOEdge#Linu...e_Releases): "BSP Linux ver 1.1 Build from SDK" and "Factory Test Build". (I burned the images to microsd with balena etcher and inserted them unto the sdcard slot on the baseboard.)

What is the next step to diagnose this? Are one of these images known to work with the SOEDGE baseboard?

FYI The device: https://www.amazon.ca/gp/product/B07BBPX8B8
  Reply
#2
Same experience here with a CH340 unit.  I even tried burning the images to eMMC and still nothing.  I also built images using the SDK, and those were not any different than the ones already available for download.  Any clues would be very much appreciated.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  New to the ecosystem - Bought the SOEDGE MrAnthony 7 483 09-10-2021, 10:06 AM
Last Post: tophneal
  Chickens, Eggs, and SOEdge lewellyn 11 5,656 11-21-2020, 08:13 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)