rock64-debian-mrfixit-190531.img.xz : missing /usr/lib/dri/rockchip_dri.so
#1
Hello !

I have a V3 Rock64. No PSU or HDMI issues : i have XU4, RPI-1, RPI-2, BPI-M5 without problems.

- rock64-debian-mrfixit-190531.img.xz >> SD Card  :  it lags very much, when moving windows with LXDE.
- rock64-debian-mrfixit-190531.img.xz >> mmc Card (Foresee 16 Go) : i can't start X, xorg doesn't find /usr/lib/dri/rockchip_dri.so. Can't find this file on my disk.

- Armbian >> black lines on screen when moving windows in XFCE.
- Armbian >> dashboard moving up an down quickly when i move some windows (ex : PCManFM, but not galculator (?))

- Slackware XFCE : works great, but no dependencies supported by this OS (?).

- Ubuntu : i don't want.

- FreeBSD .img for Rock64 doesn't boot.

What distros work on your V3 board, please ?

Undecided
  Reply
#2
(07-30-2021, 05:20 PM)popi Wrote: Hello !

I have a V3 Rock64. No PSU or HDMI issues : i have XU4, RPI-1, RPI-2, BPI-M5 without problems.

- rock64-debian-mrfixit-190531.img.xz >> SD Card  :  it lags very much, when moving windows with LXDE.
- rock64-debian-mrfixit-190531.img.xz >> mmc Card (Foresee 16 Go) : i can't start X, xorg doesn't find /usr/lib/dri/rockchip_dri.so. Can't find this file on my disk.

- Armbian >> black lines on screen when moving windows in XFCE.
- Armbian >> dashboard moving up an down quickly when i move some windows (ex : PCManFM, but not galculator (?))

Try use this https://github.com/armbian/build/blob/ma.../xfwm4.xml settings for WM. Copy over in your home directory config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml and try again. Or build image from sources.
  Reply
#3
(07-31-2021, 04:23 AM)igorp Wrote: Try use this https://github.com/armbian/build/blob/ma.../xfwm4.xml settings for WM. Copy over in your home directory config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml and try again. Or build image from sources.

Thank you Igorp for your help  Blush

No luck, the black lines are still here, even after having changed the xfwm4.xml file.
This makes windows moving without showing inside, but those black lines..are still here  Angry coming from GPU/or driver (?).
No hope for this board : i have tested DietPi : it shows me on boot "5v error from gpio" messages.
Only slackware XFCE works good... for the moment.
  Reply
#4
Oups ! The Slackware doesn't boot from mmc, than i bought specialy for it  Dodgy

Cool : i have "NO OS" working for my Rock64 V3. Happy.

Undecided
  Reply
#5
How have you confirmed that you have no physical HDMI issues. I assume you have quality HDMI cables and no shorting at the HDMI headers on the board. I bought 5 Rock64 v2 boards and have confirmed that 2 of them have faulty ethernet sockets and 1 has a faulty USB2 socket possibly down to poor soldering. If you have any warranty left on the board I'd return it now.
  Reply
#6
I am pretty sure Armbian works on Rock64, even there is no official support. But you have to build it from sources - there were some important fixed added lately.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  How to update/compile Debian 12.5? Wizardknight 0 41 02-22-2024, 01:09 PM
Last Post: Wizardknight
  Rock64 won't boot dstallmo 0 168 12-27-2023, 10:34 AM
Last Post: dstallmo
  HDMI doesn't work on rock64 Noung1991 1 427 11-21-2023, 08:33 AM
Last Post: as365n4
  Rock64 + Klipper + KlipperScreen Instructions godzilla62 0 409 10-22-2023, 01:52 AM
Last Post: godzilla62
  Rock64 Debian 11 (Bullseye) install problem jbize 15 7,613 10-12-2023, 05:14 PM
Last Post: tpaul
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 133 183,766 10-09-2023, 03:31 AM
Last Post: mara
  arch rock64 does not boot nemnob 0 437 07-09-2023, 03:28 AM
Last Post: nemnob
  RXDP from Win10 to Armbian on Rock64 Transportsicherung 0 491 05-27-2023, 06:11 AM
Last Post: Transportsicherung
  DietPi OS for ROCK64 MichaIng 41 30,814 12-07-2022, 08:22 PM
Last Post: luminosity7
  Using multiple UART's on Rock64. ramprasad 0 850 08-29-2022, 01:22 PM
Last Post: ramprasad

Forum Jump:


Users browsing this thread: 1 Guest(s)