briicked, fix from MASKROM mode?
Hey all,

During trying to flash TwisterOS to my emmc I seemingly have done something wrong, causing my pbp to brick. To my horror I found out that it's also refusing to boot from SD, however MASKROM mode still is working. I tried flipping switch 24 both ways and SD boot refused both cases. I sadly do not have the usb emmc adapter (because I actually won this device Tongue)

Does anybody have an idea how to restore/flash Manjaro or any other distro using MASKROM and rkdevtool? I have a machine with both Win10 and linux (with rkdevtool on both) available for flashing.

Edit: some progress! Using the instructions on the bottom of this page ( ) I have gotten the pbp to the point where the power led will light up green without SD, but with SD still nothing happens.
luckily your pbp isn't really bricked, and can be salvaged/restored.

when you turned off the emmc to boot from SD, did your try pressing the RESET button (28) and trying to boot from SD again?

Have you tried any other live images on your SD?

Once you do get an SD img to boot, flip the emmc switch back and run the commands in this section to bind your emmc again, and be able to edit/write to it:

Possibly Related Threads…
Thread Author Replies Views Last Post
  Need to re-write U-boot from Pinephone pro currently in mass rom mode wolverine1 1 803 10-30-2022, 10:09 AM
Last Post: wdt
  Manjaro ARM new version? And hibernate/ sleep mode regretfulpineuser 0 780 06-20-2022, 02:48 PM
Last Post: regretfulpineuser
  How to get sleep mode without bricking? regretfulpineuser 0 723 06-10-2022, 12:31 AM
Last Post: regretfulpineuser
  cannot boot SD card : "unable to select a mode" alchemist 0 1,928 06-18-2021, 02:03 AM
Last Post: alchemist
  is it possible to get wifi monitor mode on the pbp? BananaPekan 0 1,692 01-17-2021, 01:50 PM
Last Post: BananaPekan

Forum Jump:

Users browsing this thread: 1 Guest(s)