Warning: Boot regression in latest kernels (4.19, 5.10 etc.)
Hi folks,

after installing the latest kernel updates, two of my A64-LTS boxes stopped booting. Interestingly, my A64+ boards (not the LTS variants) were not affected. The issue was that the device did not detect the SD card anymore.

It took me quite a while to figure out what was wrong as reverting back to the old kernel did not help. It seems like the updated DTB files are the issue. Booting the new kernel using the old DTB files works fine. This issue affects both kernels from the stable (!) as well as unstable branches in Debian. The affected kernels in Debian are:

- 4.9.181-1 (2021-03-19)
- 5.10.24-1 (2021-03-19)

However, I suspect that this change might affect other distributions as well since the new DTB files were merged directly into the mainline kernel. I suspect the following commit to be causal for the issue:


Therefore, should you encounter the same issue, switch back to the DTB files from the previous kernel.
The problem seems to be acknowledged upstream and a fix incoming:

Come have a chat in the Pine IRC channel >>
Yes, actually I am directly in touch with upstream and another user who encountered the issue as well. There are various ideas how to fix this, but I suggest to simply use the previous version until the final fix is available.
Thanks for the thread, @kuleszdl !
My pine64lts is now booting as expected with some help from @xalius - first time I saw dtc in action Smile
Strit has pushed an update in the Manjaro kernel with a patch so that the board will work - currently that is in the unstable branch: https://gitlab.manjaro.org/manjaro-arm/p...288e4b9dd2

In case someone has a system that can't boot at the moment but would like to, here is a summary of the great instructions from @xalius on how to adjust the dtb:
# Convert a dtb to text/source with
dtc -I dtb -O dts -o output.dts <input.dtb>

# Locate and change the following line which sets the state of the pin in the output.dts file from:
cd-gpios = <0x23 0x05 0x06 0x01>;
# to:
cd gpios = <0x23 0x05 0x06 0x00>;

# Compile back to dtb:
dtc -I dts -O dtb -o <newdtb>.dtb <input.dts>

You can see in the patch used for the kernel in Manjaro, that this changes the state from LOW (SoPine) to HIGH (Pine64-LTS).
Xalius posted a couple of images of the schematics on the #pine64 channel which outline the same.
# SoPine - Low
cd-gpios = <&pio 5 6 GPIO_ACTIVE_LOW>; /* PF6 /
# Pine64-LTS - High
cd-gpios = <&pio 5 6 GPIO_ACTIVE_HIGH>; / PF6 */

Device: Pinebook Pro 128GB No:246 / MainOS: Manjaro ARM
Godot and Flutter - creating something can be fun with the right tools!
The fix should have already made it into Debian 10 and my fresh installation of Debian 11 was not affected by the issue either - so the workaround should not be required anymore. Marking issue as solved.

Possibly Related Threads…
Thread Author Replies Views Last Post
  LCD not working with Latest Buster chilicon 2 3,274 11-14-2020, 10:53 AM
Last Post: niibee
  No HDMI output on standard Debian install / no boot sagada 2 3,556 09-06-2020, 03:54 AM
Last Post: kuleszdl
  SOPINE Network boot Ninazu 1 2,964 05-11-2020, 12:40 PM
Last Post: lbruno
  Trying to boot archlinux-minimal-sopine-20170708-1.img kris240376 0 2,151 05-25-2018, 10:30 AM
Last Post: kris240376
  Cannot boot into Xenial Mate Jacob5146 4 5,254 04-22-2018, 11:00 AM
Last Post: Jacob5146
  [SOLVED] Boot from SD works, no boot with eMMC gkkpch 4 5,843 11-25-2017, 07:25 PM
Last Post: gkkpch
  PXE boot w/ SPI Flash bourg 2 3,900 09-12-2017, 03:24 AM
Last Post: ayufan
  No boot on any Linux image :/ oxomoxo 2 2,417 08-11-2017, 09:44 AM
Last Post: oxomoxo
  Can not boot from eMMC stephen fleming 2 3,292 06-25-2017, 01:30 PM
Last Post: stephen fleming

Forum Jump:

Users browsing this thread: 1 Guest(s)