Mobian can't see OpenVPN is installed.
#1
I have something I am trying to figure out and haven't been able to. I have a paid VPN service that uses the OpenVPN protocol. I have used it on the Pinephone on Arch and Manjaro but for some reason the eOVPN app cant see Open VPN is installed and up to date in Mobian and won't connect. See attached pictures. See the bottom line in the picture. Left Mobian-Right Arch. Anyone suggest anything?


Attached Files Thumbnail(s)
   
  Reply
#2
(03-10-2021, 01:15 PM)C0ffeeFreak Wrote: I have something I am trying to figure out and haven't been able to. I have a paid VPN service that uses the OpenVPN protocol. I have used it on the Pinephone on Arch and Manjaro but for some reason the eOVPN app cant see Open VPN is installed and up to date in Mobian and won't connect. See attached pictures. See the bottom line in the picture. Left Mobian-Right Arch. Anyone suggest anything?

Hmm, I can't say I ever used the gui eOVPN. Have you tried setting up openVPN through the commandline interface instead? Just try it with one servers openvpn configuration, to rule out if its the app or something else.

Sorry can't be anymore useful :/
  Reply
#3
(03-10-2021, 05:06 PM)theD0ctor Wrote:
(03-10-2021, 01:15 PM)C0ffeeFreak Wrote: I have something I am trying to figure out and haven't been able to. I have a paid VPN service that uses the OpenVPN protocol. I have used it on the Pinephone on Arch and Manjaro but for some reason the eOVPN app cant see Open VPN is installed and up to date in Mobian and won't connect. See attached pictures. See the bottom line in the picture. Left Mobian-Right Arch. Anyone suggest anything?

Hmm, I can't say I ever used the gui eOVPN. Have you tried setting up openVPN through the command line interface instead? Just try it with one servers openvpn configuration, to rule out if its the app or something else.

Sorry can't be anymore useful :/
Thanks for the suggestion anyway. Yes it works through the command line but that's not a practical solution without being attached to a monitor, keyboard. When I need a a VPN I am usually traveling. Needs to work through the GUI in the long term but for now I am using the Proton VPN GUI which uses another protocol. It's the free version of their VPN and slow but a temporary fix till I can figure out.
  Reply
#4
Native or flatpak? The readme mentions the '--debug [LEVEL]' command line option or an environment variable to set, which is easy for a native install but I don't know how it works for flatpak.
https://github.com/jkotra/eOVPN
The code getting the version is here:
https://github.com/jkotra/eOVPN/blob/mas...openvpn.py
See get_version(self) at line 172. It's trying to run 'openvpn --version' and find the version in the output using a regular expression. Is it unable to run the command (no openvpn in the path, sandboxing preventing it running, something else?) or does the response not contain a matching string? Or is there some other problem like a missing python library that's getting hidden by error trapping?
  Reply
#5
(03-11-2021, 06:56 AM)wibble Wrote: Native or flatpak? The readme mentions the '--debug [LEVEL]' command line option or an environment variable to set, which is easy for a native install but I don't know how it works for flatpak.
https://github.com/jkotra/eOVPN
The code getting the version is here:
https://github.com/jkotra/eOVPN/blob/mas...openvpn.py
See get_version(self) at line 172. It's trying to run 'openvpn --version' and find the version in the output using a regular expression. Is it unable to run the command (no openvpn in the path, sandboxing preventing it running, something else?) or does the response not contain a matching string? Or is there some other problem like a missing python library that's getting hidden by error trapping?
Thanks, I have been through all the debugging. No joy. I gave up.  I purchased a subscription to ProtonVPN for a year to use on the Pinephone when I am running Mobian. That app is fairly new. I will pass that bug on to the developer and let him see if he can figure it out. Somehow the file system must be different although I couldn't find it or something is missing in Mobian. There are files for OpenVpn everywhere throughout the system.
  Reply
#6
Hi @C0ffeeFreak 

from v0.20, eOVPN supports NetworkManager. for this to work, make sure you are using NetworkManager and has openvpn plugin installed.

Code:
sudo apt install network-manager-openvpn
sudo apt install network-manager-openvpn-gnome

then install eOVPN flaptak with --user option.

Code:
flatpak install --user flathub com.github.jkotra.eovpn
  Reply
#7
(03-11-2021, 08:36 PM)C0ffeeFreak Wrote:
(03-11-2021, 06:56 AM)wibble Wrote: Native or flatpak? The readme mentions the '--debug [LEVEL]' command line option or an environment variable to set, which is easy for a native install but I don't know how it works for flatpak.
https://github.com/jkotra/eOVPN
The code getting the version is here:
https://github.com/jkotra/eOVPN/blob/mas...openvpn.py
See get_version(self) at line 172. It's trying to run 'openvpn --version' and find the version in the output using a regular expression. Is it unable to run the command (no openvpn in the path, sandboxing preventing it running, something else?) or does the response not contain a matching string? Or is there some other problem like a missing python library that's getting hidden by error trapping?
Thanks, I have been through all the debugging. No joy. I gave up.  I purchased a subscription to ProtonVPN for a year to use on the Pinephone when I am running Mobian. That app is fairly new. I will pass that bug on to the developer and let him see if he can figure it out. Somehow the file system must be different although I couldn't find it or something is missing in Mobian. There are files for OpenVpn everywhere throughout the system.

C0ffeeFreak: Did you install the ProtonVPN app? I tried, but my ethernet connection broke just after the repository install. I didn't even get to the main app install. I tried to disable the kill switch, but it did not recognize the command since the main app was not installed yet. I deleted everything and my ethernet connection came back up. I have the new Bookworm edition of Mobian, but I have tried it on the previous version with the same results. Thanks for any advice.
  Reply
#8
(10-03-2021, 04:10 PM)county93 Wrote:
(03-11-2021, 08:36 PM)C0ffeeFreak Wrote:
(03-11-2021, 06:56 AM)wibble Wrote: Native or flatpak? The readme mentions the '--debug [LEVEL]' command line option or an environment variable to set, which is easy for a native install but I don't know how it works for flatpak.
https://github.com/jkotra/eOVPN
The code getting the version is here:
https://github.com/jkotra/eOVPN/blob/mas...openvpn.py
See get_version(self) at line 172. It's trying to run 'openvpn --version' and find the version in the output using a regular expression. Is it unable to run the command (no openvpn in the path, sandboxing preventing it running, something else?) or does the response not contain a matching string? Or is there some other problem like a missing python library that's getting hidden by error trapping?
Thanks, I have been through all the debugging. No joy. I gave up.  I purchased a subscription to ProtonVPN for a year to use on the Pinephone when I am running Mobian. That app is fairly new. I will pass that bug on to the developer and let him see if he can figure it out. Somehow the file system must be different although I couldn't find it or something is missing in Mobian. There are files for OpenVpn everywhere throughout the system.

C0ffeeFreak: Did you install the ProtonVPN app? I tried, but my ethernet connection broke just after the repository install. I didn't even get to the main app install. I tried to disable the kill switch, but it did not recognize the command since the main app was not installed yet. I deleted everything and my ethernet connection came back up. I have the new Bookworm edition of Mobian, but I have tried it on the previous version with the same results. Thanks for any advice.

Yes, I installed the app with no problems. It's been a long time ago though.
  Reply
#9
(10-05-2021, 08:29 PM)C0ffeeFreak Wrote:
(10-03-2021, 04:10 PM)county93 Wrote:
(03-11-2021, 08:36 PM)C0ffeeFreak Wrote:
(03-11-2021, 06:56 AM)wibble Wrote: Native or flatpak? The readme mentions the '--debug [LEVEL]' command line option or an environment variable to set, which is easy for a native install but I don't know how it works for flatpak.
https://github.com/jkotra/eOVPN
The code getting the version is here:
https://github.com/jkotra/eOVPN/blob/mas...openvpn.py
See get_version(self) at line 172. It's trying to run 'openvpn --version' and find the version in the output using a regular expression. Is it unable to run the command (no openvpn in the path, sandboxing preventing it running, something else?) or does the response not contain a matching string? Or is there some other problem like a missing python library that's getting hidden by error trapping?
Thanks, I have been through all the debugging. No joy. I gave up.  I purchased a subscription to ProtonVPN for a year to use on the Pinephone when I am running Mobian. That app is fairly new. I will pass that bug on to the developer and let him see if he can figure it out. Somehow the file system must be different although I couldn't find it or something is missing in Mobian. There are files for OpenVpn everywhere throughout the system.

C0ffeeFreak: Did you install the ProtonVPN app? I tried, but my ethernet connection broke just after the repository install. I didn't even get to the main app install. I tried to disable the kill switch, but it did not recognize the command since the main app was not installed yet. I deleted everything and my ethernet connection came back up. I have the new Bookworm edition of Mobian, but I have tried it on the previous version with the same results. Thanks for any advice.

Yes, I installed the app with no problems. It's been a long time ago though.

Ok. Thanks for the reply.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  bookworm vs trixie discussion for mobian in pinephone regular. zetabeta 28 3,930 06-09-2024, 04:39 AM
Last Post: anonymous
  Mobian-Kicksecure? 3460p 0 247 05-26-2024, 02:09 PM
Last Post: 3460p
  atinout binaries for mobian/debian? NeutralGrey 2 378 05-13-2024, 02:42 PM
Last Post: Gumur
  Mobian repository status henrythemouse 16 9,698 04-10-2024, 10:02 AM
Last Post: diederik
  cant verify mobian image at website gnugpg penguins_rule 0 344 03-18-2024, 08:54 PM
Last Post: penguins_rule
  mobian installed to eMMC - how to install tow-boot grump_fiddle_reinstall 6 2,583 11-22-2023, 11:46 AM
Last Post: aLoop100o
  How to check if tow-boot is installed? jojuma 3 1,234 09-29-2023, 11:29 PM
Last Post: tllim
  wwan0 (SIM interface) doesn't work with OpenVPN nickolas 6 2,396 09-05-2023, 11:16 AM
Last Post: nickolas
  What actions needed to keep on mobian testing user641 3 2,029 09-05-2023, 06:44 AM
Last Post: Zebulon Walton
  Mobian boot failed with zstd message after upgrade. Mahgue 0 769 09-01-2023, 11:29 AM
Last Post: Mahgue

Forum Jump:


Users browsing this thread: 1 Guest(s)