Crust weirdness
I tried to installl caffeine today by running `sudo apt install caffeine`. I got this error message:

md5sum: /usr/lib/crust/scp.bin: No such file or directory
E: Sub-process if grep -qE '(u-boot-sunxi|arm-trusted-firmware)'; then touch /tmp/upgrade-uboot; else md5sum /usr/lib/crust/scp.bin > /tmp/crust.md5; fi returned an error code (1)
E: Failure running script if grep -qE '(u-boot-sunxi|arm-trusted-firmware)'; then touch /tmp/upgrade-uboot; else md5sum /usr/lib/crust/scp.bin > /tmp/crust.md5; fi


After this, I couldn't installl anything without getting the same message. So I ran the following:

sudo mkdir /usr/lib/crust/

sudo cp /usr/bin/scp /usr/lib/crust/scp.bin

Now everything works, but this is a hack and I'm not sure what went wrong here, or how to fix it properly. Thoughts?
(12-27-2020, 06:26 PM)3x5co Wrote: Now everything works, but this is a hack and I'm not sure what went wrong here, or how to fix it properly. Thoughts?

Better is to report to whatever distro you're using. It seems like a problem in caffeine package, but there are many possible causes.
In any case, scp.bin stands for "System Control Processor", and you've copied scp wich is verly likely the the "secure copy" binary. I don't believe it to be a problem unless you install kernel/uboot via package manager, but is much better to get the righ file. If that is a debian based distro you can also "solve" the problem by editing a proper file under /var/lib/dpkg/info (or something similar) although that fix will dissapear if you reinstall caffeine
Maybe a slightly better hack -- manually fetch the crust-firmware package (, install it with sudo dpkg -i, then sudo ln -s /usr/lib/crust-firmware/pinephone /usr/lib/crust

This "fixed" the issue for me. I encountered it after a dist-upgrade, nothing to do with the caffeine package.

Better solution: remove the file /etc/apt/apt.conf.d/99-pinephone-uboot
I don't know how well my solution will work, but I have apt upgrading going on right now, so...

The problem appears to be that /usr/lib/crust (as a directory) is symlinked to the file /usr/lib/crust-firmware/pinephone
Where I think it's supposed to be symlinked to the directory /usr/lib/crust-firmware

I seem to have fixed it.
I cded to /usr/lib/crust-firmware
then "cp pinephone scp.bin"
then I unlinked the symlink from /usr/lib/crust
"unlink /usr/lib/crust"
then I linked the directory to the directory
"ln -s /usr/lib/crust-firmware /usr/lib/crust"

Then I did a sudo apt upgrade and the upgrade appears to be proceeding

Possibly Related Threads…
Thread Author Replies Views Last Post
  Mobian and Deep Sleep Crust some_pinephone_user 1 1,383 11-14-2021, 07:05 AM
Last Post: some_pinephone_user
  More weirdness when booting from eMMC Zebulon Walton 2 1,258 10-27-2021, 07:06 PM
Last Post: Zebulon Walton
  CRUST power management on Mobian 0x070 6 7,171 07-16-2020, 04:30 AM
Last Post: a-wai

Forum Jump:

Users browsing this thread: 1 Guest(s)