Ubuntu MATE 18.04 Can't boot after update
#1
I've been wrestling this for a couple days now. I need to work with Ubuntu for a particular project so originally tried running the 18.04 image from an SD card. Everything works great at first but I often ran into problems with software update seizing up at a certain point or the system failing to boot again after the patch. I'd reflash the SD card and start over each time, I think 6 or 7 iterations now. Deciding that it may be the SD card that's causing the problem I flashed 18.04 to the MMC drive. That went well. I ran software update and that went well too. However now, once again the system refuses to boot. I am stuck in an endless loop of the screen flashing black and then showing the boot text.

The first time through it was the Bluetooth initialization commands that were last printed. Every subsequent time it is the prompts stating that it is (in order):

Started Bluetooth service
Reached target Bluetooth
Stopped Light Display Manager
Starting Light Display Manager...
Started Light Display Manager.

The text doesn't seem to be updating so I'm not sure if the flashing is the display manager hiccuping or what. Is this a known problem with the 18.04 Ubuntu MATE image? Is there a resolution to it?
#2
I think I've narrowed it down to something getting updated with systemd configurations which is causing the system to lose it's mind. I was able to apply all non-Ubuntu Base updates except the security group. I've been going down each one (dozens of them) and it seems that when the batch for system, service manager and systemd get applied it fails. There is a second batch of much smaller updates which I noticed did reconfigure systemd as well which also caused the same failure. Is this a known problem which isn't documented in the GitHub Issue tracker (I can't find anything about it up there anyway). Is there a solution to prevent this besides not patching the OS?
#3
I'm running into the same issue.  It works fine at first, but hangs after the update.  The first update was via the GUI.  I reinstalled and tried updating from the command line (all previous versions of files kept IIRC), but the same thing happened.

The last flashing message seems to change with each boot.

I have Ubuntu Mate on an SD card.


Possibly Related Threads…
Thread Author Replies Views Last Post
Question Debian (Vanilla) no output on display after Kernel update (6.0.8-1) as365n4 0 66 11-25-2022, 08:28 AM
Last Post: as365n4
  WiFi stopped on Pinebook Pro after update tkudog 3 327 11-24-2022, 04:32 PM
Last Post: tkudog
  Tow Boot install help Paulie420 7 617 11-24-2022, 10:24 AM
Last Post: myself600
  Resume from suspend not working after flashing Tow-Boot to SPI xp19375 3 243 10-31-2022, 10:14 AM
Last Post: wdt
  Bootloader: SD card boot quirks crazyquark 1 276 10-04-2022, 12:27 PM
Last Post: elitegamercody
  Manjaro update: wxgtk dependency issue Vinay 5 543 09-09-2022, 12:03 PM
Last Post: Vinay
  Error trying to update Manjaro software boosterh 5 683 08-31-2022, 10:28 PM
Last Post: shulamy
  Manjaro Gnome 22.06 pamac update fail/soft-bricked-OS u974615 5 552 08-21-2022, 12:00 PM
Last Post: u974615
  Fresh Manjaro does not boot from eMMC pentamassiv 7 2,185 08-18-2022, 11:47 AM
Last Post: Bemo
  Manjaro PBP stable update 2022-06-19 bricked wpeckham 2 707 06-30-2022, 10:03 PM
Last Post: wangyukunshan

Forum Jump:


Users browsing this thread: 1 Guest(s)