Wifi/BT interface not detected
#11
(12-05-2020, 10:45 AM)hiimtye Wrote: the BT/Wifi module is held on the board by a coaxial cable with no locking mechanism, have you verified that it hasn't simply become detached from the main board?
@hiimtye - Sorry for quite delayed response, I was using the phone with just mobile data. Today got some time, I have ripped open the phone. I have attached pic of the main board, all cables appear fine. Which co-axial are you referring here?


Attached Files Thumbnail(s)
   
  Reply
#12
the cable that goes past the battery on the side
  Reply
#13
(01-14-2021, 10:31 PM)hiimtye Wrote: the cable that goes past the battery on the side

It appears fine. The wifi module is present on the main board right and not on PINEPHONE USB-C SIDE BOARD (chip which is at the bottom of the phone near the speaker) ?
If the wifi chip is dead, replacing the main board will help right to get the wifi working?
  Reply
#14
Hi!

I just realize, this thread might well be caused by the same issue as I have:
https://forum.pine64.org/showthread.php?tid=12745

I have made numerous tests, tried a number of OSes and versions etc (you can read the story). The thing is, I have asked the support for advice as I try to understand if the RTL8723CS has its own firmware that should be-reflashed (I consider the chip is just in a bricked state). The EG25 you *can* re-flash (see https://github.com/Biktorgj/quectel_eg25_recovery ) and possibly there is a way for RTL8723CS as well? However, the support seem to have no idea what I am talking about. So, have you by any chance know *if* the RTL8723CS has a flashable firmware and if so, do you know how to re-flash it? I would be grateful for any such advice!
  Reply
#15
(02-06-2021, 05:27 AM)frimmel Wrote: Hi!

I just realize, this thread might well be caused by the same issue as I have:
https://forum.pine64.org/showthread.php?tid=12745

I have made numerous tests, tried a number of OSes and versions etc (you can read the story). The thing is, I have asked the support for advice as I try to understand if the RTL8723CS has its own firmware that should be-reflashed (I consider the chip is just in a bricked state). The EG25 you *can* re-flash (see https://github.com/Biktorgj/quectel_eg25_recovery ) and possibly there is a way for RTL8723CS as well? However, the support seem to have no idea what I am talking about. So, have you by any chance know *if* the RTL8723CS has a flashable firmware and if so, do you know how to re-flash it? I would be grateful for any such advice!

I cannot offer other than "you're not alone" message, but I also bricked wifi/bluetooth on pinetab, and other user reported similar issue recently. As the hardware is quite close, it might be the same issue. In my case, my initial believe was that I just broke something, as I was making some nasty experiments (in particular, pp multi-boot image on the tab). Tried to find a way to re-flash wifi without success, and also tried with a few different firmware packages (didn't work either).
  Reply
#16
(02-06-2021, 05:27 AM)frimmel Wrote: Hi!

I just realize, this thread might well be caused by the same issue as I have:
https://forum.pine64.org/showthread.php?tid=12745

I have made numerous tests, tried a number of OSes and versions etc (you can read the story). The thing is, I have asked the support for advice as I try to understand if the RTL8723CS has its own firmware that should be-reflashed (I consider the chip is just in a bricked state). The EG25 you *can* re-flash (see https://github.com/Biktorgj/quectel_eg25_recovery ) and possibly there is a way for RTL8723CS as well? However, the support seem to have no idea what I am talking about. So, have you by any chance know *if* the RTL8723CS has a flashable firmware and if so, do you know how to re-flash it? I would be grateful for any such advice!
I have been using the ubports edition without wifi for few months now. Just relying on the mobile data. Nothing has helped in fixing the bricked wifi/BT module.
  Reply
#17
The wifi module has no permanent storage for it's firmware, the firmware gets uploaded each time the driver loads...
Come have a chat in the Pine IRC channel >>
  Reply
#18
hi to all, I have the same problem. My wifi and bluetooth module suddenly stop working.
I have tried several different distros and all with the same result, no wifi nor bluetooth. Contacting with sales support did not solved my issue.
They send me to run [url=https://wiki.pine64.org/wiki/PinePhone_Software_Releases#Factory-loaded_Manjaro_build_with_testing_utility][/url]factory loaded Manjaro build with testing utility and the result is

MPU-5060___OK
LIS3MDL____pending
STK3335____pending
RTL8723CS__pending
EG25_______pending
ANX7688____pending
OV5648_____pending
GC2145_____pending
12% of the test en stalled there all the time I've left it(almost an hour an a half)

Please help me to troubleshoot this behavior. Thanks in advance
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Suddenly WiFi signal strength is poor cinix 4 301 09-26-2021, 04:19 PM
Last Post: cinix
  Quectel EG25-G H/W interface - Operating Modes - eg25-manager mouffa 0 526 06-23-2021, 06:57 AM
Last Post: mouffa
  WIFI not available after anx7688 update failure frimmel 21 4,829 05-11-2021, 02:45 AM
Last Post: frimmel
  Not charging, not detected when booting jumpdrive acohl 1 605 03-05-2021, 10:38 PM
Last Post: desca
  modem not detected al_x 1 938 02-13-2021, 04:14 PM
Last Post: dsimic
  SIM not detected rdrowe 3 781 02-10-2021, 08:29 AM
Last Post: rdrowe
Rainbow PinePhone WIFI: PineCone user installable? PineUser-1337331 2 792 01-28-2021, 01:03 PM
Last Post: PineUser-1337331
  Will 5GHz USB wifi adapter work? Zebulon Walton 1 988 12-01-2020, 06:17 PM
Last Post: nas
  wifi not working quininer 3 1,690 10-23-2020, 11:16 PM
Last Post: bcnaz
Question LO Frequency of WiFi Chip DingDangDoong 1 1,032 10-02-2020, 03:10 PM
Last Post: LinAdmin2

Forum Jump:


Users browsing this thread: 1 Guest(s)