[12.11.20 Update] Latest PinePhone CE Manjaro - Device Arrival & Initial Tests Thread
#1
Lightbulb 
Hello everyone,



I was thinking, maybe it is a good idea to encapsulate all of the information for arrival and initial testing of the recently delivered PinePhone CE Manjaro, instead of opening a separate thread for each smaller subject.



I'd first identify which device have I got, and then describe my initial testing and thoughts:



My Device:

PinePhone CE Manjaro Convergence with 32GB eMMC and 3GB of RAM.

I believe it is pre-installed with Manjaro Posh (Update: Reading the paper leaflet that came in the box, my pre-installed Manjaro actually came with Lomiri according the paperwork that came with the device, even though I think the UI looks like Posh).



Delivery notes:
- Ordered on 31.10.2020, received in Europe on 09.11.2020 - pretty damn good I'd say!

- I have received the PinePhone in a small carton box, which held inside of it the actual white box which shows a nice "Pine64 Manjaro" graphic on top of it.

- Inside the box everything was packed carefully.

- What was in the box: the device it self, a charging cable, the Convergence dock, a mini-sim to normal sim (I think?) adapter, and a couple of paper leaflets with instructions / information.



So far my test results using the device right out of the box:



1. Popped up the case cover to remove the battery protection sticker, replace the battery into place and popped the case cover back on the phone.

2. Pressed the power key.

3. Manjaro logo appears on screen, and boots correctly.

4. Device is protected by a default PIN code, which was the factory 123456

5. Went through the initial setup wizard without problems and connected the device to Wifi

6. Could connect to my Wifi network, and browse the internet, Wifi connectivity seem pretty slow (took about 10 seconds to load pine64.org's homepage) - once again, I am not sure if this is an issue? or is the wifi on the device is just slow?

7. Overall the device UI responsiveness seem to run a bit slow when pressing on UI elements (e.g. tap on  Firefox, takes almost 3-4 seconds before it even pops up on the screen), not sure if this is an issue? since this is my first PinePhone, and real linux phone in general.

8. The PinePhone is connected to a charger, currently seem to charge fine (battery indicator was 94% and is currently 95%, so seem to charge)

9. The PinePhone is relatively warm on the top back of the device, not sure if this is normal ? or is it because I am fiddling with the device while it is charging? 

10. Cameras: I have just did a quick general test of the front and back cameras using the pre-installed "Megapixels" app, nothing fancy just wanted to see if the cameras actually function: both cams seem to work, one issue which I did encountered was that when I have switched from the normal cam to the front cam, and then tried to switch again back - the app seem to freeze. 

11. The "Software" app seem to hang on the "Looking for new updates.." screen when trying to look  for new updates ("Updates" tab), the message just hang in there forever - so not clear if it is still looking for something, or just stuck. 







UPDATE #1:

After having the PinePhone right out of the box, connected to a charger, no SIM card in it yet, only connected to Wifi... then and partially fiddling with it but most of the time just letting it lay on my desk, I have noticed something strange - a rather aggressive battery drainage ? about 10 minutes ago the charge indicator on Manjaro indicated a 98% charge, now after the phone has been laying on my desk (without usage), battery charge indicator had dropped and shows 95%, regardless of the device not being used and being constantly connected to a charger. anybody else have noticed battery problems when the device is very lightly used or not being used at all ?


UPDATE #2:

In my first update I wrote about charging issues, I am testing to see now if the problem was the charger block that I have used (my standard apple Iphone charger block), because I have seen that when charging using the apple charger, the status shows on the PinePhone as "Discharging" even when the charger is plugged-in, no idea why.. maybe it is too weak for the PinePhone? I have connected another usb charger which has a little higher charging amperage and suddenly the battery status was changed to "Charging" 

UPDATE #3 (Making / Receiving calls):
SIM Card inserted (was a bit of a hack with the adapter, but at least it help till I will get a duplicate SIM in a "normal" size), 
- I am using a German company (which uses a mix of 3-4 well-known companies depends on where you are, t-mobile, vodafone, o2 etc..).
- The PinePhone was able to identify the SIM and connect to the cellular network 
- I was able to make a call and receive as well.
- The audio sound quality is not crystal clear but not as bad, the voice on the other side can be understood as long as there are not too many background noises, the audio quality could also improve with the time.


** I have not yet tried to send or receive an SMS, I will add an update when I do about my result.


Currently the PinePhone is running updates (including a system update I believe), I will see how it all works out once the updates are complete.



** UPDATE 10.11.2020 **

After the latest update, currently running: 5.9.1-9-MANJARO-ARM

OK Continuing with my testing, after "spending the night" with the PinePhone CE Manjaro on my bed stand, with my SIM card inserted in it:

1. The modem shut down completely after (probably) some time of no usage, when I woke up in the morning I have noticed that when I have turned on the screen both cellular network and Wifi icons showed that they are re-connecting, which means that any usage of modem after the phone has been sitting still is questionable.

2. "Clocks" app: The alarm clock feature does not work - I have made a test, and set a timer to 6:00, it did not wake me up :-) must be some issue with the whole phone going into sleep mode? (Yes, I have tripled check that I set the date,time and timezone correctly on the phone)

3. Battery drainage is a real problem - even after waking up in the morning, and realizing that the cellular modem and Wifi were completely off the whole night, and with the device being constantly connected to a charger, I have still got a 96% charge when turning on the screen first thing in the morning (and tapping on top to slide down the upper toolbar which shows the charge status with %)

4. Remember what I have wrote in my upper portion of the post about the "Software" app being stuck up on the "looking for updates screen" ?
Well, strange enough, after inserting my SIM card and having it identified and connected - the "Software" app suddenly started to work and found a few updates :-) I did the updates, rebooted, and it seem to look like after the updates the overall UI "feels" better, work smoother.. Firefox works much better now! very nice indeed!

5. I was pleased to see the the Desktop app of Telegram functions as good as a mobile app, and that everything connected flawlessly.

6. "Megapixels" app still freeze up the moment you switch cameras twice - but the camera for me is not the highest priority  Wink

** UPDATE 10.11.2020 #2 **
I have noticed something in regarding the the charging of the PinePhone Manjaro CE, maybe this is the reason for why the device is never being able to get a 100% charge ?
- When the device is sited on my desk for long periods of time without being used, it seem to be that the charging procedure is being "detached" or stopped somehow.
  * Because when that happens, every time I press on the power button to turn on the screen, the battery icon shows the normal "battery" state (not charging), then only when I remove the charging cable from the device and plug it immediately back on - only then, the "charging" icon is coming back on.

What I am experiencing is a matter of fact, but the question which I am not able to accurately answer is, is this a hardware issue? or an operating system issue? since I thought that the hardware controls the charging and not the operating system.
 
** UPDATE 11.11.2020 **
1. "Clocks" app - I have tried again to setup an alarm clock for me, at 6:00 in the morning, this time I have woken up earlier to make sure the phone is not in "sleep" mode, I made sure the "Clocks" app is still running after I set my alarm, I configured the alarm to function in all days of the week, all of the configuration was double checked! unfortunately the alarm still does not work!
This is strange, because first I was thinking that because this is a real linux, that when the device is going to sleep mode it prevents the alarm from going off, but this is not the case, because even when the phone is not in idle mode (I made sure to fiddle with it every 5-10 minutes or so), the alarm still does not work.
This is not the most important app, but IMHO it is a very basic functionality, and I have no idea why it does not work? from my side, I am pretty sure that I was using it correctly. maybe a software bug? or something else? I am not sure.
2. "Software" App - I have tested the "Explore" tab and was able to search for all types of software, FYI: the search is not filtered only to mobile-compatible apps, so even software that was never meant to run on a PinePhone will be found and are possible to install. I have installed a few apps for testing: some did not even run, some crushed, other loaded fine but it was clear that those were Desktop-only apps so not usable on a PinePhone.
* As a software developer, I would love to know if there is any resource with information about developing apps for Linux arm, preferably something modern (It's been some time since I have done C programming), best if focused on development for smart devices such as the PinePhone (none of that embedded software type) maybe I could contribute somehow.



** UPDATE 12.11.2020 **

1. "Clocks" app - I have tried the alarm clock feature once again, this time it worked, the alert went of on time and work me up.
Yesterday I had to reboot the PinePhone after (once again!) the lock screen stopped responding, maybe it was that reboot which have settled down some changes in the system, which allowed the "Clocks" app the finally work correctly? no idea, but it is now working as expected.



Please share your own initial tests and insights here if you like, once you get your device (or if you already got it ), maybe we can build here a very useful thread that is focused on the new PinePhone CE release.





In the meantime, I wish a great day to all  Big Grin


Messages In This Thread
[12.11.20 Update] Latest PinePhone CE Manjaro - Device Arrival & Initial Tests Thread - by kern707 - 11-09-2020, 06:12 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Most stable Pinephone OS karcdaeh 13 300 11 hours ago
Last Post: karcdaeh
  PureTalk work with Pinephone? car46999 3 200 12-01-2022, 10:46 PM
Last Post: car46999
  Access Device With Broken MicroUSB Reader _radv_ 5 93 11-30-2022, 01:54 PM
Last Post: _radv_
  no sdcard boot and manjaro update failed Gwen 3 127 11-27-2022, 07:56 AM
Last Post: fxc
  UI crashes after unplugging USB device, seen on multiple OSes; is my hardware broken? slondr 1 247 11-05-2022, 11:31 AM
Last Post: slondr
Exclamation No wIfI after Mobian update crakabeats 3 695 11-03-2022, 04:16 AM
Last Post: wifinoworkie
  Pinephone power consumption figures? girl 5 920 11-01-2022, 09:21 AM
Last Post: tunnelstrong
  SELLING: Pinephone 3GB RAM 32GB ROM gerstavros 12 3,012 10-24-2022, 02:51 PM
Last Post: gerstavros
  Are you using the Pinephone as your daily driver? jro 115 55,963 10-20-2022, 10:19 PM
Last Post: Chief
  Pinephone for sale in Europe tiho 7 2,943 10-19-2022, 05:35 AM
Last Post: peatord

Forum Jump:


Users browsing this thread: 1 Guest(s)