Install postgres
#1
I've tried both the x86 and arm versions I found on the arch-linux wiki and they both gave me an error saying I do not have the correct architecture.  Where can I find a postgres that will work on PBP Manjaro?

Still confused about relationship btw Arch and Manjaro.
#2
AArch64 is the right one.
#3
(10-21-2020, 11:36 AM)Samurai_Crow Wrote: AArch64 is the right one.
I could use more explanation. I downloaded a file from here https://www.postgresql.org/download/linux/#generic

I ran it but then nothing happened but it seems installed. If I type psql it says the DB is not running and there is no UI from which to turn it off or. Are there instructions on how to install it? I can't find anything for arm.

So the way to do it I think, in the off chance anyone else needs this info, is to install it first then go the wiki and follow the instructions. I could not find a one-stop shop.

wiki: https://wiki.archlinux.org/index.php/PostgreSQL
arm: https://archlinuxarm.org/packages/arm/postgresql
#4
ARM is 32-bit ARM. The PineBook Pro is 64-bit ARM which is called AArch64 architecture which isn't compatible with 32 bit Linux.
#5
It installed though, without any errors saying that I was installing the wrong package type. I have failed during installation as it won't start the server, and I cannot delete postgres (to try a reinstall) as it requires a PW which I have not set/does not exist.

Doesn't seem like these would be related to wrong architecture though?
#6
>and I cannot delete postgres (to try a reinstall) as it requires a PW which I have not set/does not exist.
For the package manager?
id ,,, should show you are in sudo group


Possibly Related Threads…
Thread Author Replies Views Last Post
  Use SD to install new OS over pinebook debian Rudy558 9 2,882 06-10-2022, 05:28 AM
Last Post: Zara3344
  microsoft teams install problem jip 3 2,195 02-17-2021, 09:27 AM
Last Post: pagesix1536
  Install TorBrowser on Pinebook pro 2020 edition BananaPekan 0 1,455 07-30-2020, 04:52 AM
Last Post: BananaPekan
  pip and install Jupyter lab jcj52436999 4 4,340 07-17-2020, 07:04 PM
Last Post: carlosqueso
  Need to install 64-bit Ubuntu rhyde 6 4,694 06-20-2020, 07:44 PM
Last Post: rhyde
  Install new OS without USB Adapter for eMMC Module? leonidas 9 6,795 03-05-2020, 02:30 PM
Last Post: PineFan
  Locate and Install OOTB chromium 78.0 Moon1 0 1,158 02-21-2020, 12:17 AM
Last Post: Moon1
  Chrome settings that's with default Debian install FeMike 3 2,955 01-25-2020, 02:17 PM
Last Post: hpc@scale

Forum Jump:


Users browsing this thread: 1 Guest(s)