First time user experiencing weird keyboard issues
Not sure where this post fits, but since I'm a first time user I'll put it here.

I recently received a PineBook Pro.  I am very enthusiastic about this project and would like to get everything up and running well, but I'm worried by some problems I have been having that I've never seen with any other Linux install or computer, and I've installed many.

The biggest worry has been the keyboard.  On first boot, all went well with login and input of requested info.  As suggested, I updated the software on the PineBook Pro.  I rebooted, and after rebooting, all was still well.  After charging, the next time I booted and logged in all went well, but suddenly the keyboard was unresponsive.  I logged out to see if that would fix the problem.  However, I was not able to log back in because the login failed.  I enabled password visibility so I could see what I was typing.  The keys I hit had nothing to do with the letters that appeared.

The first letter I typed did not appear at all.  After that, all letters appeared as CAPS, even though caps lock was not on.  Turning caps lock on resulted in letters being typed in lower case.  However, whether caps lock was enabled or not it was impossible to type any numbers.  The symbols above the numbers was all that appeared. 
Rebooting once, then twice did not solve the issue.  I was unable to login.  Thinking it a lost cause, I shut down the computer.  This morning when I rebooted I could login and all was well.  For awhile....

Then the same issue started repeating itself.  This time I noticed it was mainly an issue of caps or not.  If I typed a letter, I could get caps, but if I kept re-typing it, I would get some lower case letters to appear as well.  At any rate, nothing consistent.  Of course, this makes the PBP essentially unusable, especially when I need to type a password in the terminal and can't see what's being typed!

However, I need a computer that I can rely on.  I take it with me and need to know when I boot I can login without any trouble.  I need to know what this problem was so I can avoid it.  Perhaps I should mention that KWin constantly crashes.  I tried LXQt to see if it might be a KDE issue, but kwin also crashed just as much.  Reinstalling kwin didn't help.

My eventual plan is to remove Manjaro which I have never liked and install another distro, probablly Arch Linux since there is quite a bit of PBP software for it.  My second choice would be Fedora.

Has anyone had this kind of issue?  I really want to be a PBP user but need reliability.

As of this moment of writing, this post has received 149 views but 0 replies.  I didn't expect the problem to be that challenging.  Or maybe I posted in the wrong forum?  Anyway, I'm continuing to have the problem and have been troubleshooting it on my own, so I thought I'd post what I've found.
First, I thought I'd try a different DE than the default KDE to see if the problem might be there.  Tried Gnome, LXQt, Xfce but nothing different. 
Second, I thought to try different operating systems.  I tried Fedora Xfce, Armbian, Arch, and NetBSD booting from a MicroSD.  NetBSD wouldn't boot, but the others booted fine.  But the keyboard problem remained.  With Fedora the problem disappeared for two whole days and I thought the issue might be solved, but it returned and hasn't left.
As for the problem itself, it's very consistent.  When I type I get all caps, as if the caps lock key was on.  If I do turn on the caps lock key I get lower case letters.  I am not able to type numbers except by typing Fn + the number as it is for the numerical pad.  I have not found a way to type a hyphen, -, and the Enter key doesn't work consistently.  Plus occasionally upper and lower case gets mixed.  Not being able to type a hyphen or Enter key makes the terminal pretty unusable for troubleshooting.  An external USB keyboard doesn't solve the problem.
The fact that the problem is consistent, i.e. basically a confusion of the CapsLk keyboard with regular keyboard, and not just typing random characters or something, makes me think a solution might be available.  Perhaps a systemd service was shutdown.  If so, I wonder what that service might be and if it could be re-enabled.  Or perhaps it's a more serious hardware problem.
I am also wondering if trying to re-install the keyboard firmware might help, or installing an alternate keyboard firmware.  If so, any guidance would be appreciated as to how to go about doing this.
And any thoughts at all would be welcome, better than silence at least.
I just received a Pinebook Pro from the latest 2021 batch of the machines, and I have an identical problem to kendrew's keyboard problem.

I can add that occasionally the keyboards (keyboards plural --- USB external keyboards behave with exactly the same symptoms as the laptop keyboard) _do_ function properly. On some reboots the keyboards work normally, and sometimes I can get the keyboard to work normally hammering the caps lock and enter keys for a while. But it does not take long for them to revert to kendrew's behavior.

Via ssh (no problems over ssh of course) I managed to flash the firmware, according to this github repo:

But it did not fix the problem.

It _feels_ like software/firmware thing to me. But if you know what you're talking about and told me it was hardware, I would believe you.

Any ideas?
I also just tried booting Arch off the SD card, and it has the same problem with the keyboard.

That makes me less inclined to believe it's software.

I hate to bother the Pine64 folks with an exchange! Any suggestions would be awesome.
One final data point: I pulled the key caps off the enter and caps lock keys and tried going at the little rubber bumper switches directly. But this moved the problem no closer to resolution.
A final note on resolving this:
I did end up having to get an RMA and send it in to have the keyboard replaced.
(Triple-check your Fn key isn't just stuck before you start thinking you need to do this though!)

When I got the unit back, the keyboard worked correctly.

Unfortunately, after updating Manjaro, it no longer boots from any media. That is almost certainly a different problem, which I'll take up on another thread.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Hello All! New user - 2 basic Quartz64 questions oldschool 2 1,080 12-14-2023, 12:06 AM
Last Post: oldschool
  New User use PineBookPro default OS Manjaro clessard 0 1,625 07-02-2022, 09:01 AM
Last Post: clessard
  Can I use the pinetime as a blind user pranav 1 2,193 06-22-2022, 01:07 PM
Last Post: zer0sig
  Keyboard layout dealie 0 1,556 08-27-2021, 12:55 PM
Last Post: dealie
  Please Help: Bricked Pinebook Pro with Keyboard Update dumbguywhobrokehiscomputer 3 4,128 07-14-2021, 02:49 PM
Last Post: wdt
  RockPro64 ethernet issues: DMA engine initialization failed slowcamp 1 3,130 04-26-2021, 06:03 AM
Last Post: slowcamp
  Pinebook Pro- configuration aborts setting keyboard layout scroall 10 12,539 10-30-2020, 11:58 AM
Last Post: scroall
  First time setup of pro glennngiere 2 4,736 06-07-2020, 04:52 PM
Last Post: xmixahlx
  WiFi issues Pinebook Pro sunnystormy 6 9,204 05-28-2020, 05:44 PM
Last Post: Luke
  A newest user in Pine64 Aliko 1 4,043 04-19-2020, 10:33 PM
Last Post: tllim

Forum Jump:

Users browsing this thread: 1 Guest(s)