1 of 7 SoPINE compute modules not receiving DHCP lease
#1
I recently purchased a clusterboard and 7 compute modules. One of the 7 never retrieves an IP from my DHCP server.

Here's been my process thus far:
  1. Download Arbian 20.08 Buster 5.7.15 (Pine64so version) and unxz the archive.
  2. Mount the image, use dtc and vim to make the necessary modification to the device tree image for networking to work.
  3. Copy the image to a microSD card with dd. (All cards are new and tested with f3. Class A1 cards were selected per the documentation.)
  4. Insert the card in a compute module, insert module into first slot on clusterboard, connect cables.
  5. Wait for my DHCP server to assign a lease.
  6. Create a static IP assignment for the MAC address from the DHCP lease.
  7. SSH to module and complete first login steps (root password, locale, user creation)
  8. Issue shutdown, power off the board, and remove the module.
  9. Repeat 3-8 successfully for five of the six other compute modules.
For one of the modules step 5 seemed to never complete. I have tried:
  • Waiting a very long time (more than 40 minutes; others took less than 5)
  • Reseating the module
  • Reseating the microSD card
  • Re-imaging the microSD card
  • Using a microSD card verified to be working in one of the other modules
  • An nmap scan of my local network (which turned up nothing unexpected)
Things I have not tried:
  • Serial Console debugging. I did not buy one.
  Reply
#2
@ClusterMaker, fixed your post.

Whence you are beyond the initial posting pre-approval limit, (I think 2), you will be able to edit your posts yourself.
--
Arwen Evenstar
Princess of Rivendale
  Reply
#3
In the list of things that you tried, you say that you moved the SD card to another module to test it. Did you also move the module to another slot?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  SOQUARTZ Compute module W does not fit Raspberry Pi CM4 dev board ihab 0 1,623 10-06-2022, 08:46 PM
Last Post: ihab
  Wi-Fi/Bluetooth for PINE64, Model: Sopine A64 lamson 0 1,804 08-24-2021, 08:17 AM
Last Post: lamson
  PSCI, u-boot and reboot on Sopine ClusterBoard hbaxmann 0 2,376 09-03-2019, 11:57 PM
Last Post: hbaxmann
  sopine cluster board install Smurfbot 1 4,478 03-31-2018, 04:09 AM
Last Post: pfeerick
  Sopine A64 doesn't boot ubuntu stixcher 5 7,954 12-03-2017, 11:05 AM
Last Post: tllim
  Turning off RPI GPIO 5v on boot (SOPine) TeknoRapture 1 3,037 03-31-2017, 02:48 PM
Last Post: xalius
  Sopine compatibility with Pi Compute temcocontrols 7 10,883 02-12-2017, 09:28 PM
Last Post: tllim
  Would the SOPINE modules work if they were put into a standard SODIMM RAM slot? Wiooooo 4 6,736 02-05-2017, 02:57 PM
Last Post: MarkHaysHarris777
  red led + cat5 lights but noshow on DHCP list, no video mckenna.tim 1 3,880 01-24-2017, 12:03 PM
Last Post: Luke
  Can I use RaspBerry Pi Modules with the Pine? shivamvahia 1 4,876 04-25-2016, 08:51 AM
Last Post: rahlquist

Forum Jump:


Users browsing this thread: 1 Guest(s)