Pine64 UART4 RTS
#1
Hi,

I'm using a Pine64 with Raspbian and everything is fine.
My project uses the UART4 and as I have a device with very specific and short timing I developped a Linux Line Discipline for that.

Everything is still Ok, but I'm facing an issue (maybe a newbie issue...) I cannot get RTS line (pin18 / PD4) controlled, neither from C from inside ,my line disciple neither from python with PySerial.

BTW, to veryfy I've connected a bitscope to lines Euler2 pins 18-19-21 and I see the signal on pins 19 & 21 (Tx & RX), but desperately nothing on pin 18 (RTS).

Are the RTS/CTS lines activated on the device or should I add an overlay for that? Or at least where to check?
Any clue?


Possibly Related Threads…
Thread Author Replies Views Last Post
Question Any chance to see a mobile-friendly Pine64 forums ? kern707 5 1,386 06-01-2021, 07:45 AM
Last Post: TRS-80
  Mirroring Pine64 software phasewrap 3 708 05-17-2021, 02:29 PM
Last Post: robinjamess
  Recent changes to the Pine64 wiki dsimic 4 794 04-22-2021, 08:01 AM
Last Post: Daniel972
  Thank you Pine64 wholesomedonut 1 369 04-22-2021, 07:51 AM
Last Post: Daniel972
  Pine64 doesn't respect its return and refund policy? EverlyWyatt 3 573 03-02-2021, 04:08 AM
Last Post: xalius
Information Feeling scammed by Pine64 Janik020301 15 4,683 02-14-2021, 09:46 AM
Last Post: WarpLover
  Pine64 should do a line of modular IoT sensors like Grove/STEMMA/Qwiic! EternityForest 1 465 02-08-2021, 09:11 PM
Last Post: tllim
  Pine64 Zoho support site broken anomaly 2 580 02-08-2021, 09:03 PM
Last Post: anomaly
  I think AT&T is blocking pine64.org binarycat 2 598 01-29-2021, 10:27 PM
Last Post: patrickmollohan
  Account delete on Pine64 Forum User 12599 3 2,806 01-06-2021, 09:14 PM
Last Post: moulder

Forum Jump:


Users browsing this thread: 1 Guest(s)