Whats good and working: latest build.
#1
Hi everyone!
Okay so very pleased now. Over the last couple weeks with some tinkering and a few OTA updates much of my Pinephone is working and almost ready to be my daily driver.

The following now work:
Calls
Text
Data
Bluetooth incl. Audio
Gps (although not stable - must be manually initialized through terminal each time, can UBports include this in next update?)

Most of the other glitches i encountered appear to be ironed out.

Looks like camera is the one outstanding thing most people will care for.

What else do i need?
Im sure as a community we will find more things we are missing/need or want, but for where we are and whence we've come, this is pretty great!

2 little things that would be really nice are in-call volume control, although not too critical since i can hear the other party anyway. And if screen brightness could be made to go dimmer too. I find the pinephone screen incredibly bright, even on it's lowest setting. Makes me feel like im going to go blind once the sun sets... A night mode/ blue light filter would be nice too!
#2
Do you have calls working on 4G?

If so, what have you done to get it working? My calls fail on 4G without exception.
#3
(07-30-2020, 10:45 AM)livanti21 Wrote: Do you have calls working on 4G?

If so, what have you done to get it working? My calls fail on 4G without exception.
Yeap. But TBH this one wasn't my tinkering. I was having issues with it too until update 114 which was 2 days ago. Then it started working! Current update is 117 and its good too. If you haven't done an update in 2 days that might get it working for you.

If you already tried that, or if it still doesn't work then it could be the specific 4G band your carrier uses vs the ones the PP currently supports. There's countless, and im not sure if the PP scans the full spectrum, or looks for a few most common ones. If its the latter we gotta wait or maybe encourage the team to get more bands supported.
#4
(07-30-2020, 10:53 AM)Cree Wrote:
(07-30-2020, 10:45 AM)livanti21 Wrote: Do you have calls working on 4G?

If so, what have you done to get it working? My calls fail on 4G without exception.
Yeap. But TBH this one wasn't my tinkering. I was having issues with it too until update 114 which was 2 days ago. Then it started working! Current update is 117 and its good too. If you haven't done an update in 2 days that might get it working for you.

If you already tried that, or if it still doesn't work then it could be the specific 4G band your carrier uses vs the ones the PP currently supports. There's countless, and im not sure if the PP scans the full spectrum, or looks for a few most common ones. If its the latter we gotta wait or maybe encourage the team to get more bands supported.
Interesting. The thing is that 4G calling works on Mobian with no issue for me. I'm US based and on Mint Mobile for the Pinephone but I've had no luck on T-Mobile either. If I switch to 2G/3G then calls work but SMS doesn't work so I'm kind of stuck.

I'll keep messing with it and see what I can come up with. Thanks!
#5
I am using the UBports CE edition in the US. I used the settings that T-Mobile listed on their site for BYOD. The PinePhone automatically set the APN as Fast.t-mobile.com but it did not pick up the MMSC. I tried to manually enter the MMSC but the phone would not save it. I set the phone to 2G/3G/4G and tried selecting the "Internet and MMS" option (phone would not save the Internet and MMS option) and nothing changed. I was not able to make or receive calls.

The texting partially worked (outgoing only) so I assume I was connected to T-Mobile in some capacity. I was not expecting full texting parity since the SIM is tied to my Apple iMessages. The phone settings function locks up on occasion so I have to close the settings and reopen. Is there a swipe or option to go back to the previous screen? In the settings, there does not appear to be a save function or a previous screen option/toggle after making changes. I have tried pressing the "v" in the upper right corner and it does not save the changes.

The first time I placed the SIM in the PinePhone I had received a phone call that went to voicemail and I received a notification on the PinePhone. I was able to listen to the voicemail, but the sound was so low that I could barely hear it, even though the phone volume was turned to max.

Wi-Fi works for me and I was able to use the phone as a hot spot. The phone dial pad sounds do not work after the first initial attempt to make a call after a restart. The time does not appear to be tracking properly. I have already set it and it worked initially but it reset for some reason.
PinePhone UBports CE and Mobian on SD, Mint Mobile, Pinebook Pro Manjaro
#6
(07-30-2020, 03:06 PM)klick Wrote: I am using the UBports CE edition in the US. I used the settings that T-Mobile listed on their site for BYOD. The PinePhone automatically set the APN as Fast.t-mobile.com but it did not pick up the MMSC.  I tried to manually enter the MMSC but the phone would not save it. I set the phone to 2G/3G/4G and tried selecting the "Internet and MMS" option (phone would not save the Internet and MMS option) and nothing changed. I was not able to make or receive calls.

The texting partially worked (outgoing only) so I assume I was connected to T-Mobile in some capacity. I was not expecting full texting parity since the SIM is tied to my Apple iMessages. The phone settings function locks up on occasion so I have to close the settings and reopen. Is there a swipe or option to go back to the previous screen? In the settings, there does not appear to be a save function or a previous screen option/toggle after making changes. I have tried pressing the "v" in the upper right corner and it does not save the changes.

The first time I placed the SIM in the PinePhone I had received a phone call that went to voicemail and I received a notification on the PinePhone. I was able to listen to the voicemail, but the sound was so low that I could barely hear it, even though the phone volume was turned to max.

Wi-Fi works for me and I was able to use the phone as a hot spot. The phone dial pad sounds do not work after the first initial attempt to make a call after a restart.  The time does not appear to be tracking properly. I have already set it and it worked initially but it reset for some reason.
I have also not been able to delete/change/save APN settings no matter what I do. I wonder if that is the cause of the calls issue. Also, is Internet the only option available currently for everybody? Selecting LTE won't save as it always defaults back to internet. Maybe I'm doing something wrong.
#7
(07-30-2020, 04:01 PM)livanti21 Wrote:
(07-30-2020, 03:06 PM)klick Wrote: I am using the UBports CE edition in the US. I used the settings that T-Mobile listed on their site for BYOD. The PinePhone automatically set the APN as Fast.t-mobile.com but it did not pick up the MMSC.  I tried to manually enter the MMSC but the phone would not save it. I set the phone to 2G/3G/4G and tried selecting the "Internet and MMS" option (phone would not save the Internet and MMS option) and nothing changed. I was not able to make or receive calls.

The texting partially worked (outgoing only) so I assume I was connected to T-Mobile in some capacity. I was not expecting full texting parity since the SIM is tied to my Apple iMessages. The phone settings function locks up on occasion so I have to close the settings and reopen. Is there a swipe or option to go back to the previous screen? In the settings, there does not appear to be a save function or a previous screen option/toggle after making changes. I have tried pressing the "v" in the upper right corner and it does not save the changes.

The first time I placed the SIM in the PinePhone I had received a phone call that went to voicemail and I received a notification on the PinePhone. I was able to listen to the voicemail, but the sound was so low that I could barely hear it, even though the phone volume was turned to max.

Wi-Fi works for me and I was able to use the phone as a hot spot. The phone dial pad sounds do not work after the first initial attempt to make a call after a restart.  The time does not appear to be tracking properly. I have already set it and it worked initially but it reset for some reason.
I have also not been able to delete/change/save APN settings no matter what I do. I wonder if that is the cause of the calls issue. Also, is Internet the only option available currently for everybody? Selecting LTE won't save as it always defaults back to internet. Maybe I'm doing something wrong.

You can delete apn settings by swiping right on the name of the APN set. Then a little trash bin icon will appear to the left of the name. Took me a while to figure it out too. Didnt work until i deleted the extra and auto settings and manually entered only one set given by my provider. Then it was perfect

Again, it would not work as long as i had extra APN settings such as mms. More than one set seems to screw it up. You need to just set up the internet APN address manually, leave it and delete the rest. Then you'll get data calls and text. Maybe no mms but you can still get picture messages over data and wifi with the right app.
#8
(07-30-2020, 06:39 PM)Cree Wrote:
(07-30-2020, 04:01 PM)livanti21 Wrote:
(07-30-2020, 03:06 PM)klick Wrote: I am using the UBports CE edition in the US. I used the settings that T-Mobile listed on their site for BYOD. The PinePhone automatically set the APN as Fast.t-mobile.com but it did not pick up the MMSC.  I tried to manually enter the MMSC but the phone would not save it. I set the phone to 2G/3G/4G and tried selecting the "Internet and MMS" option (phone would not save the Internet and MMS option) and nothing changed. I was not able to make or receive calls.

The texting partially worked (outgoing only) so I assume I was connected to T-Mobile in some capacity. I was not expecting full texting parity since the SIM is tied to my Apple iMessages. The phone settings function locks up on occasion so I have to close the settings and reopen. Is there a swipe or option to go back to the previous screen? In the settings, there does not appear to be a save function or a previous screen option/toggle after making changes. I have tried pressing the "v" in the upper right corner and it does not save the changes.

The first time I placed the SIM in the PinePhone I had received a phone call that went to voicemail and I received a notification on the PinePhone. I was able to listen to the voicemail, but the sound was so low that I could barely hear it, even though the phone volume was turned to max.

Wi-Fi works for me and I was able to use the phone as a hot spot. The phone dial pad sounds do not work after the first initial attempt to make a call after a restart.  The time does not appear to be tracking properly. I have already set it and it worked initially but it reset for some reason.
I have also not been able to delete/change/save APN settings no matter what I do. I wonder if that is the cause of the calls issue. Also, is Internet the only option available currently for everybody? Selecting LTE won't save as it always defaults back to internet. Maybe I'm doing something wrong.

You can delete apn settings by swiping right on the name of the APN set. Then a little trash bin icon will appear to the left of the name. Took me a while to figure it out too. Didnt work until i deleted the extra and auto settings and manually entered only one set given by my provider. Then it was perfect

Again, it would not work as long as i had extra APN settings such as mms. More than one set seems to screw it up. You need to just set up the internet APN address manually, leave it and delete the rest. Then you'll get data calls and text. Maybe no mms but you can still get picture messages over data and wifi with the right app.
Thank you for the tip on deleting! I deleted the APN as suggested and tried using both fast.t-mobile.com (for LTE) and the epc.tmobile.com (for non-LTE) and still was unable to make a call. I also checked my IMEI on T-Mobile's site and it stated that the PinePhone was missing the Extended Range LTE and Voice Over LTE functions but it did not mention that the phone would not work at all.
PinePhone UBports CE and Mobian on SD, Mint Mobile, Pinebook Pro Manjaro


Possibly Related Threads…
Thread Author Replies Views Last Post
  UB Touch build with debos layton-dev 0 373 04-23-2021, 08:12 AM
Last Post: layton-dev
  Nextcloud Account setup not working kelbot 3 2,083 04-21-2021, 11:25 AM
Last Post: lsitongia
  UBPorts Not Working Pinoideae 7 2,306 03-13-2021, 01:51 PM
Last Post: KNERD
  Whats the latest with UB touch? Cree 9 3,504 03-11-2021, 10:59 AM
Last Post: andybleaden@gmail.com
  If you're ready to tinker - here is how to get the more features working right now Luke 17 16,841 01-09-2021, 12:14 PM
Last Post: Csanderson0313
  Pinephone 3G Bluetooth Working Pretty Well With Latest Mobian Updates rmcg 0 976 09-27-2020, 10:22 PM
Last Post: rmcg
  No SMS on latest nightly firefox-58 1 1,044 09-15-2020, 04:24 AM
Last Post: Helium75
Question Camera(s) not working? UNi 9 5,772 09-06-2020, 10:45 AM
Last Post: Cree
  Having troubles developing an app for UT, any good tutorials out there? ragreenburg 18 8,149 08-25-2020, 11:23 AM
Last Post: FOSSagent0
  OTA build 150 removed my installed apps. Cree 1 1,158 08-17-2020, 02:32 AM
Last Post: evilbunny

Forum Jump:


Users browsing this thread: 1 Guest(s)