Modem UBports edition Celluar not working
#11
(08-01-2020, 06:38 PM)bcnaz Wrote: Curious,  have you attempted to use the software update feature on Mobian O.S. with the 'firmware updates' checked ?
  Top right corner of the main software page, under preferences ?
    You said your wifi is working  ?   * * *  (  I am not a tech, so my ideas could be mistaken )

 I asked for more information about those choices in another thread,  but I have not got a response to that post yet.

  I am thinking this could likely be a firmware problem....  The Brave Heart seems to be affected more than the Community Editions.???
I took your suggestion.  I had not been running the updates but did so with the 8-2 and 8-3 Mobian nightly builds.  The sim is still not being detected.  Went back and tried it in the newer PostMarketOS factorytest version and same negative result that the sim card was not found.

Apparently, my situation is rather unique or rare in that no one else seems to be experiencing a complete failure of there Braveheart to pass the EC25 factorytest or to detect a working sim card in multiple OS's (UBPorts, Mobian, PureOS, and PostMarketOS).

Dissapointed but if that is the case as evidenced by few if any other reports of this problem with the Braveheart then I guess I'll be relegated to waiting for the new PinePhone with Convergence and hopefully will have much better luck with it since there are several modem related hardware fixes in that V1.2 mainboard revision.

Anyone know when a V1.2 replacement mainboard for the Pinehone might be available in the store for those of us for one reason or another that could use one?
#12
Hey,

 Take a look here  https://bloggerbust.ca/post/install_and_...-the-shell

specifically the section on usim detection
#13
(08-04-2020, 07:09 PM)LazLong Wrote:
(08-01-2020, 06:38 PM)bcnaz Wrote: Curious,  have you attempted to use the software update feature on Mobian O.S. with the 'firmware updates' checked ?
  Top right corner of the main software page, under preferences ?
    You said your wifi is working  ?   * * *  (  I am not a tech, so my ideas could be mistaken )

 I asked for more information about those choices in another thread,  but I have not got a response to that post yet.

  I am thinking this could likely be a firmware problem....  The Brave Heart seems to be affected more than the Community Editions.???
I took your suggestion.  I had not been running the updates but did so with the 8-2 and 8-3 Mobian nightly builds.  The sim is still not being detected.  Went back and tried it in the newer PostMarketOS factorytest version and same negative result that the sim card was not found.

Apparently, my situation is rather unique or rare in that no one else seems to be experiencing a complete failure of there Braveheart to pass the EC25 factorytest or to detect a working sim card in multiple OS's (UBPorts, Mobian, PureOS, and PostMarketOS).

Dissapointed but if that is the case as evidenced by few if any other reports of this problem with the Braveheart then I guess I'll be relegated to waiting for the new PinePhone with Convergence and hopefully will have much better luck with it since there are several modem related hardware fixes in that V1.2 mainboard revision.

Anyone know when a V1.2 replacement mainboard for the Pinehone might be available in the store for those of us for one reason or another that could use one?

  Are you certain of your sim card itself ?

   I am unable to activate a new sim card in my Brave Heart,
but it does work fairly well with the sim card I removed from my Android phone.
#14
(08-05-2020, 01:10 PM)fins Wrote: Hey,

 Take a look here  https://bloggerbust.ca/post/install_and_...-the-shell

specifically the section on usim detection
Thanks!  Will do!  Much appreciated.

I have ran across a couple other sources of information on the modem but have not had the time to delve into the particulars including
a few pdfs including this one:

https://www.quectel.com/UploadImage/Down...l_V1.3.pdf

Quectel.com also has some scattered information including references to EC25 and flashing/updating firmware

      https://forums.quectel.com/t/ec25-flash-...error/5214

In addition some possibly interesting stuff at osmocom.org I have barely looked at osmocom.org including:

      https://projects.osmocom.org/projects/qu.../wiki/EC25

Most of the information seems a few years old but is surely for the most part relevant.

Thank you again.

(08-05-2020, 05:21 PM)bcnaz Wrote:
(08-04-2020, 07:09 PM)LazLong Wrote:
(08-01-2020, 06:38 PM)bcnaz Wrote: Curious,  have you attempted to use the software update feature on Mobian O.S. with the 'firmware updates' checked ?
  Top right corner of the main software page, under preferences ?
    You said your wifi is working  ?   * * *  (  I am not a tech, so my ideas could be mistaken )

 I asked for more information about those choices in another thread,  but I have not got a response to that post yet.

  I am thinking this could likely be a firmware problem....  The Brave Heart seems to be affected more than the Community Editions.???
I took your suggestion.  I had not been running the updates but did so with the 8-2 and 8-3 Mobian nightly builds.  The sim is still not being detected.  Went back and tried it in the newer PostMarketOS factorytest version and same negative result that the sim card was not found.

Apparently, my situation is rather unique or rare in that no one else seems to be experiencing a complete failure of there Braveheart to pass the EC25 factorytest or to detect a working sim card in multiple OS's (UBPorts, Mobian, PureOS, and PostMarketOS).

Dissapointed but if that is the case as evidenced by few if any other reports of this problem with the Braveheart then I guess I'll be relegated to waiting for the new PinePhone with Convergence and hopefully will have much better luck with it since there are several modem related hardware fixes in that V1.2 mainboard revision.

Anyone know when a V1.2 replacement mainboard for the Pinehone might be available in the store for those of us for one reason or another that could use one?

  Are you certain of your sim card itself ?

   I am unable to activate a new sim card in my Brave Heart,
but it does work fairly well with the sim card I removed from my Android phone.

===========================

I hear you bcnaz.  Thank you for your thoughts and relating your experience.

I did not expect to be able to necessarily activate a new sim with the BH and that turned out to be the case.  After activating a couple sims on an android phone (from carriers that folks have reported good results including AT&T) the sim cards have been missing in action on the BH.  Both sims work fine and seamlessly in an iPhone as well.

Hope it is not the case but I suppose the BH may be inordinately finicky with sim cards.

I am leaning to a hardware or firmware problem so if cannot wake the thing up with some AT commands or scripts as time allows am going to pursue trying to flash the modem.

If anyone has had luck flashing the EC25 would appreciate hearing your methods used and any advice.  I and the BH are a work in progress.  Ha!   
#15
Sorry you are having such disappointing results.
TLlim said in a recent thread the 1.2 revision boards should be in the store in the 4th quarter of this year.
That sounds like a long wait.
I try to look for the simplest answers first, but sometimes that is not the cure.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
#16
Any updates on this issue? Ive tried a newer image from UBports and still nothing. Im not sure what to do at this point. I wonder if the adapter and the size of sim card might be another factor as well.
#17
@LazLong
 
Is there any chance you have a "LOCKED"  sim card  ?

I remember seeing some posts regarding that problem, it seems the Pine phone cannot function with a locked sim... and the Pine phone cannot unlock them ether.
  If I remember correctly that forum member was able to unlock his sim in a Android phone, then it worked in his Pine phone.

Also any chance of "trying" a different sim card ?

I am now using Mobian August 10 nightly release, flashed to an SD card in my Brave Heart edition with most functions working.
   I am using AT&T Prepaid sim card.

Good Luck !
#18
Question 
For my issue my SIM card is not locked, its not a new SIM card, I did think of getting a new sim card to replace it and see if that would fix it. It does have a few scuffs and its probably over 3 or 4 years old.  I did confirm that it was not locked by calling up T-mobile and later placing it in a other android phone that was laying around, which did get reception and network detection quickly too.

I got no help  from Pine64 when I asked I got such a poor anwser that makes me even more skeptical of them.

Hello XXXXXXXXXXXX

Please check out this wiki link for service provider question: https://wiki.pine64.org/index.php?title=PinePhone#Modem_and_Carrier_Support
If you have both Wifi and Modem fail when perform hardware test, it means that you forget to take out the plastic tab locates at battery connector.

Both Wifi and MODEM withdraw power directly from battery and please make sure your battery is fully charge.


Your understanding and patience is greatly appreciated.

support team#2...


Below my original message to them. I even opened a issue ticket with them.

Quote:I have pre-ordered my Pinephone back in April and upon the first day of receiving it I noticed that I had issues with no cellular reception or any connectivity. I over the course of time tried updating, using another os called Mobian and neither of those had working celluar. I noticed when troubleshooting that some of your users mentioning firmware corruption on the cellular modem on the Pinephones. Since I received it around July I have spent time on my phone and now it appears that my phone may be affected by that firmware corruption mentioned in the Pinephone forums. As of right now this cannot function as a phone.

What will Pine do about this issue? Will there be returns, fixes or updates for this? The Phone is a UBports Community Edition.


I don't want to rip on them but that answer just does not help their cause.


Anyway I have been trying Mobian and Ubports and my celluar issue is not fixed.
#19
@FOSSagent0
Sorry for your problems,
I did suspect modem problems with my Brave Heart phone, as for a few weeks there I was experiencing some similar problems.
But now my phone is operating fairly well.
Since these phones are all built almost identical, it should make sense that the fixes would be the same ?
I do hope you find a solution soon.

Good Luck


Possibly Related Threads…
Thread Author Replies Views Last Post
  Modem Hardware bad? Not ready for 5g?? linux76 7 960 05-19-2022, 07:33 AM
Last Post: kebab
  Severe screen flicker + occasional ghosting | Pinephone Beta edition legowave440 4 310 04-23-2022, 02:04 AM
Last Post: fxc
  Modem in failed state, not sending/receiving SMS brb78 5 566 03-31-2022, 08:37 AM
Last Post: wibble
  Modem Dead? grimlok 5 763 03-12-2022, 04:38 PM
Last Post: bcnaz
Question Upgrading a 2020 Community Edition Pinephone? danimations 5 706 03-10-2022, 08:18 AM
Last Post: danimations
  Question regarding modem AntonReiser 21 3,501 02-14-2022, 12:23 PM
Last Post: vap0rtranz
Question Powering the modem after turning off the smartphone Mikoduso 3 760 02-04-2022, 04:06 PM
Last Post: grwlf
  Hardware switch for mic is not working properly submariner 10 2,451 01-25-2022, 07:01 AM
Last Post: wibble
Question Modem shield feklee 3 889 12-13-2021, 01:06 PM
Last Post: feklee
  what are these pins above modem chip? zetabeta 1 536 12-13-2021, 04:38 AM
Last Post: kqlnut

Forum Jump:


Users browsing this thread: 1 Guest(s)