Audio jack and external mic?
#1
Will the headset jack on the PBP work with combined mic/headsets? The wiki seems to say it should, but so far it doesn't for me. Using Manjaro, have tried two different headsets which work on other machines. Headset function works, but mic does not. The mic privacy switch is set to enabled, and the built-in mics are working (with the reported whine, of course). USB mic also works.

-john
  Reply
#2
(06-08-2020, 12:18 PM)johns Wrote: Will the headset jack on the PBP work with combined mic/headsets? The wiki seems to say it should, but so far it doesn't for me. Using Manjaro, have tried two different headsets which work on other machines. Headset function works, but mic does not. The mic privacy switch is set to enabled, and the built-in mics are working (with the reported whine, of course). USB mic also works.

-john

You likely need to change the input port within your system sound settings.

The privacy switches only disable the internal mics, IIRC, and should not effect any external mics.
  Reply
#3
(06-08-2020, 01:53 PM)tophneal Wrote:
(06-08-2020, 12:18 PM)johns Wrote: Will the headset jack on the PBP work with combined mic/headsets? The wiki seems to say it should, but so far it doesn't for me. Using Manjaro, have tried two different headsets which work on other machines. Headset function works, but mic does not. The mic privacy switch is set to enabled, and the built-in mics are working (with the reported whine, of course). USB mic also works.

-john

You likely need to change the input port within your system sound settings.

The privacy switches only disable the internal mics, IIRC, and should not effect any external mics.

That makes sense, but the system sound settings don't show the headset mic as an option. Whereas, if I connect a USB webcam with a mic, that does show up as an input device.

-john
  Reply
#4
You might want to look at the settings in ALSA, then: https://linuxconfig.org/how-to-test-micr...cture-alsa
  Reply
#5
(06-08-2020, 02:59 PM)tophneal Wrote: You might want to look at the settings in ALSA, then: https://linuxconfig.org/how-to-test-micr...cture-alsa

Okay. I guess I'm confused about how ALSA and PulseAudio might interact here. pavucontrol seems to provide accurate controls for my other input and output devices, just not the headset mic.

On another system, where the headset mic works, it shows up as a selectable input device in pavucontrol (something like "headset microphone (plugged in)")

Thanks for the ALSA test link. I tried it, but arecord -l only shows a single device with the headset plugged in.

**** List of CAPTURE Hardware Devices ****
card 0: rockchipes8316c [rockchip,es8316-codec], device 0: ff890000.i2s-ES8316 HiFi ES8316 HiFi-0 [ff890000.i2s-ES8316 HiFi ES8316 HiFi-0]
Subdevices: 0/1
Subdevice #0: subdevice #0

Attempting to record on that device (which I assume is the built-in mic anyway) gives an error:

arecord -f S16_LE -d 10 -r 16000 --device="hw:0,0" /tmp/test-mic.wav

arecord: main:830: audio open error: Device or resource busy

which is odd because nothing is using the input device (and both the toolbar audio mixer and pavucontrol show no active input).

Any ideas about next things to try? Are we sure that this should work to begin with?

-john
  Reply
#6
Have you run across this wiki section yet? https://wiki.pine64.org/index.php/Pinebo...icrophones

I tried to pull out some old iPhone headphones that have the microphones, but it turns out they are trash, and I have no other 3.5mm headphones. :/
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  External DVD/CD MIchael 22 4,474 03-07-2021, 03:49 PM
Last Post: ab1jx
  External Monitor Recommendations SteveSquatch 1 311 02-17-2021, 08:23 AM
Last Post: Arwen
  Audio with Debian GloriousCoffee 5 2,206 10-15-2020, 01:22 PM
Last Post: Mangled
  [split] Change password from external media James Good 11 3,783 07-23-2020, 02:42 PM
Last Post: wdt
  Battery draining with external power while under load? RndmNmbr 17 5,541 06-24-2020, 08:33 PM
Last Post: Syonyk
  Always in 'Charging' state, despite being disconnected from external power phuzy 13 4,718 03-26-2020, 04:12 AM
Last Post: agurenko
  Youtube audio stopped fuctoning Moon1 0 562 02-14-2020, 12:12 AM
Last Post: Moon1
  Audio problem resume from suspend tomfowler 8 3,082 02-08-2020, 12:21 PM
Last Post: Bobhodgen
  Audio challenge with Firefox 8jef 4 2,504 01-31-2020, 03:13 PM
Last Post: sasha
  Pinebook Pro Audio Codecs CryptoRick 3 2,038 09-06-2019, 09:11 AM
Last Post: CryptoRick

Forum Jump:


Users browsing this thread: 1 Guest(s)