Left USB port stopped functioning
(06-07-2020, 01:43 PM)diodelass Wrote: This seems to be some sort of issue with the USB drivers in the vendor kernel, I guess. My own unit did the same when I was using the Debian install that the first units shipped with. For what it's worth, the issue totally vanished when I switched to Manjaro (which uses the mainline kernel). If you can find a distro that gives you a mainline 5.6 kernel and suits your needs, you might also find it solved.

If you prefer Debian over Manjaro because you prefer older, more stable software, I understand - but do consider that the Pinebook Pro itself is not really very old or stable hardware yet, and it might be much better-served by a distro that has more up-to-date packages than Debian typically offers.

I think you may be right. I put the SDcard I installed Debian from back in and also had no USB port there now. Then I decided to install Debian from DanielT's script onto eMMC. Debian 11 wouldn't boot for me but then I tried again with Debian 10 and the USB port came back functional.

So this tells me it wasn't a hardware issue but something in software.

Debian 10 installed this way with XFCE seems lighter on resources than MrFixit2001's install is but that could be just my perception.

As for what caused this issue, I have no idea, but I'm now happily running Debian 10 just like on my desktop! I tried Manjaro as well but I personally like Debian + backports better.

Messages In This Thread
RE: Left USB port stopped functioning - by firebrd_1979 - 06-07-2020, 05:51 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
Photo PineBook Docking Deck charging port? ColoBill 3 748 02-26-2021, 10:07 PM
Last Post: Paull
  Some keys have stopped working wsgts 1 972 04-07-2020, 06:24 AM
Last Post: wsgts
  Port Adapters for PBP — Ethernet, HDMI, etc. zaius 18 7,786 01-19-2020, 03:52 PM
Last Post: Arwen
  Left-side USB 3.0 port not working diodelass 6 2,101 11-09-2019, 03:18 AM
Last Post: tgrauss

Forum Jump:

Users browsing this thread: 1 Guest(s)