Left USB port stopped functioning
#1
Hi everyone,
I received my Pinebook PRO a few days ago and it has worked fine up until this morning. When I plug a mouse (anything) into the USB port attached to the mainboard (left USB) , nothing happens. The other USB port works fine still.

After I received it, I flashed MrFixit2001 Debian image to eMMC and everything was functional. Last night I turned it off (no hibernate etc.), put it on the charger and this morning no left USB anymore.

I tried Debian from sdcard today and also there, I get no USB.

lsusb gives:

Code:
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 0c45:6321 Microdia
Bus 002 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 258a:001e
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Here's a picture of the USB slot:
Top:

https://pasteboard.co/Jc13GGv.jpg
Bottom:
https://pasteboard.co/Jc14hsv.jpg

I'm on the default kernel that came with the image:
Linux 4.4.213 #1 SMP Fri Feb 7 13:03:55 EST 2020 aarch64 GNU/Linux

It looks as if nothing even registers when I plug something in this port as there's no lines added to dmesg. When I plug the same devices I'm testing with into the right port, dmesg shows what's plugged in etc. (tried this with a mouse, usb stick and headset) Is there anyone who has an idea or would this be a hardware/port defect?
  Reply


Messages In This Thread
Left USB port stopped functioning - by firebrd_1979 - 06-07-2020, 12:02 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
Photo PineBook Docking Deck charging port? ColoBill 3 930 02-26-2021, 10:07 PM
Last Post: Paull
  Some keys have stopped working wsgts 1 1,024 04-07-2020, 06:24 AM
Last Post: wsgts
  Port Adapters for PBP — Ethernet, HDMI, etc. zaius 18 8,294 01-19-2020, 03:52 PM
Last Post: Arwen
  Left-side USB 3.0 port not working diodelass 6 2,300 11-09-2019, 03:18 AM
Last Post: tgrauss

Forum Jump:


Users browsing this thread: 1 Guest(s)