Arch Linux ARM on PinePhone (2020/12/23)
(06-30-2020, 08:08 PM)Danct12 Wrote: ...

All downloads are available on:


Huge shout out THANKS for the image with phosh - not that I love phosh but it gives a common denominator for me to start playing with arch.
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Started Bionic minimal - now "groovy", Openbox desktop for general purpose daily PC.
  • PinePhone BraveHeart now v1.2b 3/32Gb daily driver, dual boot via p-boot with Mobian/f2fs/Phosh on eMMC, Arch/f2fs/Phosh on SDcard
  • PinePhone v1.2a 2G/16Gb that needs USB board replaced
I have been rather lax in my recent testing,  but the last two releases have worked with 'data'  for me when using "Pure Talk" (ATT reseller)

My only issue is kind of minor,  I greatly prefer a lighter screen, the dark screen is good inside, but quite hard to see in the sunlight, (for me).
   Donate to $upport
your favorite OS Team
pacman -Syu 2020-11-24, Based on 20201112 image. Meets all my needs for production use. Update applied to eMMC.
Same old same old, still working , lol
- Mobile data works with manual control
- deep sleep wakeup: 100% of the time the phone wakes up, 95% of the time gnome-calls answers
- suspend/sleep is very flaky
- USB changes are flaky

I have not coded against hardware in over 30 years but now that I am watching the system logs and monitoring the DBus it appears the sleep and USB problems are related. I'm guessing due to the physical  circuitry. Right now I am coding integration hooks using the DBus, steep learning curve, lol.

I love the phone, it is such a fun machine to explore.

Anyone got a blue light filter or clipboard to work? Mobile stops working especially after screens off. I get a permissions error for run/user/1000 when attemping to launch apps with su and a dislay:0 error with sudo
I had to switch to "internal speaker" within the sound settings. (new multi-distro with GUI Phosh from Odrej

Testing incoming phone calls since yesterday. Screen wakes up at the first dial tone, ring tone at the third or fourth dial tone.

One time the phone asked for the Wlan-key while waking up, I just closed the notification.

When refusing a call from my FritzPhone I always need to refuse several times.

Up to now it works 100%. Big Grin

I've tested for a longer time. Most of the time the resume process / wake up of the cellular connection took too much time, more than 30s. Sometimes it worked as described above (phone rings after 3 dial tones). The same behaviour in Fedora.

Perhaps this new project of Ondrej will help:
Thanks for the info @Juergen. Are you using the 20201112 image or have you done an update on top of that?
LF seems to be having good results with an update to 20201124.
I'm going to start using this today/tomorrow, so just looking for as much info as possible on which the best version is.
Arch Linux ARM (20201129):
  • Kernel 5.9.10
  • Enabled dm-thin-pool kernel module for Docker
  • Upgrade squeekboard to 1.11.1
  • Upgrade geary to 3.36.0+5961+git7644e034-1pureos0
  • Upgrade pulseaudio to 14.0
  • Use upstream pipewire
  • Fixed alsa-ucm-{pinephone,pinetab} for latest pulseaudio and pipewire
  • Upgrade phoc to 0.5.1
  • Upgrade phosh to 0.6.0
  • Upgrade wys to 0.1.10
  • Upgrade modemmanager to 1.14.8
  • Upgrade feedbackd to 0.0.0+git20201114
  • Upgrade chatty to 0.2.0
  • Upgrade megapixels to 0.12.0
  • Fixed gnome-software crash
  • Enable Displays and some bug fixes in gnome-control-center
  • Make GTK3 more elegant when in convergence
  • Removed flashlight from PinePhone (top menu bar has a replacement)

Find me in the forest, when I'm at my lowest. I don't really think you should continue..

sudo pacman -Syu today borked my QA card. The modem refuses to wake up after sleeping.
Reverting to yesterday's backup

Manjaros MEGI kernel and modem driver ATM seems to work "a bit" better in receiving calls.

50% of calls while asleep could be received.
It was pointed out to me that I probably needed to update the modem firmware. I followed the forum post here Remember to use sudo. There were no issues, the phone rebooted and saw the modem. While I have not done a huge amount of testing my QA card has returned to the same functionality.

pacman -Syu run 2010/11/29 based on 2020/11/12 image
- phone wakes up 100%  on incoming calls, gnome-calls wakes up 90-95%
- sleep/suspend and USB are flaky (and the hardware people are making huge progress here)
- mobile data and GPS are under manual control

Now the big question is do I  upgrade the production card?

Thanks to all

Possibly Related Threads…
Thread Author Replies Views Last Post
  Arch auto mount usb example Lazy_one 1 58 06-13-2021, 05:10 PM
Last Post: Lazy_one
  Arch Linux PinePhone scaling slider Chief 5 483 06-09-2021, 02:23 PM
Last Post: Chief
  Arch Linux ARM - "my" issues mikehenson 0 313 04-29-2021, 10:01 PM
Last Post: mikehenson
  Keyboard not appearing in Arch Diagon 3 807 03-14-2021, 02:15 AM
Last Post: Danct12
  Pinephone debugging tools jjdekroon 0 351 02-27-2021, 05:05 AM
Last Post: jjdekroon

Forum Jump:

Users browsing this thread: 3 Guest(s)