Problem with EMMC bootup and detection
#1
Hello guys,
I have recently bought PINEA64-lts boards with EMMC modules of 16gb. I am having trouble interfacing them now. When I burn any image on EMMC ( I have tried several), it dosen't boot from EMMC. The same image when I burn onto SD card,  it starts booting. When only EMMC is inserted PINE64 shows black screen and there is no sign of booting process. Can you please help me out.

I have also tried auyfan's image on SD card. and when I insert EMMC onto PINEA64-lts and check EMMC status, it gets detected with uenv.txt "mmc_compact=on". But when i burn the same image on EMMC and repeat all of above process, boot process does not start.

I am using pine64 usb programmer to program the emmc modules. and i ordered everything from the pine64 official site. EMMC has FORESEE 16 GB IC on it.

When i plugin emmc module in laptop using programmer, it always gets detected and there is no problem in programming the EMMC module.

I am newbie here, hope you guys will guide me well.... Thanks in advacnce
#2
(11-06-2020, 01:47 AM)khantheengr Wrote: Hello guys,
I have recently bought PINEA64-lts boards with EMMC modules of 16gb. I am having trouble interfacing them now. When I burn any image on EMMC ( I have tried several), it dosen't boot from EMMC. The same image when I burn onto SD card,  it starts booting. When only EMMC is inserted PINE64 shows black screen and there is no sign of booting process. Can you please help me out.

I have also tried auyfan's image on SD card. and when I insert EMMC onto PINEA64-lts and check EMMC status, it gets detected with uenv.txt "mmc_compact=on". But when i burn the same image on EMMC and repeat all of above process, boot process does not start.

I am using pine64 usb programmer to program the emmc modules. and i ordered everything from the pine64 official site. EMMC has FORESEE 16 GB IC on it.

When i plugin emmc module in laptop using programmer, it always gets detected and there is no problem in programming the EMMC module.

I am newbie here, hope you guys will guide me well.... Thanks in advacnce

On Pine A64-LTS board, teh SD boot has higher priority than eMMC, please make sure there is no bootable OS build microSD card in microSD slot.
#3
That doesn't seem to be the issue. I think it is rather that images made to boot from SD will not boot from emmc, and there is very little clarity what needs to be done to make them boot from emmc.
#4
(11-07-2020, 11:52 PM)tllim Wrote:
(11-06-2020, 01:47 AM)khantheengr Wrote: Hello guys,
I have recently bought PINEA64-lts boards with EMMC modules of 16gb. I am having trouble interfacing them now. When I burn any image on EMMC ( I have tried several), it dosen't boot from EMMC. The same image when I burn onto SD card,  it starts booting. When only EMMC is inserted PINE64 shows black screen and there is no sign of booting process. Can you please help me out.

I have also tried auyfan's image on SD card. and when I insert EMMC onto PINEA64-lts and check EMMC status, it gets detected with uenv.txt "mmc_compact=on". But when i burn the same image on EMMC and repeat all of above process, boot process does not start.

I am using pine64 usb programmer to program the emmc modules. and i ordered everything from the pine64 official site. EMMC has FORESEE 16 GB IC on it.

When i plugin emmc module in laptop using programmer, it always gets detected and there is no problem in programming the EMMC module.

I am newbie here, hope you guys will guide me well.... Thanks in advacnce

On Pine A64-LTS board, teh SD boot has higher priority than eMMC, please make sure there is no bootable OS build microSD card in microSD slot.
Yes, i made sure that SD card has not been inserted during boot process and only EMMC module is attached to the board. but issue still not sovled.

(11-08-2020, 06:02 AM)poVoq Wrote: That doesn't seem to be the issue. I think it is rather that images made to boot from SD will not boot from emmc, and there is very little clarity what needs to be done to make them boot from emmc.
i downloaded the following image from pine64 site and they did mention it supports EMMC module tooo
"""""
Armbian Buster for Desktop Usage """"""

I am very worries, i already have emailed PINE64 but they havent replied me. Can you please let me know which image will be better for emmc module.
#5
I think the Armbian images currently do not support booting from the emmc. In fact I have trouble getting my Sopine modules (on a clusterboard) to recognize the emmc at all, but I am not sure if that is only a clusterboard specific issue.
#6
(11-10-2020, 08:50 AM)poVoq Wrote: I think the Armbian images currently do not support booting from the emmc. In fact I have trouble getting my Sopine modules (on a clusterboard) to recognize the emmc at all, but I am not sure if that is only a clusterboard specific issue.

The emmc issue seems to exist due to kernels still not being able to handle emmc properly yet. I had the same issue trying to make a Volumio image that would boot from emmc and sd.

Perhaps not the most preferred solution, but this is how I solved it with disabling support for hs ddr by patching the sunxi emmc driver in the kernel:
See kernel 5.7.19 used for Volumio

Perhaps this problem gets fixed in 5.10 or 5.11
#7
@gkkpch can you please correct that link?

Edit: is it the same as this: https://lore.kernel.org/patchwork/patch/1038299/ ?

Edit2: here they even talk about disabling it for the A64: https://www.spinics.net/lists/linux-mmc/msg61280.html

Hmm, the problem seems to be that in my case on the clusterboard it actually seems to work better with the HS DRR mode (but better in the sense that it is still broken), if as by default in Armbian only "mmc-hs200-1_8v;" is set and thus apparently no drr mode used, the emmc fails completely in my case.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Booting from eMMC saileshrajk 12 8,488 02-16-2021, 01:02 PM
Last Post: IanJames
  eMMC fail in 2% of flashing barucha 10 5,601 12-14-2020, 06:51 AM
Last Post: Little_Johnny
  Pine64 LTS GbE Problem scchoi 1 1,598 06-20-2020, 12:39 PM
Last Post: tllim
  SoPine eMMC compatibility Terra854 4 4,237 02-20-2020, 07:52 PM
Last Post: mcrognale
  LTS can't see eMMC devices 1291 4 3,371 02-20-2020, 07:43 PM
Last Post: mcrognale
  EMMC cards in Pine64 store stephen fleming 16 21,547 12-26-2017, 12:19 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)