Busted Pine64 does not turn on any more
#1
Got mine a couple of hours ago (2GB). Burned a Ubuntu image and booted it up. Rebooted a couple of times. And now it doesn't turn on anymore. The red LED stays off. Looks dead.

I tried a few other USB power supplies (I have quite a few and I bought them for my Pis, none of those crappy ones that you get with your phone) and nothing. The board seems to be busted. I removed everything (no keyboard or mouse or Ethernet or HDMI cable, no SD card) and it didn't make any difference.

Sigh.. knowing them, 1- it will take them forever to replace the board and 2- they will charge me another $7 to send a replacement

Waiting for : it must be your fault doing something you're not supposed to do. your power supply was -bad-, cables have not been thick enough. Stop whining, there is always problem with a new piece of hardware, etc. etc. etc.

is the right email support@pine64.com?
#2
(04-23-2016, 07:24 PM)alid Wrote: Got mine a couple of hours ago (2GB). Burned a Ubuntu image and booted it up. Rebooted a couple of times. And now it doesn't turn on anymore. The red LED stays off. Looks dead.

I tried a few other USB power supplies (I have quite a few and I bought them for my Pis, none of those crappy ones that you get with your phone) and nothing. The board seems to be busted. I removed everything (no keyboard or mouse or Ethernet or HDMI cable, no SD card) and it didn't make any difference.

Sigh.. knowing them, 1- it will take them forever to replace the board and 2- they will charge me another $7 to send a replacement

Waiting for : it must be your fault doing something you're not supposed to do. your power supply was -bad-, cables have not been thick enough. Stop whining, there is always problem with a new piece of hardware, etc. etc. etc.

is the right email support@pine64.com?

The support@pine64.com is correct address. If confirmed is DOA (Dead of Arrival), we will ship another board to you and will not demand shipping charge. If you didn't get response or not able to resolve in a week time, please PM me.
#3
(04-24-2016, 02:49 AM)tllim Wrote:
(04-23-2016, 07:24 PM)alid Wrote: Got mine a couple of hours ago (2GB). Burned a Ubuntu image and booted it up. Rebooted a couple of times. And now it doesn't turn on anymore. The red LED stays off. Looks dead.

I tried a few other USB power supplies (I have quite a few and I bought them for my Pis, none of those crappy ones that you get with your phone) and nothing. The board seems to be busted. I removed everything (no keyboard or mouse or Ethernet or HDMI cable, no SD card) and it didn't make any difference.

Sigh.. knowing them, 1- it will take them forever to replace the board and 2- they will charge me another $7 to send a replacement

Waiting for : it must be your fault doing something you're not supposed to do. your power supply was -bad-, cables have not been thick enough. Stop whining, there is always problem with a new piece of hardware, etc. etc. etc.

is the right email support@pine64.com?

The support@pine64.com is correct address. If confirmed is DOA (Dead of Arrival), we will ship another board to you and will not demand shipping charge. If you didn't get response or not able to resolve in a week time, please PM me.

So I send email to support alias and today I finally I got an answer that basically asking to take my problem to forum! It is obvious that they didn't even bother to read my email. Here's their answer:

Quote:Thanks for contacting us. With volume of emails we're receiving daily, we're kindly asking that you visit our forum.pine64.org for technical questions/inquiries. We have team members actively on there assisting.
 Please follow the checklist below as it has helped backers boot up their boards.
 
1) did you try a different power supply
2) did you use a class 10 MicroSD
3) did you follow instructions on downloading and burning the images
4) did you wait at least 5-10 min for the initial boot to allow the OS to unpack?
 
This link generated by user provide good info of getting Pine A64 board up: http://forum.pine64.org/showthread.php?tid=514 
 
 
Hope this helps! Please let us know if it doesn't!
#4
So, what am I supposed to do now?
#5
(04-27-2016, 12:45 AM)alid Wrote: So, what am I supposed to do now?

Please PM me your KS number and shipping info, I will get a replacement board for you soon.
#6
tllim
could you please confirm you have received my PMs and you have everything you need?

I am not asking for an immediate replacement. Just a confirmation that you have seen the PMs that I sent you per your request and verifying that you have what you need.
#7
(05-02-2016, 07:51 PM)alid Wrote: tllim
could you please confirm you have received my PMs and you have everything you need?

I am not asking for an immediate replacement. Just a confirmation that you have seen the PMs that I sent you per your request and verifying that you have what you need.

Confirm PM received
#8
I just wanted to update the thread and let everybody know that I received a replacement board without paying for the shipping and a prepaid UPS slip to return back the old board. The replacement board is working fine.

Giving credit when it is due!

Thanks.
#9
(05-16-2016, 02:52 AM)alid Wrote: I just wanted to update the thread and let everybody know that I received a replacement board without paying for the shipping and a prepaid UPS slip to return back the old board. The replacement board is working fine.

Giving credit when it is due!

Thanks.

Glad to know that you have received the replacement board.
#10
(05-16-2016, 10:12 AM)tllim Wrote:
(05-16-2016, 02:52 AM)alid Wrote: I just wanted to update the thread and let everybody know that I received a replacement board without paying for the shipping and a prepaid UPS slip to return back the old board. The replacement board is working fine.

Giving credit when it is due!

Thanks.

Glad to know that you have received the replacement board.
Actually now I have received two replacement boards. I need to either return back one of them or find a way to pay for it. Please check your PM.


Possibly Related Threads…
Thread Author Replies Views Last Post
Thumbs Down Pine64 was a Useless Project pushpendrak 18 15,519 11-21-2020, 10:17 PM
Last Post: tllim
  Pine64 LCD rstcologne 0 1,616 09-22-2020, 12:43 PM
Last Post: rstcologne
  Pine64+ power button PaddyChan 0 1,264 09-14-2020, 09:55 AM
Last Post: PaddyChan
  Pine64 OS dpcons 2 2,436 03-02-2020, 04:32 PM
Last Post: dpcons
  Jailhouse supports Pine64+ vj-kumar 0 1,476 02-17-2020, 11:39 PM
Last Post: vj-kumar
  PINE64 board not powering up loki21century 2 3,036 11-25-2019, 12:19 PM
Last Post: Partymack711
  Pine64 not powering up. skylab 5 3,550 05-03-2019, 02:48 PM
Last Post: Mendota
  Pine64 LTS vs Rock64 4 GB LTS gops 2 2,106 04-15-2019, 10:56 AM
Last Post: gops
  Pine64+ 2GB board for sale with WiFi module and case ~clumsy~ 1 2,006 10-21-2018, 04:54 AM
Last Post: aeiltz
  Video Chat with Pine64 mathiraj 0 1,494 07-02-2018, 02:33 PM
Last Post: mathiraj

Forum Jump:


Users browsing this thread: 1 Guest(s)