RockPro Wireless+Bluetooth Issue - Linux (ayufan 0.7.8 and previous)
#1
I may be overlooking something very simple. Here is what I have observed so far. I am referencing the image file from ayufan, 0.7.8 LDXE RockPro. I have went all the way down from dev releases to the 0.6.X stable releases, but I have the same results. It's actually worse on older builds, which I expected.

I have two separate units, with two separate RockPro bt+wifi modules that integrate in to the board. I have ran several commands to try to see the issue, but with no success.

The lsusb output does not show the adapter, which is expected since it doesn't use USB.

The "lshw -C network" shows that the adapter is wlan0.

The "rfkill list" shows that the adapter is there, and wireless isn't blocked. However, it shows that Bluetooth is soft blocked so I issued the unblock all command. This fixed the software block, but the wireless still wouldn't work.

iwconfig isnt even available. The "ifconfig wlan0 up" command returns "The operation is not permitted".

To validate that it isn't hardware related, I loaded the other Android builds and they work great with wireless. But those builds are extremely limited functionally and visibly without the tablet.

Sorry if this is a solid noob question, so feel free to cut jokes, lmao. I just tried about everything I could think of. wicd wasn't even an option, but that's likely due to the build not recognizing the adapter fully. 

Any help is appreciated!! Thanks all, especially to ayufan for everything! You are a kind soul, and I'll buy you a beer anytime. ;-)
  Reply
#2
Lukasz pointed this out to me last night:

0.7.8: Disable sdio (no wifi/bt) to fix pcie/nvme support on 4.4 for RockPro64,
  Reply
#3
Thanks for the reply! I noticed that in the release notes. I found it by searching with the keyword "wifi", which was mentioned 3 times within his releases. I downgraded to 0.7.7 and even the 0.6.X stable, but still have the issue unfortunately.
  Reply
#4
(07-25-2018, 08:57 AM)JeffD Wrote: Thanks for the reply! I noticed that in the release notes. I found it by searching with the keyword "wifi", which was mentioned 3 times within his releases. I downgraded to 0.7.7 and even the 0.6.X stable, but still have the issue unfortunately.

I haven't had any luck getting it to work yet either and I've resorted to using the USB one.
  Reply
#5
(07-25-2018, 04:53 PM)evilbunny Wrote:
(07-25-2018, 08:57 AM)JeffD Wrote: Thanks for the reply! I noticed that in the release notes. I found it by searching with the keyword "wifi", which was mentioned 3 times within his releases. I downgraded to 0.7.7 and even the 0.6.X stable, but still have the issue unfortunately.

I haven't had any luck getting it to work yet either and I've resorted to using the USB one.

So after a ton of digging, a close friend and I were able to find a solution. Here is what we found.

The wireless+bt chip is an AMPAK AP6359SA, but it uses the Broadcom 4359 chipset. After more digging, we found the kernel calling for /system/etc/firmware instead of /etc/firmware which is what the Linux distro uses. After realizing that, we researched the current stable Android release that has working wireless+bt firmware.

The folder for the firmware on the stable Android release referenced /system/etc/firmware, which is what the Linux kernel is using. We archived the file on to a USB from the Android release, then brought back up the Linux release. We moved the files over to the folder structure that the Linux kernel was calling. Once we got everything in order, we reissued the rfkill unblock all command then proceeded to reboot. 

Once rebooted, the wireless module was fully recognized and scanning SSID's. To make it where we didn't have to use a wpa_supplicant file every time(for my wife's usability), I installed WICD. It works pretty well from what we have tested thus far. We still need to validate further.

But there is a good thing coming up soon to make this much easier for all, but some may want it quickly so we will write up a report and put the files out for downloading. However in 4.5+, the chipset will be fully supported out of the box. I just wanted to send an update that it is working and that we are going to put something together just in case anyone wants to leverage it prior to the 4.5 release.

I should have something written up today, but the information here can be used to get the wireless module up and going. I hope this helps others!!

Thanks for being an awesome community and making great boards!  Smile
  Reply
#6
@JeffD: Very nice! On which board? v2.0 or v2.1?
Sorry for any mistakes. English is not my native language

1. RP64 v2.1 / PCIe SATA Marvell 88SE9230 Chipsatz / sd-card / 2 * 3,5 Zoll 4TB HDD (raid1) / using as NAS / Kernel 4.4.202-1237-rockchip-ayufan-gfd4492386213 / Booting from an USB3 SSD

2. RP64 v2.1 / testing.....testing....testing 

https://forum.frank-mankel.org/category/14/rockpro64
  Reply
#7
(07-27-2018, 10:29 AM)Bullet64 Wrote: @JeffD: Very nice! On which board? v2.0 or v2.1?

I don't have the board with me, but it was the second preorder. I imagine it is V2.1, but I'll definitely update that once I get off work!

We did heed the release notes for 0.7.8 concerning the wireless being disabled, so we ran with 0.7.7. I will give it a shot on 0.7.8 as well, just for the sake of fun.  Tongue
  Reply
#8
(07-27-2018, 01:01 PM)JeffD Wrote:
(07-27-2018, 10:29 AM)Bullet64 Wrote: @JeffD: Very nice! On which board? v2.0 or v2.1?

I don't have the board with me, but it was the second preorder. I imagine it is V2.1, but I'll definitely update that once I get off work!

We did heed the release notes for 0.7.8 concerning the wireless being disabled, so we ran with 0.7.7. I will give it a shot on 0.7.8 as well, just for the sake of fun.  Tongue

Yeah, i forgot about 0.7.8 With 0.7.7 on ROCKPro64 v2.1 i got this


Code:
rock64@rockpro64:~$ rfkill list
0: bt_default: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: brcmfmac-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no


And


Code:
rock64@rockpro64:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
   link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
   inet 127.0.0.1/8 scope host lo
      valid_lft forever preferred_lft forever
   inet6 ::1/128 scope host
      valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000
   link/ether 1e:0e:99:52:8e:40 brd ff:ff:ff:ff:ff:ff
   inet 192.168.3.17/24 brd 192.168.3.255 scope global dynamic eth0
      valid_lft 3368sec preferred_lft 3368sec
   inet6 fe80::1c0e:99ff:fe52:8e40/64 scope link
      valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
   link/ether ac:83:f3:e6:1f:b2 brd ff:ff:ff:ff:ff:ff

Will need more tests. Thanks for the hint! Big Grin
Sorry for any mistakes. English is not my native language

1. RP64 v2.1 / PCIe SATA Marvell 88SE9230 Chipsatz / sd-card / 2 * 3,5 Zoll 4TB HDD (raid1) / using as NAS / Kernel 4.4.202-1237-rockchip-ayufan-gfd4492386213 / Booting from an USB3 SSD

2. RP64 v2.1 / testing.....testing....testing 

https://forum.frank-mankel.org/category/14/rockpro64
  Reply
#9
Well. I purposely disabled, for now, the sdio (wireless and bt) as more people look at pcie support, and there seems to be some conflict of interest (probably with clocks) that prevents both of them working always, at the same time.

I have all other bits to enable it, but since it is not stable yet, I will likely leave it like that for time being Smile
Homepage: https://ayufan.eu

Releases:
Rock/Pro 64/Pinebook Pro: LinuxChromium OS
So/Pine A64/Pinebook: LinuxAndroid 6.0Android 7.1

Buy me a Beer
  Reply
#10
(07-30-2018, 03:51 PM)ayufan Wrote: I have all other bits to enable it, but since it is not stable yet, I will likely leave it like that for time being Smile
Can you describe what are those "bits to enable it" ?
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Arch Linux on RockPro64 mmatyas 29 10,907 05-23-2020, 02:29 PM
Last Post: rhysperry111
  RockPro64 Linux Manjaro HDMI 4K mkne 12 305 05-03-2020, 07:23 AM
Last Post: PakoSt
  Mainline U-Boot with Arch Linux PKGBUILD mmatyas 0 89 04-17-2020, 03:49 AM
Last Post: mmatyas
  Slow/dead ethernet on (non-Ayufan) Linux Mainline (fixed) mmatyas 1 135 04-17-2020, 02:53 AM
Last Post: Thra11
  New Pre-release 0.10.9 from Ayufan Bullet64 0 147 04-09-2020, 06:49 AM
Last Post: Bullet64
  Rockpro64 and stock arch linux TaborFife 6 1,024 01-15-2020, 05:17 PM
Last Post: dragop
  Problem with compiling ayufans linux kernel voegelit 4 339 01-14-2020, 07:38 AM
Last Post: patstew
  Ayufan 5.4.0 rc1 release - cannot boot Mentaluproar 2 414 01-05-2020, 02:39 PM
Last Post: mmiigg
  Reboot problem on latest ayufan and 4.4 /dev/null 2 430 11-27-2019, 04:23 AM
Last Post: dukla2000
  poor HDD performance - ayufan mainline OMV Mentaluproar 0 134 11-11-2019, 10:26 PM
Last Post: Mentaluproar

Forum Jump:


Users browsing this thread: 1 Guest(s)