Playbox LCD on Linux
I got the LCD working on XFCE Debian running on the 3.10.102-3-pine64-longsleep kernel running on a 2GB Pine64+.

I have a list of instructions on along with the device tree blob and script that worked for me.

I have only tested this on my own pine64+ playbox.

I am looking for help with testing and improving the instructions.


edited:  added pic to database; click to enlarge
Thanks Mack, very nice work !

( I added the pic to our database ; thread pinned )
marcushh777    Cool

please join us for a chat @   or ssl

( I regret that I am not able to respond to personal messages;  let's meet on irc! )

Going to give this a try Monday after work....
(10-02-2016, 11:37 PM) Wrote: Next I edited /etc/systemd/system/


I commented out the lines that did something. Which is everything but the section headers Putting a # on every line should work.

A better way to do that is this:

sudo systemctl disable sunxi-disp-tool

It's much more simpler and cleaner that way.
Donate BTC: 3Eav9uqXi8Nx1axb7QjK6xV4km4K9YGv9a
good job Smile
You can find me on IRC, Discord and Twitter

This is great! Those same steps should work for any of the other distributions also.

It works.  A few notes for those trying this at home:

a) the DTC compiler will most likely not be on your image:
   sudo apt-get install device-tree-compiler

b) you don't need the DTC compiler.  Since the dtb files are in the boot partition which is FAT32, go to the GitHub page and download it.
    1) click the link, hit the "Raw" and you should get a "Save As" in your browser. 

c) Unless you want to be like me and screw up and re-image, first go into your distribution the normal HDMI way and disable the lines in systemd as mentioned above in first post. Shutdown the OS, take out the memory card and copy the new dtb files in the boot partition.

d) touchscreen does not appear to work.   I'm guessing that this is just a module that isn't yet loaded or compiled.
(10-03-2016, 02:56 AM)Terra854 Wrote:
(10-02-2016, 11:37 PM) Wrote: Next I edited /etc/systemd/system/


I commented out the lines that did something. Which is everything but the section headers Putting a # on every line should work.

A better way to do that is this:

sudo systemctl disable sunxi-disp-tool

It's much more simpler and cleaner that way.

Thank you, I have update the file as suggested, Plus I added an "easy way" at the top.
Wow!  So simple!  worked first time!

So - I got it working with the Debian Mate image...  no dramas! Sweet!  (n.b. still can't install synergy - complains about libqnetwork dependancy)

But then I realised how much I hate Mate - so installed XFCE, and removed MATE...  but something went wrong along the way - and 'cause I couldn't get synergy to install from the "default" /etc/apt/sources.list that comes with the Pine Debian images - I decided I'd try DietPI :

It worked for a bit - but I noticed sometime (which also seems to have happened to my other Pine running DietPI) - drops off the network!  Stays online during the first boot up and pulls down its updates - but somewhere along the way it's drops off my LAN - and because the UART is disabled - I can't do anything....  I can confirm that boot up and Penguin logos show up as a splash screen (after replacing /boot/pine64/*.dtb files as per the at the github page) in DietPI - but the GUI (XFCE) never loads...  Actually tried it twice - and same result - nothing on screen, nothing on network (first few boots of DietPI it always gets the same IP address), and the UART is disabled...

So - I burned (figuratively) another image onto SDCard of Debian XFCE 18/07/2016 - and I've got it running currently - I have TOUCHED anything on there, left the /etc/apt/sources.list file alone (even though my ISP hosts ARMHF and ARM64/AARCH64 debian repos) - I've installed maybe a couple of things (unison, nfs-common) - and I still cannot install synergy (I acknowledge that quicksynergy is not repo'd for aarch64 [but it is in arm7l/armhf]) :

x@figlio-di-puttana:~$ sudo apt-get install synergy
Reading package lists... DoneR
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 synergy : Depends: libqt4-network (>= 4:4.5.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

But - never mind - I am CHUFFED that the Pine64 supplied 7" display is "that easy" to get going in Linux...  I'm not bothered about missing out on touch (it would be nice to have ALL the features of ALL the hardware supplied, working).

I will add - I am powering Pine64+ (2GB) directly to PWR header pins on the EULER bus and I also have a battery hooked up via the JST.

I even got bluetooth working!

So BIG massive Kudos to MackPI for the LCD and pfeerick for showing me how to get Bluetooth working...

Now I just need synergy to install (I already spent some time compiling it for armhf on one of my CHIPs - don't really want to do that again).
Following the instructions on GitHub, the screen does show scrolling text during the DietPI bootup sequence, but then goes black. According to the GitHub repo: "This far got me scrolling text on boot but the screen would go black before the login prompt with HDMI still working."

That seems to be the case for me as well, but I cannot find a way to fix this? It would be great to have the screen fully working (albeit without touch interaction). Should I give up on DietPI if I want to get the screen working?

Possibly Related Threads…
Thread Author Replies Views Last Post
Information LCD Support on Linux pfeerick 8 19,952 02-08-2021, 03:30 PM
Last Post: HBeserra
  [EXPERIMENTAL] Linux on the LCD screen Terra854 24 36,956 07-21-2017, 07:41 AM
Last Post: apple4ever
  Linux Support UnixOutlaw 69 95,975 03-18-2017, 07:25 PM
Last Post: apple4ever

Forum Jump:

Users browsing this thread: 1 Guest(s)