RockPro64 getting started - non-booting images [solved]
(03-05-2020, 03:58 PM)grukrz2 Wrote:
(11-21-2019, 01:09 AM)new-rockpro-user Wrote: Well, even with all that, it continues to be a little hit or miss.

Manjaro booted exactly once from eMMC. And reflashing the eMMC appears to make no difference.
It does seem to boot more reliably from SD though. So there's that.

Any extra ideas or pointers about booting non-ayufan images from eMMC would be welcome!

I've flashed U-Boot on my RockPro64 using your procedure but I don't see U-Boot starting from SPI memory when I power system on.

On eMMC I have installed Libreelec which boots fine (without jumper).
Microsd with Debian I can only boot when I plug-in jumper (=disable eMMC)

Knowing that SPI is flashed properly (as on output linked above), how could I boot from microsd without necessity inserting jumper.

According to I should have possibility booting with order:

  1. SPI flash
  2. eMMC (disable with jumper)
  3. microSD
  4. USB drive
  5. PXE

I seems to be about as far into booting the RockPro64 as you are.

As far as I understand it, even with the uboot in the spi, if you add an eMMC with a bootable image, it will always boot from there first.
So, no matter if you add a microSD or USB drive, it will still boot eMMC. Unless you jumper it.

Which, to be honest, seems to be a very unfortunate design decision.
Basically, with the RockPro64, the eMMC is useless if you are experimenting one way or another with different images.
Especially if you use a case like the official premium aluminum case, you can only use the SD card to boot if you don't have an eMMC plugged in.

I could boot almost nothing at first, and this only improved when adding the ayufan spi. But that brings the above situation.
My eMMC is collecting dust now. Also, I only got booting from USB working with USB 2.

Also, not sure why, but the red light stays on quite long before actually commencing the booting. And sometimes requiring an extra reset to go.
So, basically, what I'm saying, the booting situation here is pretty horrible. But, then, when it boots, the RockPro64 is actually quite nice.

We seem to be missing some kind of boot menu, a la petitboot, grub or whatever.

Messages In This Thread
RE: RockPro64 getting started - non-booting images [solved] - by new-rockpro-user - 03-06-2020, 06:31 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Booting from NVME ilovegentoo 11 3,043 05-10-2021, 02:06 PM
Last Post: rrowles2000
  New OS for RockPro64 is here, TwisterOS Armbian jtremblant 75 12,865 05-09-2021, 08:48 PM
Last Post: jtremblant
  slarm64 (unofficial slackware) ROCKPro64 RK3399 (aarch64) mara 43 22,015 05-03-2021, 02:16 AM
Last Post: mara
  Armbian images available Luke 52 29,592 04-26-2021, 03:16 AM
Last Post: Wizzard
Question Booting official Debian on RP64 arteeh 4 487 03-31-2021, 10:01 AM
Last Post: kuleszdl
  Booting Linux/Debian from the eMMC linuxha 4 510 03-02-2021, 07:01 PM
Last Post: linuxha
Question My Rockpro64 stopped booting with these error messages please help seaurchin 4 505 02-18-2021, 04:27 PM
Last Post: TRS-80
  Rockpro64 not stable... crashes now and then. Pineapple 18 6,163 02-16-2021, 02:45 PM
Last Post: TRS-80
Question Mainline Debian Buster on RockPro64 ? chrestomanci 36 12,973 02-14-2021, 02:37 PM
Last Post: foresto
  Alpine on RockPro64 mutemule 0 318 02-05-2021, 10:10 AM
Last Post: mutemule

Forum Jump:

Users browsing this thread: 1 Guest(s)