80 mm fan not working
#1
L.S.,

I just got the NASCase running. I got the 80 mm fan with it, it is properly plugged in in the right place on the board, but for some reason it is not working. Is this a hardware or a software problem?

My NAS runs OMV.

I already tried to install ATS (https://github.com/tuxd3v/ats), but that didn't work out:

after I run

Code:
luarocks build https://raw.githubusercontent.com/tuxd3v/ats/master/ats-0.2-0.rockspec



I get the following error in the terminal:


Code:
Warning: variable CFLAGS was not passed in build_variables
gcc -c -march=armv8-a+crc -mtune=cortex-a72.cortex-a53 -fPIC -Wall -Werror -O3 -g -I/usr/include/lua5.3  -o debug.o src/debug.c
gcc -c -march=armv8-a+crc -mtune=cortex-a72.cortex-a53 -fPIC -Wall -Werror -O3 -g -I/usr/include/lua5.3  -o ats.o src/ats.c
gcc -shared -Wl,-soname,ats.so.0 -llua5.3  -o ats.so.0.9 debug.o ats.o
Install ATS Tool ..................: ats in /usr/local/sbin
Install ATS Config ................: ats.config in /etc
Install ATS Service File ..........: ats.service in systemd
Remove previous ATS Library .......: ats.so.* from /usr/local/lib/lua/5.3
Install new ATS Library ...........: ats.so.0.9 in /usr/local/lib/lua/5.3
Create soname symLink .............: ats.so in /usr/local/lib/lua/5.3
Starting ATS Service..
● ats.service - ATS - Active Thermal Service
   Loaded: loaded (/lib/systemd/system/ats.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Mon 2019-07-01 01:13:48 UTC; 923ms ago
  Process: 7288 ExecStart=/usr/local/sbin/ats (code=exited, status=1/FAILURE)
 Main PID: 7288 (code=exited, status=1/FAILURE)
      CPU: 14ms

Jul 01 01:13:48 rockpro64 systemd[1]: ats.service: Failed with result 'exit-code'.
Makefile:103: recipe for target 'install' failed
make: *** [install] Error 3

Error: Build error: Failed installing.

Any ideas on what could be happening?

So to be clear the main issue is that the fan isn't working. The secondary issue is that I can't install ATS.

Allt the best,


Messages In This Thread
80 mm fan not working - by kromsam - 06-30-2019, 07:22 PM
RE: 80 mm fan not working - by Luke - 07-01-2019, 05:08 AM
RE: 80 mm fan not working - by kromsam - 07-01-2019, 08:01 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
Bug Anyone else's UART RX (serial input) stopped working? pion 1 884 04-07-2022, 08:35 PM
Last Post: foresto
  Cheap 4-port SATA card working with RockPro64 4Gb andyburn 6 8,483 08-10-2020, 08:36 PM
Last Post: zer0sig
  new WIFI/BT module not working with android 8.1 Firesped 0 1,586 05-12-2020, 10:33 PM
Last Post: Firesped
  video not working greenhobby 0 1,187 03-21-2019, 05:56 AM
Last Post: greenhobby

Forum Jump:


Users browsing this thread: 1 Guest(s)