Can not get board to boot up reliably
#8
(04-24-2017, 01:41 AM)Leo Wrote: *** I have read many of the threads regarding power and firmware and tried without success

Hi Leo,

I also have/had these kind of startup problems. I did some test to see if they were power related, but
i don't think that is the case. If there is an issue i believe it has to do with correct initialisation order of
some registers in the Allwinner. I did not have the time to really do some in depth research, so I first
made a workaround by letting the kernel panic on soft lockups and auto reboot. At least this will result
in an auto retry without having to toggle power. 

I used the latest kernel from longsleep and did some custom kernel options. I have noticed that i was
unable to get my board to lockup at boot. Even with bad power supply (only 4.3Volt) the board still
boots fine. I think the fix is triggered by compiling the kernel without preemptive support; see also my
kernel config. If you don't want to compile the kernel you can also download my version at:
https://pkfpeters.stackstorage.com/s/mL1bQL0Dlj8Xw04

Sorry, i forgot my setup:

-Using a Pine A64+ 2GB (tested with and without the wifi addon module)
-Tested with apacer 16GB and 32GB MicroSD card.
-Tested with hdmi to vga converter (and monitor connected) and without converter (headless setup).
-Using standard debian image from forum and updated with -> apt-get update followed by apt-get upgrade and followed by pine64_update scipt from longsleep to get latest kernel and uboot
-Downloaded latest kernel source from longsleep and made custom changes to kernel settings with 'make ARCH=arm64 -j4 menuconfig all' -> see config attached to this item.
-Compiled kernel on the Pine64 with custom config by using -> 'make ARCH=arm64 -j4 all'
-Installed kernel modules with 'make ARCH=arm64 -j4 install'
-Reused initrd and dtd from longsleep; only replaced kernel in /boot dir and changed uboot kernel name.

Rebooted the unit and did many power tests. Low power, reboots, quick power off/on etc....


Attached Files
.zip   linux-3.10.105-0-pine-ppe.zip (Size: 20.26 KB / Downloads: 224)
  Reply


Messages In This Thread
Can not get board to boot up reliably - by Leo - 04-24-2017, 01:41 AM
RE: Can not get board to boot up reliably - by pkfpeters - 06-12-2017, 08:25 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Debian Base (3.10.102 BSP 2) won't boot without monitor Scion 7 9,060 09-16-2016, 03:58 PM
Last Post: Scion
  Possible to add a boot logo for boot? Darkshadow2913 4 4,088 09-09-2016, 06:02 AM
Last Post: Darkshadow2913
  Very long boot time with Debian image Xabaras76 5 5,176 07-14-2016, 03:49 PM
Last Post: Xabaras76
  Debian base(102) n xfce(101) does not boot HenryD 2 2,061 07-09-2016, 04:50 PM
Last Post: HenryD

Forum Jump:


Users browsing this thread: 1 Guest(s)