power circuit can't charge battery and can't supply enough power for modem or wifi
#1
I have what seems like a hardware problem and am trying to diagnose it. Most likely, it is the PMIC (Power Management IC) or something else on the motherboard that is bad and would have to be replaced, but maybe I am missing something.

First, I have a Convergence Edition PinePhone (1.2b board) which I got about 2 years ago.

Second, the lead up. PinePhone spontaneously rebooted like it sometimes does and was sitting at the screen for providing the decryption password for the storage for a long time, draining the battery and producing a lot of heat and getting decently warm. I finally noticed and logged in and the phone claimed that there was just 5% battery left. I plugged it into my computer as quickly as I could (USB A to C cable). My OS (Mobian Trixie) didn't indicate that it was plugged in so I tried the usual unplug, replug, unplug, plug in a different way, etc.

Then finally went to the power section of the settings program (I use Phosh) to see what was wrong. It indicated the battery health was good and was registering that the USB was there but not its voltage or current. Based on the discharge rate with the USB cable plugged and unplugged, not enough current was being drawn from the USB so the battery was steadily draining further just at a slower rate. I tried other chargers including the one I used every day, plugging into the USB C cable on my computer, a steamdeck charger, and an old pre USB-PD charger I still have, as well as trying some of these through the USB dock. Same result including not being able to read the USB voltage.

I turned it off and let it sit for several hours with the charger plugged in before turning it on again. No change in battery charge and continuing to drain.

So, I just unplugged it and removed the battery (to really really turn the whole thing off long enough that none of the capacitors and inductors would have any energy left in them) and let it sit.

Later, I put the battery back in and powered it up again. Same result as before. Though now it was registering the battery as 10%. I did not remember the battery voltage from before, so I do not know if it was higher or lower. Then, I flipped all the switches to turn off everything I could (modem, wifi, cameras, microphone) and the discharge rate dropped to nearly but not quite zero. But still no charging. Again, it was reporting that the battery health was good. I tested it again but this time with the modem on but not the rest. Battery was discharging despite being connected to an overkill USB power source.

From this, it was clear that at least one of the following was true

1. USB circuitry was bad and not enough current could be sourced
2. Battery was bad but in a way that the PMIC could tell but the rest of the system couldn't
3. PMIC or other power circuitry had gone bad (whether hardware or firmware)

I hooked the phone up into the PinePhone keyboard to see if I could eliminate possibilities (I had been intending to buy one for some time and decided to go ahead and do it since it could help diagnose). Same exact pattern. Can't charge the battery. The modem being on causes the battery to discharge even though the keyboard can supply more than enough power.

This seems to eliminate possibility 1 above, leaving only

1. Battery was bad but in a way that the PMIC could tell but the rest of the system couldn't
2. PMIC or other power circuitry had gone bad (whether hardware or firmware)

Based on what the battery diagnostics and its voltage, I am inclined to think that the battery itself is probably OK. It definitely wasn't at a low enough voltage to be unrecoverable -- 3.5 V or so (very drained and likely its lifespan reduced by it, but still should be OK).

This makes me think it is the PMIC or its support circuitry.

Am I missing a possibility, or is this the best guess that can be made?

If it is the PMIC, is it possible it is just a firmware issue (maybe firmware got corrupted)?

Otherwise, I am looking at having to replace the motherboard if I want to get my PinePhone working again, or replacing the phone outright (would go to the PinePhone Pro).
  Reply


Messages In This Thread
power circuit can't charge battery and can't supply enough power for modem or wifi - by vortex - 02-04-2024, 02:37 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinephone refusing to charge while suspended tiol 1 1,293 04-02-2024, 10:54 AM
Last Post: joH_N_Doe64
  Supported Carrier and Modem Bands NachoMomma 4 1,886 03-23-2024, 02:00 PM
Last Post: Kevin Kofler
  bluetooth wifi bugs aular 6 1,932 08-27-2023, 07:53 AM
Last Post: aular
  PinePhone constantly vibrating and won't take charge ImmyChan 5 5,804 07-23-2023, 03:49 PM
Last Post: kb-zealot
  Battery life improvement freelectro 10 3,966 06-01-2023, 08:27 PM
Last Post: KC9UDX
  Pinephone - broken power button rorus 10 9,854 05-18-2023, 09:11 AM
Last Post: kbm
Bug PinePhone modem keeps "disappearing" Kevin Kofler 14 6,568 03-22-2023, 05:28 PM
Last Post: Kevin Kofler
Thumbs Down Battery Issue or Power Management IC? bcoyle 2 1,734 03-20-2023, 12:54 AM
Last Post: bcoyle
  modem not working michelinux 0 1,031 02-16-2023, 04:56 AM
Last Post: michelinux
  modem not detected al_x 3 4,526 02-15-2023, 11:17 AM
Last Post: fxc

Forum Jump:


Users browsing this thread: 1 Guest(s)