Does latest Tow-Boot install/work correctly for everyone?
#1
After a few years of rocking a BSP img on my emmc (for that sweet S3) and not booting into it, I'd like to switch fully to a modern install of Fedora since I've been booting a pre EFI Fedora img from SD as my unofficial main boot.

Since Tow-Boot is needed for a modern Fedora install, I went and grabbed the latest version (2022.07-006) from Github. After writing spi.installer.img to several different and known working SDs, as well as using dd, nandwrite, and flashcp to write it directly to /dev/mtd0 (all indicated successful writes in terminal) I cannot get my PBP to boot into the installer menu, or show anything tow boot related at boot up when writing directly to the SPI. (At most, I get a solid-lit green power LED and a black screen when booting the SPI installer SD.)

I've also tried going back a few versions, including 2021.10-005 and 2021.10-03 (which I recall successfully booting and installing a year+ ago) and I get the same results from them too.

So I'm curious now if anyone else has had this or a similar issue when trying to install tow-boot through SD installer or writing directly to mtd0 from within a booted OS. I'd raise it as an issue on the Github, but I want to be sure I haven't overlooked any potential solutions and I know @samueldr has indicated he isn't able to be as active in maintaining/troubleshooting as before.

EDIT: it was pointed out, I should add the commands I've run to write the installer to SD, and the .bin to SPI. Please note, the SD card is read as sda by the system. 


dd (as per the tow-boot pbp page:
Code:
sudo dd if=spi.installer.img of=/dev/sda bs=1M oflag=direct,sync status=progress

nandwrite:
Code:
sudo nandwrite -p /dev/mtd0 Tow-Boot.spi.bin

flashcp:
Code:
sudo flashcp Tow-Boot.spi.bin /dev/mtd0

I ran 
Code:
sudo flash_erase /dev/mtd0 0 0
between each nandwrite or flashcp.
  Reply


Messages In This Thread
Does latest Tow-Boot install/work correctly for everyone? - by tophneal - 08-03-2023, 12:31 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  uboot wont boot to SD card after upgrade jbradley419 7 799 01-19-2024, 02:29 PM
Last Post: wdt
  Video Flashing/adjusting on boot and reboot jbradley419 0 286 01-16-2024, 09:17 AM
Last Post: jbradley419
  Brand new Pinebook Pro doesn't boot after Manjaro update johnboiles 8 2,210 12-15-2023, 02:11 PM
Last Post: wdt
  PBP won't boot after trying to reinstall Manjaro ARM soupgirl 3 686 12-13-2023, 08:17 PM
Last Post: trillobite
  Various freezes during boot & while running several Linux distros - hardware error? donuts 1 584 11-22-2023, 11:47 AM
Last Post: fxc
  Cannot boot to Kali SD card after uboot upgrade jbradley419 4 1,171 09-19-2023, 08:48 AM
Last Post: dachalife
  Boot into NVME drive, no wifi, sound, buttons... PaulQ 0 795 07-13-2023, 01:50 PM
Last Post: PaulQ
  New Pinebook pro won’t boot Generaltuxenburg 4 1,923 06-14-2023, 07:20 AM
Last Post: KC9UDX
  Followed the blog post to install Fedora: PBP not booting anymore koenigs 6 1,870 06-01-2023, 10:58 AM
Last Post: wdt
Tongue Yet another Pinebook Pro won't boot thread pinemouth 4 2,426 05-20-2023, 01:02 AM
Last Post: jackwilson

Forum Jump:


Users browsing this thread: 1 Guest(s)