Compile of Anbox fails because kernel function kallsyms_lookup_name() is unexported
#7
(06-29-2020, 06:20 PM)Tsvi Bar-David Wrote: Tophneal, thanks for you help!
I took your advice, enabled the anbox flags, and recompiled the arch linux kernel, and it looked like it got pretty far along, until it aborted with the following error message about the (mis)location of objtool.  Here is the last couple of lines emitted from makepkg:

INSTALL sound/usb/snd-usb-audio.ko
  INSTALL sound/usb/snd-usbmidi-lib.ko
  INSTALL sound/xen/snd_xen_front.ko
  INSTALL virt/lib/irqbypass.ko
  DEPMOD  5.7.6-arch1-1-anbox
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "linux-anbox"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Starting package_linux-anbox-headers()...  # i named my modified kernel:  linux-anbox
Installing build files...
install: cannot stat 'tools/objtool/objtool': No such file or directory
==> ERROR: A failure occurred in package_linux-anbox-headers().
    Aborting...

---
The line that fails in PKGBUILD seems to be 108:

# add objtool for external module building and enabled VALIDATION_STACK option
108  install -Dt "$builddir/tools/objtool" tools/objtool/objtool

It feels like I am so close ...
Thoughts?
Thanks,
Tsvi


Have you tried looking yet to see if you can find objtool on your system and correcting the PKGBUILD? Likely you just need to make a pull of the kernel repo and try your changes again.


Messages In This Thread
RE: Compile of Anbox fails because kernel function kallsyms_lookup_name() is unexported - by tophneal - 06-30-2020, 06:41 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  How to mainline kernel on daniel thompson's debian installer? hellojack 14 8,390 09-07-2023, 09:38 PM
Last Post: Der Geist der Maschine
  kernel module that supports usb-c hdmi alexandre 16 15,575 05-14-2023, 09:58 PM
Last Post: rathofkhan3
  NVME fails detection our0 1 949 01-30-2023, 08:45 AM
Last Post: Tazdevl
Question Debian (Vanilla) no output on display after Kernel update (6.0.8-1) as365n4 1 1,411 12-09-2022, 12:43 PM
Last Post: as365n4
  bootloader menu to pick a kernel - what is the current situation in in early 2022? maxtothemax 4 3,408 02-05-2022, 03:04 PM
Last Post: maxtothemax
  Kernel panics solostian 17 15,167 01-26-2022, 08:08 AM
Last Post: TRS-80
  Kernel 5.17 will improve VP9 support? jiyong 1 2,320 01-16-2022, 08:26 PM
Last Post: xmixahlx
  red/green power led not working with kernel 5.14 alchemist 4 4,096 11-04-2021, 04:09 AM
Last Post: alchemist
  Anyone tried Anbox-4-arm64 yet? tophneal 88 104,575 08-11-2021, 11:21 AM
Last Post: Proant
  Sound stuttering on Manjaro gnome after latest kernel upgrade? pjsf 0 1,901 07-13-2021, 10:37 PM
Last Post: pjsf

Forum Jump:


Users browsing this thread: 1 Guest(s)