On/Off Switch Pad Working Bad
#16
(06-27-2016, 11:11 AM)dhardingham Wrote: Once the CPU has been shutdown, the power switch can only be start the boot sequence when there is a battery attached. If there is no battery, the power will be turned off. Just odd!

This is exactly the same behaviour I have noticed - the power button requires a battery to be connected - I suspect a symptom of the fact that at heart the pine64 is the guts of a tablet computer... and they don't power up well without batteries! 

And as Mark pointed out, the power button sends keycode 116 to the kernel, so you can use that to trigger a power down with gnu+linux or re-purpose it for your own nefarious use! ;D 

This makes it (in my experience anyway):
  • power button - user programmable function once system running, powers up system IF a battery is connected
  • system led - user programmable / controllable
  • charge led - not functioning as APX registers aren't set correctly to use it
  • reset button - leave this one alone unless you want a corrupt file system Big Grin


Messages In This Thread
On/Off Switch Pad Working Bad - by RaspiBit - 05-12-2016, 12:51 PM
RE: On/Off Switch Pad Working Bad - by Ghost - 05-12-2016, 04:22 PM
RE: On/Off Switch Pad Working Bad - by RaspiBit - 05-13-2016, 04:19 PM
RE: On/Off Switch Pad Working Bad - by rodenti - 06-22-2016, 10:08 PM
RE: On/Off Switch Pad Working Bad - by Xabaras76 - 06-22-2016, 10:34 PM
RE: On/Off Switch Pad Working Bad - by Xabaras76 - 06-23-2016, 11:55 AM
RE: On/Off Switch Pad Working Bad - by Xabaras76 - 06-23-2016, 02:35 PM
RE: On/Off Switch Pad Working Bad - by xalius - 06-23-2016, 03:26 PM
RE: On/Off Switch Pad Working Bad - by Xabaras76 - 06-23-2016, 05:32 PM
RE: On/Off Switch Pad Working Bad - by Xabaras76 - 06-27-2016, 10:24 AM
RE: On/Off Switch Pad Working Bad - by pfeerick - 06-28-2016, 02:28 AM
RE: On/Off Switch Pad Working Bad - by pfeerick - 06-28-2016, 09:20 PM
RE: On/Off Switch Pad Working Bad - by DonFL - 06-28-2016, 01:11 PM
RE: On/Off Switch Pad Working Bad - by rvalecruz - 06-29-2016, 03:14 PM
RE: On/Off Switch Pad Working Bad - by DonFL - 06-29-2016, 03:45 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Working linux distribution that supports BT/Wifi on A64 Roverius 3 3,838 08-19-2019, 04:47 AM
Last Post: Roverius
  assistantpine, a working idea for a distro tohipfortheroom 1 2,718 01-22-2017, 02:56 AM
Last Post: tllim
  Support registration seems not to be working winterflaw 2 2,926 11-04-2016, 02:08 PM
Last Post: winterflaw
  UAE4Droid Amiga emulator not working Middleman 1 2,591 07-25-2016, 04:18 AM
Last Post: CaptainZalo
  Bluetooth not working reesh95 0 1,348 04-28-2016, 01:29 AM
Last Post: reesh95

Forum Jump:


Users browsing this thread: 1 Guest(s)