Facing difficulty in getting started with Ubuntu image
1. I downloaded longsleep image (xenial-pine64-bspkernel-20161218-1.img.xz) ! 
I burned image and booted too.

I do not have any monitor with me. I do not have any keyboard with me. (actually i do not want to use it.)
How, can i do it. I used different hardware, where device was connected to Laptop. When C.H.I.P. was connected to laptop, using usb cable, I do not need cable. I just need to use screen utility to login on any tty

I connected a monitor and keyboard to what is available.. after login, I tried, ifconfig. ifconfig do not show any wlan0. I have connected my wifi module to Pine64. so, ideally it should show wlan0 too. unable to find instruction on how to connect wifi.
the worst thing, I tried to connect with LAN cable.  router is very far from Work table. If I connect LAN cable, I cannot connect keyboard. So I thought , I can do ssh and let Pine64 to be connected on LAN cable without any keyboard.
When I connected with a LAN cable, It do not get any ip address. It should get ip address automatically, so that I can do a ssh. 
I am highly frustrated, I cannot get stated on this board.
Somehow, It is getting ip address. I can do a remote ssh and login too.
But problem is still same..
trying to get connected with Wifi !!
My Wifi is not working, I am using original Wifi module from Pine. I am also using original charge from Pine.
Here are my logs

ubuntu@pine64:~$ dmesg | grep wlan
[ 8.933130] sunxi-wlan wlan.27: wlan_busnum (1)
[ 8.938176] sunxi-wlan wlan.27: Missing wlan_power.
[ 8.943618] sunxi-wlan wlan.27: wlan_power_name ((null))
[ 8.949535] sunxi-wlan wlan.27: io_regulator_name (vcc-wifi-io)
[ 8.956150] sunxi-wlan wlan.27: wlan_regon gpio=354 mul-sel=1 pull=-1 drv_level=-1 data=0
[ 8.965684] sunxi-wlan wlan.27: wlan_hostwake gpio=355 mul-sel=6 pull=-1 drv_level=-1 data=0
[ 8.975497] sunxi-wlan wlan.27: clk not config
[ 13.730099] sunxi-wlan wlan.27: bus_index: 1
[ 13.745621] sunxi-wlan wlan.27: check wlan io_regulator voltage: 1800000
[ 14.193745] RTL871X: rtw_ndev_init(wlan0)
[ 14.207622] RTL871X: rtw_ndev_init(wlan1)

ubuntu@pine64:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 36:d5:2b:db:21:7b
inet addr: Bcast: Mask:
inet6 addr: fe80::34d5:2bff:fedb:217b/64 Scope:Link
RX packets:512 errors:0 dropped:0 overruns:0 frame:0
TX packets:332 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:44625 (44.6 KB) TX bytes:43405 (43.4 KB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:80 errors:0 dropped:0 overruns:0 frame:0
TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5920 (5.9 KB) TX bytes:5920 (5.9 KB)

Detailed logs available at - https://gist.github.com/nsisodiya/925b80...9ae26b9ee4
Wifi working... - followed instructions on - http://forum.pine64.org/showthread.php?t...&pid=18823
Glad you got it working. For these sort of questions, if you can't find the answer in the forum, it may be a good idea to ask in the chat first --- there is a chance that someone will know the answer or will be able to point you to the right forum thread.
You can find me on IRC, Discord and Twitter


Possibly Related Threads…
Thread Author Replies Views Last Post
  Ubuntu server 20.04 request phi0x 2 1,641 12-30-2020, 08:02 PM
Last Post: phi0x
  Xenial Minimal Image (PINE A64(+)) 0.6.2-77 pineadmin 4 13,603 08-30-2020, 10:35 AM
Last Post: jrronimo
  Kickstarter P64 with LCD, working image? MostHated 1 2,214 01-04-2020, 10:32 AM
Last Post: igorp
  Allwinner A64 RTC bug fix on bionic image? tkaivola 1 2,406 02-01-2019, 05:09 AM
Last Post: tllim
  SPI on ubuntu IlyaM 4 5,193 07-16-2018, 03:00 AM
Last Post: kingflab
  Ubuntu password not working joemassimino 4 4,676 05-18-2018, 03:33 PM
Last Post: Luke
  After flashing Ubuntu- how to get graphical desktop Partymack711 6 6,134 02-01-2018, 09:45 AM
Last Post: Partymack711
  (ARCHIVED) Ubuntu Xenial Image (BSP Kernel) longsleep 337 371,071 01-31-2018, 11:58 AM
Last Post: Luke
  PPTP doesnt work with ubuntu escovedo 2 5,448 08-23-2017, 09:28 AM
Last Post: gilbertotcc
Question HELP Ubuntu Mate password recovery procedure Captain Anni Hilator 5 6,009 08-03-2017, 03:52 PM
Last Post: Luke

Forum Jump:

Users browsing this thread: 1 Guest(s)