Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums



(Advanced Search)

Forum Statistics
» Members: 28,184
» Latest member: Gill0319
» Forum threads: 15,709
» Forum posts: 114,675

Full Statistics

Latest Threads
Netbds10.0 on Rock64 not ...
Forum: BSD on Rock64
Last Post: KC9UDX
Yesterday, 10:23 AM
» Replies: 3
» Views: 34
bookworm vs trixie discus...
Forum: Mobian on PinePhone
Last Post: treebeard
Yesterday, 07:58 AM
» Replies: 27
» Views: 2,860
USB charging is unreliabl...
Forum: PinePhone Pro Hardware
Last Post: lightwo
Yesterday, 04:29 AM
» Replies: 0
» Views: 33
Calls: ALSA UCM config no...
Forum: PinePhone Pro Software
Last Post: lightwo
Yesterday, 04:23 AM
» Replies: 6
» Views: 292
how to enable /dev/i2c-0 ...
Forum: Getting Started
Last Post: Pavlos1
Yesterday, 12:04 AM
» Replies: 1
» Views: 70
Official Debian support
Forum: Linux on Pinebook Pro
Last Post: rempfer
05-16-2024, 11:00 PM
» Replies: 63
» Views: 52,600
Android Gaming Image
Forum: Game Station Emulation
Last Post: Abeldean
05-16-2024, 09:18 PM
» Replies: 51
» Views: 76,152
upgrading u-boot--what ve...
Forum: General Discussion on Pinebook Pro
Last Post: bsammon
05-16-2024, 05:59 PM
» Replies: 0
» Views: 45
PineTime for kid
Forum: General
Last Post: KC9UDX
05-16-2024, 03:35 AM
» Replies: 1
» Views: 121
WiFi Walkie Talkies?
Forum: General
Last Post: KC9UDX
05-16-2024, 03:28 AM
» Replies: 3
» Views: 130

 
  Reboot ending with INFINI TIME w/ 2 triangles
Posted by: plainsman - 03-26-2024, 07:24 AM - Forum: General Discussion on PineTime - No Replies

Attempting to set up sealed watch - able to set it up as a watch and was able to get it to pair with my android phone via gadgetbridge.  But attempts to install 1.14 INFINI time failed with "element can not be installed".  Held button and it goes through the White/GREEN pinecone (V 1.0.0) then goes to INFINI Time logo.  Then nothing.  However, when texts come in, the watch vibrates.

UPDATE: Let the phone drain, recharged - could connect via gadgetbridge for file transfer purposes - updated it using pinetime-mcuboot-app-dfu.1.14.0.zip. Watch came back to life.


  PinePhone only turns on sometimes
Posted by: zvavybir - 03-25-2024, 06:44 AM - Forum: PinePhone Pro Hardware - Replies (1)

Since a long time my PinePhone only turned on by trying twice (i.e. pressing the Power On button, taking out the battery, putting it back in, pressing the Power On button again).  At the first turning on, the LED was shortly on and shortly thereafter the phone rumbled.  This was annoying, but not annoying enough to try to fix it.

But then I didn't use it for the last two weeks (as I didn't need a phone during that time) and now even trying it twice doesn't work reliable (I did get it on twice still, so I'm pretty confident that it's still possible, but I don't know how and I sadly turned it off yesterday).  The failing starts still looks like back when trying twice worked (i.e. LED+rumble).

I'm pretty confident that it's not a battery issue because the same thing happens with only the battery in, with only a (good) charging cable and with battery and charging cable at the same time.

Googling didn't help this time (the first of the two times I got it to work was after trying to push the Reset Button as I read on the internet, but this seems to just have been an accident – or at least it doesn't work now), so any help is appreciated, thanks!


  irradium (based on crux linux) Rock64 riscv64, aarch64
Posted by: mara - 03-24-2024, 01:07 PM - Forum: Linux on Rock64 - No Replies

irradium - source based Linux distribution CRUX adhering to ideology keep it simple, has its own package system, also supports the port system.

irradium development

packages aarch64
packages riscv64

installation README.TXT
kernel 6.8.1

irradium-3.7-aarch64-core-rock64-6.8.1-build-20240324.img.zst
irradium-3.7-aarch64-core-rock64-6.8.1-build-20240324.img.zst.sha256
irradium-3.7-aarch64-xfce-rock64-6.8.1-build-20240324.img.zst
irradium-3.7-aarch64-xfce-rock64-6.8.1-build-20240324.img.zst.sha256


  quick question about mic
Posted by: Ferriah - 03-23-2024, 09:20 AM - Forum: PinePhone Hardware - Replies (3)

hey all,

for a long time I thought my mic problems were software related, as it would sometimes work. most of the time I was barely audible on calls with static, and now there is dead silence

after trying many different distros with no improvement I've come to the conclusion that something is physically wrong with the mic. in the past I did drop the phone a few times, and eventually replaced the screen (had a crack across the top.) other than that the phone hasn't had any other damages, and everything else works fine

I wanted to ask where exactly is the mic in the phone? I assumed that it would be on the usb board, but don't really see much there. everything looks to be connected properly. Since the mic works sometimes, I think there might be a way to fix it before resorting to buying a replacement part


  systemic issue pinephone
Posted by: penguins_rule - 03-21-2024, 03:36 PM - Forum: Manjaro on PinePhone - Replies (3)

Hi all-

I bought a regular pinephone (beta).

It seems to want to install booting emmc first.
Being a newbie, I flashed spi on it.
It boots and hands it off to k splash for plasma manjaro.

Then it peters out with a kernel os error.

Pinephone support says reinstall OS which I am attempting to do.

Two things:
1) the pinephone doesnt synch with my pc at this time windows 11.
2) I cant get into the boot order in  the firmware or reset in any way shape or form.

I have another thread posted today where i am debugging this issue but am waiting for further feedback.

It seems strange the choice to go with emmc first because 'stranger things HAVE happened' lol.

Please HELP.... thanks,
jim


  debugging issue realted to iso image wth extra data eror
Posted by: penguins_rule - 03-21-2024, 03:28 PM - Forum: Manjaro on PinePhone - Replies (3)

Hi all-

I work with the ai.

I ran this line:
dd if=shared.disk-image.img of=shared.disk-image.iso

I get this error:

Code:
/c/msys64/mingw64/bin/7z x /c/Users/myuser/Downloads/is02/shared.disk-image.iso

7-Zip 23.01 (x64) : Copyright (c) 1999-2023 Igor Pavlov : 2023-06-20

Scanning the drive for archives:
1 file, 5250048 bytes (5127 KiB)

Extracting archive: C:\Users\myuser\Downloads\is02\shared.disk-image.iso

0.Firmware (Tow-Boot).img
ERRORS:
There are data after the end of archive

--
Path = C:\Users\myuser\Downloads\is02\shared.disk-image.iso
Type = GPT
Physical Size = 5250048
ID = E0CA6E57-39B2-4482-9838-21E2785CD93D
----
Path = 0.Firmware (Tow-Boot).img
Size = 4194304
File System = 67401509-72E7-4628-B1AF-EDD128E4316A
Characteristics = Sys
Offset = 8192
ID = CE8F2026-17B1-4B5B-88F3-3E239F8BD3D8
--
Path = 0.Firmware (Tow-Boot).img
Type = gzip
ERRORS:
There are data after the end of archive
Offset = 617544
Physical Size = 3149
Tail Size = 3573611
Headers Size = 10
Streams = 1

ERROR: There are some data after the end of the payload data : 0.Firmware (Tow-Boot)

Sub items Errors: 1

Archives with Errors: 1

Open Errors: 1

Sub items Errors: 1

so the issue was per ai to check and see if the file is corrupted so i with the ai help came up with this:

Quote:python.exe test.py
  File "/c/Users/myuser/Downloads/is02/test.py", line 5
    p = subprocess.Popen(["PYTHONPATH=$PYTHONPATH:/c/msys64/usr/bin", 'python", "/usr/bin/binwalk", "-e", "shared.disk-image.img"], stdout=subprocess.PIPE, stderr=subprocess.PIPE)
                                                                      ^
SyntaxError: unterminated string literal (detected at line 5)
mycomputer@name MSYS /c/Users/myuser/Downloads/is02
$ python.exe test.py
Traceback (most recent call last):
  File "/c/Users/myuser/Downloads/is02/test.py", line 5, in <module>
    p = subprocess.Popen(["PYTHONPATH=$PYTHONPATH:/c/msys64/usr/bin", "python", "/usr/bin/binwalk", "-e", "shared.disk-image.img"], stdout=subprocess.PIPE, stderr=subprocess.PIPE)
        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/lib/python3.11/subprocess.py", line 1026, in __init__
    self._execute_child(args, executable, preexec_fn, close_fds,
  File "/usr/lib/python3.11/subprocess.py", line 1953, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: 'PYTHONPATH=$PYTHONPATH:/c/msys64/usr/bin'

mycomputer@name MSYS /c/Users/stealth_droid/Downloads/is02
$ python.exe test.py
Exit code: 0

#!/usr/bin
import subprocess

# Execute the Binwalk command
p = subprocess.Popen([ "python", "/usr/bin/binwalk", "-e", "shared.disk-image.img"], stdout=subprocess.PIPE, stderr=subprocess.PIPE)

# Communicate with the Binwalk command and get the output and error messages
output, error = p.communicate()

# Check the exit code of the Binwalk command
exit_code = p.returncode

# Print the exit code
print("Exit code:", exit_code)
so the issue then becomes 0 error code no error.


the output is a file named:
0.Firmware (Tow-Boot)

what other outputs would i expect after unpacking the tow-boot with 7zip?

thanks for any input.

jim


  PinePhone Pro silver lining, it’s fast, real damn fast
Posted by: ashoka232 - 03-20-2024, 01:45 AM - Forum: General Discussion of PinePhone Pro - No Replies

There’s been a lot of grumbling the last few days among my friends about PPP and various power issues. Frankly, it makes a person a bit paranoid to enjoy their new device. As soon as I got it I mentally made note:

  1. don’t even attempt to upgrade packages
  2. take out the battery the instant you are done
  3. find some way to prevent deep sleep
  4. keep plugged in at all times https://www.fuelly.com/forums/f8/loose-g...22996.html
All that worry aside, a small little part of my brain is smiling about how fast it is. I knew as soon as I got it I would have a gut check about whether it’s speed would be tolerable or not. I can safely say yes.
Web browser loaded up Reddit just fine and scrolling felt good.
I’m eager to get to work with some gesture control phone experiments I want to do. This phone is going to be a winner.


  pinephone can provide more than 500mA to a usb-c displayport device?
Posted by: unrznbl - 03-19-2024, 01:02 PM - Forum: PinePhone Hardware - Replies (2)

I am wanting to use Xreal air glasses with my pinephone. I have the manjaro edition so don't think there are usb-c issues with the hardware.

I see in log messages in dmesg that the anx7688 driver sets a 500mA limit when the glasses are plugged in.

I confirmed with the manufacturer that 1A is needed.

I see good info from xrandr and such but the glasses won't turn on due to lack of current I suppose due to this 500mA limit.

I couldn't find any information on wiki pages or anx7688 product brief to tell me if I could increase the limit to a different value, say 2100 mA or 3000 mA as I might expect from a USB 3.1 device.


  link for supported pinephone os manjharo et all
Posted by: penguins_rule - 03-19-2024, 09:53 AM - Forum: Manjaro on PinePhone - Replies (3)

Hi-

the images at the manjaro site only have a checksum and the site looks funny like no CSS styling is applied.  It is just a bunch of hyperlinks.
Mobian didnt have a way to verify either.

I am desperate for an image. Can someone point me somewhere there is a cool image i can use with the pinephone that is supported?
I like manjaro gnome but v16 aiin't workin.

thanks,
jim


  Not receiving SMS messages
Posted by: squiggums - 03-19-2024, 12:43 AM - Forum: Manjaro on PinePhone - No Replies

Hey

I am a fairly new user, just got my phone set up with a new SMS, installed all the updates etc etc.

I seem to be able to send SMS messages, but I only receive them some of the time. The last three people who have tried to send me an SMS message they did not go through. I didn't get any notification and they don't show up in my messages.

SMS app being used is Spacebar
Phone app in use is just "Phone"

The notifications for SMS when the phone is in sleep mode are also a bit dodgy/unreliable, but I am more concerned with not getting any message or notification at all when people are trying to contact me.

Any help would be appreciated, thanks!

OS: Manjaro-ARM
KDE Plasma Version: 5.25.2
Kernel Version: 5.19.9-1-MANJARO-ARM