Testing a broken Vulkan driver
#1
After reading this post that someone has Vulkan working on the Pinephone Pro, I tried it on the Pinebook Pro.
https://www.reddit.com/r/pinephone/comme...rk_on_the/

You have to add the following line to /etc/environment
PAN_I_WANT_A_BROKEN_VULKAN_DRIVER=1
And reboot.

So I tested with Manjaro and you have to be on Wayland.

I have the following Vulkan packages installed:
vulkan-headers
vulkan-icd-loader
vulkan-mesa-layers
vulkan-panfrost
vulkan-tools

And the vkcube demo only works for me when I run the Wayland version: vkcube-wayland
So far I haven't found anything useful.
PPSSPP doesn't work with Vulkan on Linux ARM and I can't start a game with AetherSX2.
Perhaps there are some other things we can try to test?

https://youtu.be/657hnmSMYd
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Broken eMMC boot annahellrothsparent 3 1,221 04-28-2022, 07:31 AM
Last Post: tophneal
Question Manjaro arm + sway - battery indicator broken mfashby 6 4,971 02-20-2021, 04:07 AM
Last Post: mfashby
  Xorg graphics driver? rdenthem 2 3,247 08-28-2020, 09:21 AM
Last Post: rdenthem
  Printer driver lib32-glibc dependency definitiv. 4 4,371 07-05-2020, 08:04 AM
Last Post: wdt
Exclamation LibreOffice Toolbar Rendering Broken davemaps 0 1,346 06-11-2020, 08:11 AM
Last Post: davemaps
  Bluetooth Debian Testing wasgurd 15 10,501 01-21-2020, 11:10 PM
Last Post: xmixahlx

Forum Jump:


Users browsing this thread: 1 Guest(s)