Booting Quartz64 Model B
#1
Hello,

I'm new with setting up a Linux distribution on a board. After receiving my two Quartz64 I tried to flash several images on a microSD and afterwards tried to boot the board. Additionally I have connected a 24" monitor on the HDMI Port, a LAN-cable at the ethernet adapter, a power adapter (12V 3.5A 42W) and mouse & tastatur at the USB-ports.

But it seems there isn't even a booting sequence, my monitor doesn't show any command line and only the power LED is shining blue.
I tried to press the power button several times but nothing seems to work. BAT_Jumper is sticked on the board too.

I tried the following OS:
I looked through several posts in this forum but couln't find an answer. From my understanding I should see at least a command line even if the OS isn't set up yet.
I tested everything with both Quartz64 to exclude the possibility that there is a boot error or any defect with my board.
Since I never have set up a board before, am I doing something fundamentally wrong?
  Reply
#2
Try Armbian https://github.com/armbian/build/releases/tag/latest ... its not perfect, this hw is no officially support, but you have much greater chances of success.
  Reply
#3
(06-26-2022, 09:30 AM)igorp Wrote: Try Armbian https://github.com/armbian/build/releases/tag/latest ... its not perfect, this hw is no officially support, but you have much greater chances of success.

Thank you that worked fine for me! My quartz64b has booted finally Smile

Do you have any explaination why all other official supported OS didn't work for me but for others?
  Reply
#4
> Do you have any explanation

None.
  Reply
#5
i'm having the same struggle getting the model B to boot! i tried both manjaro and arch instructions from the wiki with no luck...
manjaro failed with a null pointer deref during boot, and with arch the processor tried to self immolate / burn a hole in my desk.

> Thank you that worked fine for me! My quartz64b has booted finally

since there isn't a model b image, which one did you use?
  Reply
#6
(07-15-2022, 12:25 AM)ryankurte Wrote: and with arch the processor tried to self immolate / burn a hole in my desk.

You were probably using the wrong device tree, Arch's kernel package doesn't yet have a Model B device tree so you'd have to bring your own.

I've just received my Model B so I'll look into updating the Arch instructions for it and provide a pre-compiled device tree.

Edit: Updated the Arch instructions on the wiki for the Model B

Occasional Linux Kernel Contributor, Avid Wiki Updater, Ask Me About Quartz64
Open Hardware Quartz64 Model A TOSLink Adapter
Pi-bus GPIO Extender For ROCKPro64 And Quartz64
  Reply
#7
Quote:> You were probably using the wrong device tree, Arch's kernel package doesn't yet have a Model B device tree so you'd have to bring your own.

Edit: Updated the Arch instructions on the wiki for the Model B


amazing, thanks for you help!

the `dtb` certainly gets me further (and no longer has the thermal problems). i'm trying to boot from SD without an eMMC fitted and seeing a bunch of errors configuring `mmc0` at different speeds (which makes sense because there's no eMMC), but then can't find the `rootfs` partition (by label or UUID) like it's stopped talking to the SD card too...


Code:
[    1.024380] mmc_host mmc0: Bus speed (slot 0) = 150000000Hz (slot req 150000000Hz, actual 150000000HZ div = 0)
[    1.026003] dwmmc_rockchip fe2b0000.mmc: All phases bad!
[    1.026473] mmc0: tuning execution failed: -5
[    1.026869] mmc0: error -5 whilst initialising SD card
[    1.045839] dwmmc_rockchip fe2b0000.mmc: failed to set rate 300000Hz
[    1.046406] mmc_host mmc0: Bus speed (slot 0) = 150000000Hz (slot req 300000Hz, actual 300000HZ div = 250)
[    1.062177] dwmmc_rockchip fe2b0000.mmc: failed to set rate 300000Hz
[    1.065473] dwmmc_rockchip fe2b0000.mmc: failed to set rate 300000Hz
[    1.068023] mmc_host mmc2: Bus speed (slot 0) = 375000Hz (slot req 400000Hz, actual 375000HZ div = 0)
[    1.072724] dwmmc_rockchip fe2b0000.mmc: failed to set rate 300000Hz
[    1.076013] dwmmc_rockchip fe2b0000.mmc: failed to set rate 300000Hz
[    1.161369] mmc_host mmc2: Bus speed (slot 0) = 50000000Hz (slot req 50000000Hz, actual 50000000HZ div = 0)
[    1.165029] mmc2: new high speed SDIO card at address 0001
[    1.202016] dwmmc_rockchip fe2b0000.mmc: failed to set rate 300000Hz
[    1.212939] dwmmc_rockchip fe2b0000.mmc: failed to set rate 300000Hz
[    1.214583] dwmmc_rockchip fe2b0000.mmc: failed to set rate 300000Hz
[    1.215155] mmc_host mmc0: Bus speed (slot 0) = 150000000Hz (slot req 150000000Hz, actual 150000000HZ div = 0)
[    1.216751] dwmmc_rockchip fe2b0000.mmc: All phases bad!
[    1.217219] mmc0: tuning execution failed: -5
[    1.217604] mmc0: error -5 whilst initialising SD card
[    1.236530] dwmmc_rockchip fe2b0000.mmc: failed to set rate 200000Hz
[    1.237104] mmc_host mmc0: Bus speed (slot 0) = 150000000Hz (slot req 200000Hz, actual 200000HZ div = 375)
[    1.251633] dwmmc_rockchip fe2b0000.mmc: failed to set rate 200000Hz
[    1.254832] dwmmc_rockchip fe2b0000.mmc: failed to set rate 200000Hz
[    1.259294] dwmmc_rockchip fe2b0000.mmc: failed to set rate 200000Hz
[    1.262491] dwmmc_rockchip fe2b0000.mmc: failed to set rate 200000Hz
[    1.384649] dwmmc_rockchip fe2b0000.mmc: failed to set rate 200000Hz
[    1.391110] dwmmc_rockchip fe2b0000.mmc: failed to set rate 200000Hz
[    1.392281] dwmmc_rockchip fe2b0000.mmc: failed to set rate 200000Hz
[    1.392853] mmc_host mmc0: Bus speed (slot 0) = 150000000Hz (slot req 150000000Hz, actual 150000000HZ div = 0)
[    1.394438] dwmmc_rockchip fe2b0000.mmc: All phases bad!
[    1.394914] mmc0: tuning execution failed: -5
[    1.395300] mmc0: error -5 whilst initialising SD card
[    1.414209] dwmmc_rockchip fe2b0000.mmc: failed to set rate 100000Hz
[    1.414783] mmc_host mmc0: Bus speed (slot 0) = 150000000Hz (slot req 100000Hz, actual 100000HZ div = 750)
[    1.430429] dwmmc_rockchip fe2b0000.mmc: failed to set rate 100000Hz
[    1.433716] dwmmc_rockchip fe2b0000.mmc: failed to set rate 100000Hz
[    1.440698] dwmmc_rockchip fe2b0000.mmc: failed to set rate 100000Hz
[    1.443975] dwmmc_rockchip fe2b0000.mmc: failed to set rate 100000Hz
[    1.569603] dwmmc_rockchip fe2b0000.mmc: failed to set rate 100000Hz
[    1.580116] dwmmc_rockchip fe2b0000.mmc: failed to set rate 100000Hz
[    1.581717] dwmmc_rockchip fe2b0000.mmc: failed to set rate 100000Hz
[    1.582279] mmc_host mmc0: Bus speed (slot 0) = 150000000Hz (slot req 150000000Hz, actual 150000000HZ div = 0)
[    1.583891] dwmmc_rockchip fe2b0000.mmc: All phases bad!
[    1.584360] mmc0: tuning execution failed: -5
[    1.584754] mmc0: error -5 whilst initialising SD card
  Reply
#8
It is reported that the 'sd-uhs-sdr104' configuration does not work.

See the following thread::
    Manjaro Image June 2022
    https://forum.pine64.org/showthread.php?tid=16790
    Bullet64's site has an introduction to the git-hub on this subject

We recommend that you check the 'dtb' you used and if it corresponds to the above, change it to 'sd-uhs-sdr50' and try again.
If that doesn't work, try 'sd-uhs-sdr25' -> 'sd-uhs-sdr12'... or even lower.
  Reply
#9
Oh right, the SD card thing. (I didn't notice as I tested on a slow SD card)

Try this dtb, if it works I'll replace the one on the wiki: https://overviewer.org/~pillow/up/5f1fab...tz64-b.dtb

Edit: I put that on the wiki as it booted for me so doesn't make things any worse.
Edit2: Ordered a fast SD card to see if I can reproduce the original issue, and then will upstream the fix for this if I can and can confirm lowering the speed to 50 fixes it reliably.

Occasional Linux Kernel Contributor, Avid Wiki Updater, Ask Me About Quartz64
Open Hardware Quartz64 Model A TOSLink Adapter
Pi-bus GPIO Extender For ROCKPro64 And Quartz64
  Reply
#10
thanks again for all the assistance! that gets me further (up to mounting the file system), with another kernel panic:

Code:
:: performing fsck on '/dev/mmcblk0p5'
rootfs: clean, 33904/917504 files, 177393/3666688 blocks
:: mounting '/dev/mmcblk0p5' on real root
[    2.861970] EXT4-fs (mmcblk0p5): mounted filesystem with ordered data mode. Opts: (null). Quota mode: none.
:: running cleanup hook [udev]
/sbin/init: error while loading shared libraries: /usr/lib/libse[    3.001700] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00007f00
ccomp.so.2: file too short
[    3.002834] CPU: 1 PID: 1 Comm: init Not tainted 5.16.13-1-aarch64-ARCH #1
[    3.003639] Hardware name: Pine64 RK3566 Quartz64-B Board (DT)
[    3.004151] Call trace:
[    3.004367]  dump_backtrace+0x0/0x1cc
[    3.004703]  show_stack+0x18/0x24
[    3.004997]  dump_stack_lvl+0x68/0x84
[    3.005324]  dump_stack+0x18/0x34
[    3.005619]  panic+0x138/0x308
[    3.005892]  do_exit+0x3e8/0x3ec
[    3.006182]  do_group_exit+0x38/0xa0
[    3.006498]  __arm64_sys_exit_group+0x18/0x20
[    3.006883]  invoke_syscall+0x48/0x114
[    3.007216]  el0_svc_common.constprop.0+0x44/0xfc
[    3.007629]  do_el0_svc+0x28/0x90
[    3.007925]  el0_svc+0x28/0x80
[    3.008197]  el0t_64_sync_handler+0xa4/0x130
[    3.008575]  el0t_64_sync+0x1a0/0x1a4
[    3.008903] SMP: stopping secondary CPUs
[    3.009255] Kernel Offset: disabled
[    3.009562] CPU features: 0x20,00000203,46600e46
[    3.009968] Memory Limit: none
[    3.010242] ---[ end Kernel panic - not syncing: Attempted to kill init! exitcode=0x00007f00 ]---

i would think if the `fsck` succeeds the SD card / interface is okay, but will try with another cleanly formatted card in case it's some error in the copying over

Edit: swapped SD cards (from a 10MB/s SDHC UHS class 1 to a 30MB/s SDXC UHS class 3), setup -exactly- the same (i wrote a script) and now we _seem_ to be up and running
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  The "Should I buy a Quartz64 right now?" flow chart CounterPillow 3 1,699 07-13-2022, 09:50 AM
Last Post: CounterPillow
Tongue Trying to get Quartz model A working fasani 0 226 06-09-2022, 06:30 AM
Last Post: fasani
  Has the Quartz64 Model B project been canceled? Silver 8 2,959 05-03-2022, 11:56 AM
Last Post: CounterPillow
  Quartz64 Model A & B benchmarks vs. RK3399 sbc's Silver 5 5,028 02-11-2022, 09:10 PM
Last Post: stuartiannaylor
  Quartz64 Model-A 8GB board boot error d4s 6 2,696 01-25-2022, 08:32 AM
Last Post: d4s
  can quartz64 boot without blobs greentree 1 843 01-08-2022, 11:56 PM
Last Post: CounterPillow
  Quartz64 max PCIE power? nixcamic 1 785 12-06-2021, 01:07 PM
Last Post: CounterPillow
  sub forum for Android on Quartz64? dieselnutjob 2 1,267 10-01-2021, 02:44 PM
Last Post: dieselnutjob
  Quartz64 Model B release date? Silver 7 4,759 08-15-2021, 06:20 PM
Last Post: Silver
  JTAG/SWD on Quartz64 model A capablegh 2 1,798 08-12-2021, 02:29 PM
Last Post: capablegh

Forum Jump:


Users browsing this thread: 1 Guest(s)