ROCKPro64 DOA
#1
I bought a ROCKPro64 about a year ago, but have only just taken it out of the box and tested it to find it DOA (Dead On Arrival). I contacted Pine64 sales about getting a replacement and although they replied quickly, they just told me to raise a support ticket, which I did. However, I've been waiting six days without a response and reading other messages here about ROCKPro's being DOA I'm concerned that Pine64 support is non-existent.

I also have a Pinebook Pro that was delivered with two ';' keys and a missing 'H' key - It took months to resolve that problem until they eventually sent me a replacement 'H' key and I managed to pries off the incorrectly positioned keys and replace them in their correct positions. Like everyone else here, I support the objectives of Pine64, but the lack of support and unwillingness to RMA faulty products seriously detracts from their stated objective to create good hackable hardware at affordable prices.

I've tried connecting a USB-TTL adapter to the UART pins on the GPIO connector of my ROCPro64, but nothing is being output: There is only one green LED illuminated on the board, but the NIC led's are on solid. It makes no difference if I have an eMMC chip or SD-card in, but I was hoping to see "uboot" output as I do on the Pinebook Pro over the UART serial lines. Has anyone got advice about how to check if my ROCKPro64 board is dead or not?

Thanks,

  Tony.
  Reply
#2
(11-23-2021, 07:18 PM)ajtravis Wrote: I bought a ROCKPro64 about a year ago, but have only just taken it out of the box and tested it to find it DOA (Dead On Arrival). I contacted Pine64 sales about getting a replacement and although they replied quickly, they just told me to raise a support ticket, which I did. However, I've been waiting six days without a response and reading other messages here about ROCKPro's being DOA I'm concerned that Pine64 support is non-existent.

I also have a Pinebook Pro that was delivered with two ';' keys and a missing 'H' key - It took months to resolve that problem until they eventually sent me a replacement 'H' key and I managed to pries off the incorrectly positioned keys and replace them in their correct positions. Like everyone else here, I support the objectives of Pine64, but the lack of support and unwillingness to RMA faulty products seriously detracts from their stated objective to create good hackable hardware at affordable prices.

I've tried connecting a USB-TTL adapter to the UART pins on the GPIO connector of my ROCPro64, but nothing is being output: There is only one green LED illuminated on the board, but the NIC led's are on solid. It makes no difference if I have an eMMC chip or SD-card in, but I was hoping to see "uboot" output as I do on the Pinebook Pro over the UART serial lines. Has anyone got advice about how to check if my ROCKPro64 board is dead or not?

Thanks,

  Tony.

When you say your RockPro64 is DOA, when you apply power is there any activity at all. I'm using my board booting off Armbian Focal 5.10 kernel via an SD card. I've a beefy 12v 5a power supply attached, sourced elsewhere to avoid under voltage issues. Have you tried an alternative power supply just to rule that issue out. Keep the board as stripped down as possible before you attempt to boot it.
  Reply
#3
(11-30-2021, 12:41 PM)Rocklobster Wrote: [...]

When you say your RockPro64 is DOA, when you apply power is there any activity at all. I'm using my board booting off Armbian Focal 5.10 kernel via an SD card. I've a beefy 12v 5a power supply attached, sourced elsewhere to avoid under voltage issues. Have you tried an alternative power supply just to rule that issue out. Keep the board as stripped down as possible before you attempt to boot it.

Hi,

There was no activity at all when I wrote an eMMC image and tried to boot from it, but a friend managed to get it to boot Debian Buster from an SD card: I was expecting to see Uboot output from the UART on the serial lines, when booting from the eMMC but there was nothing. We are now trying to reflash the SPI to run Uboot from there. Seems it's not DOA after all, but it was not clear to me that I would have to boot from an SD card even if I had created an eMMC image. Seems that, by default, the ROCKPro64 will not boot from eMMC.

Thanks,

  Tony.
  Reply
#4
(11-30-2021, 01:02 PM)ajtravis Wrote:
(11-30-2021, 12:41 PM)Rocklobster Wrote: [...]

When you say your RockPro64 is DOA, when you apply power is there any activity at all. I'm using my board booting off Armbian Focal 5.10 kernel via an SD card. I've a beefy 12v 5a power supply attached, sourced elsewhere to avoid under voltage issues. Have you tried an alternative power supply just to rule that issue out. Keep the board as stripped down as possible before you attempt to boot it.

Hi,

There was no activity at all when I wrote an eMMC image and tried to boot from it, but a friend managed to get it to boot Debian Buster from an SD card: I was expecting to see Uboot output from the UART on the serial lines, when booting from the eMMC but there was nothing. We are now trying to reflash the SPI to run Uboot from there. Seems it's not DOA after all, but it was not clear to me that I would have to boot from an SD card even if I had created an eMMC image. Seems that, by default, the ROCKPro64 will not boot from eMMC.

Thanks,

  Tony.

I didn't think so. The SD card route is usually the best route when testing these boards. I've a number of Rock64 boards as well as this RockPro64 board that were junked. I picked them up at a very reasonable price and used Armbian on an SD card. They all booted fine. From there you can test different distros or different boot mediums once you've ruled out hardware problems. Nothing worse than owning an electrical door stop or bookend. Glad you got things resolved.
  Reply
#5
I've closed my support ticket now - Very disappointed about the lack of support from Pine64, but a friend of mine solved the problem for me. it would be nice if Pine64 made it clear that the only way to boot a new ROCKPro64 is using an SD-card and the SPI is not functional by default.
  Reply
#6
(12-04-2021, 05:59 AM)ajtravis Wrote: I've closed my support ticket now - Very disappointed about the lack of support from Pine64, but a friend of mine solved the problem for me. it would be nice if Pine64 made it clear that the only way to boot a new ROCKPro64 is using an SD-card and the SPI is not functional by default.

I get the feeling you're on your own now when it comes to the Rock series of boards. It really is a case use whatever Distro boots for you. When they do boot they are very stable. I've Armbian Buster running on one Rock64, Android 9 on another and LibreElec running on a RockPro64. All running 24/7 from an SD card and so far no problems. Once you're not hammering the SD card with multiple writes its a safe enough medium to use.
  Reply
#7
These boards, without a BIOS/POST like a PC, can be a bit perplexing - they look dead when they're just running an odd build. I remember buying my first PINE device, a 64 A+, and it just sat in a box - I fired it up and nothing. No idea what was going on. Started messing with different builds and it's been running for 5 years with almost zero interruption other than a rare outage (when I haven't had it sipping the juice from my UPS) or reboots after kernel/major armbian upgrades.

they are really some of the coolest little SBCs around, but they are definitely for the patient. I'll walk away sometimes and come back, try a different distro/build, and all is right with the world. Now I feel like building the 4 or 5 devices I haven't done anything with yet, heh
------
it doesn't get happy
it doesn't get sad
it just runs programs
  Reply
#8
(07-18-2022, 10:35 PM)zer0sig Wrote: These boards, without a BIOS/POST like a PC, can be a bit perplexing - they look dead when they're just running an odd build. I remember buying my first PINE device, a 64 A+, and it just sat in a box - I fired it up and nothing. No idea what was going on. Started messing with different builds and it's been running for 5 years with almost zero interruption other than a rare outage (when I haven't had it sipping the juice from my UPS) or reboots after kernel/major armbian upgrades.

they are really some of the coolest little SBCs around, but they are definitely for the patient. I'll walk away sometimes and come back, try a different distro/build, and all is right with the world. Now I feel like building the 4 or 5 devices I haven't done anything with yet, heh

A friend got my RockPro64 to boot from SD - I was trying to boot it from eMMC and this has turned into a huge waste of time and money: In the end, I bought a new eMMC module from the Pine64 online store and I have another ticket open with them now because the eMMC module they sold me is even worse than the one I bought previously. Basically the only way I could get the eMMC to be used as the root filesystem is to run Uboot from either SD or SPI. It is impossible to load Uboot from eMMC directly on the RockPro64. I'm so disappointed with the RockPro64, which seemed to have so much potential. Writing to the eMMC is unreliable under load and causes filesystem corruption. I installed OpenMediaVault, but I don't trust the RockPro64 to store my data. I understand that these are 'hacker' SBC's, but they need to work reliably to be useful and the RockPro64 does not.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  RockPro64 not booting up mvicha@gmail.com 0 82 09-19-2022, 07:35 AM
Last Post: mvicha@gmail.com
  ROCKPro64 with 16 ports SATA controller ZeblodS 18 16,540 09-17-2022, 09:20 PM
Last Post: caroljames972022
  GPIO Expander HAT for ROCKPro64 and Quartz64 CounterPillow 7 1,925 07-18-2022, 10:05 PM
Last Post: zer0sig
  RockPro64 premium aluminium casing justwantin 2 523 05-27-2022, 06:51 PM
Last Post: justwantin
  charging 3 rockpro64 from single source rpt312 1 430 05-16-2022, 02:34 AM
Last Post: dukla2000
  help or suggestions removing RockPro64 Playbox please? jahway603 2 737 03-22-2022, 12:17 PM
Last Post: jahway603
  rockpro64 13 megapixel camera Aycaramba 9 8,716 01-24-2022, 02:47 PM
Last Post: solbs
  RockPro64 doesn't boot when PCIe to M.2 adapter is installed Cerberus 3 1,605 11-27-2021, 11:38 PM
Last Post: Cerberus
  Rockpro64 Sata Card kills itself jerry110 33 29,864 10-20-2021, 04:36 AM
Last Post: fieni
  RockPro64 has bad Memory (Software sogfaults and kernel panics) kop316 20 15,362 08-04-2021, 07:42 PM
Last Post: t4_4t

Forum Jump:


Users browsing this thread: 1 Guest(s)