Startx Error

I just installed Longsleeps base Ubuntu image and and then used the included script to install Mate desktop.  All went smoothly.  I now want to use Mate to configure Wifi.

I run StartX and the first problem I ran into was 

(EE) parse_vt_settings: Cannot open /dev/tty0 (No such file or directory)

I think that that was due to the fact that I needed to run startx as root.  (I included that example in case someone searches the forum.)  Anyway, I then ran "sudo startx" and then the system hands with the following error messages.

modprobe: FATAL: Module g2d_23 not found in directory /lib/modules/3.10.65-7-pine64-longsleep
modprobe: FATAL: Module mali_drm not found in directory /lib/modules/3.10.65-7-pine64-longsleep
modprobe: FATAL: Module sunxi_cedar_mod not found in directory /lib/modules/3.10.65-7-pine64-longsleep
SunxiMaliDRI2_Init: drmOpen failed!

So this brings me to my questions.  Did I do something wrong?  Is there something I can do to fix this?

Finally, is there a simple way to configure wireless via the CLI?  That is my first goal because I am running this headless.

Thank you!

I think that I sorted this one out. A reboot seemed to be required. I just restarted the Pine and it come up happily. Sorry!

Possibly Related Threads…
Thread Author Replies Views Last Post
  systemd-gpt-auto-generator: failed to dissect: input/output error 0 282 12-11-2019, 04:10 PM
Last Post:
  config error installing XML-RPC on longsleep Ubuntu tinkertom 2 1,459 02-22-2017, 06:50 AM
Last Post: MarkHaysHarris777
  Error load mate desktop environment b.simp404 2 1,190 01-21-2017, 02:24 PM
Last Post: wizkidcom
  GStreamer: XIO: fatal IO error 11 (Resource temporarily unavailable) on X server Pander 0 1,304 10-27-2016, 06:09 AM
Last Post: Pander
  Error When Resizing SD Card Bob123456789 4 1,128 07-07-2016, 11:06 AM
Last Post: Bob123456789
  Network Access Error coolnine98 5 1,389 06-29-2016, 06:15 PM
Last Post: coolnine98
  System program problem detected error ebclr 0 537 05-15-2016, 09:18 PM
Last Post: ebclr
  Mounting USB hard drive - error registering v4l2 subdevice Ruckus 4 1,430 05-13-2016, 06:48 AM
Last Post: Ruckus

Forum Jump:

Users browsing this thread: 1 Guest(s)