sw4 jumper for disabling eMMC boot / multiboot
#1
Ran into the following: I wanted to connect a little switch to choose between sdcard and emmc boot.

Didn't work: Open was fine - eMMC booted.

But closed seemed to boot from eMMC, too, but the archlinux didn't come up and got stuck while looking for its root device.

After some fiddling around, trying and reading serial console I tried a _jumper_.

Worked. As described in the layout the jumper shortens the clock of the emmc to ground. Is it possible that already a 5cm wire has too much resistance to disable the eMMC?

And if so, is there a smarter way to multiboot?


Possibly Related Threads…
Thread Author Replies Views Last Post
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 103 44,492 07-08-2021, 04:55 PM
Last Post: Mentaluproar
  Device unable to boot Lunix33 7 599 07-05-2021, 08:25 PM
Last Post: t4_4t
  First boot - no fan, no display... is it broken? rantoie 1 386 04-28-2021, 04:41 PM
Last Post: rantoie
  PXE boot - unable to login LMM 2 556 04-22-2021, 02:59 PM
Last Post: LMM
  eMMC 128gb flailingeffort 1 708 01-18-2021, 04:42 AM
Last Post: Wizzard
  unable to boot from SDCard Charles Tarkowski 4 1,353 12-16-2020, 11:11 AM
Last Post: Charles Tarkowski
  Rockpro64 boot issues larsgn 14 8,113 10-21-2020, 07:54 AM
Last Post: quinterro
  RockPro64 eMMC boot euu 4 3,092 08-24-2020, 11:07 PM
Last Post: t4_4t
  RockPro64 so problematic! Boot issues PorterDon 1 1,592 06-04-2020, 12:25 PM
Last Post: dukla2000
  Failure to boot atcwells 1 1,428 05-10-2020, 03:06 PM
Last Post: atcwells

Forum Jump:


Users browsing this thread: 1 Guest(s)