Mainline U-Boot with SPI, NVMe and SATA boot support
you have not disabled emmc by jumpering the sw4 switch https://wiki.pine64.org/index.php/ROCKPr...sable_eMMC?
irrelevant because kernel 4.4 works

you could eventually erase the spi with the ayufan spi or sigmaris erase image.
  Reply
(07-01-2021, 01:06 PM)LMM Wrote: you have not disabled emmc by jumpering the sw4 switch https://wiki.pine64.org/index.php/ROCKPr...sable_eMMC?
irrelevant because kernel 4.4 works

you could eventually erase the spi with the ayufan spi or sigmaris erase image.


I erased the spi and get the same result trying to boot from eMMC.
As expected booting from USB doesn't work anymore either.

reflashed the spi and:
- boot from eMMC fails again
- boot from USB works
  Reply
(07-03-2021, 04:47 AM)MisterA Wrote:
(07-01-2021, 01:06 PM)LMM Wrote: you have not disabled emmc by jumpering the sw4 switch https://wiki.pine64.org/index.php/ROCKPr...sable_eMMC?
irrelevant because kernel 4.4 works

you could eventually erase the spi with the ayufan spi or sigmaris erase image.


I erased the spi and get the same result trying to boot from eMMC.
As expected booting from USB doesn't work anymore either.

reflashed the spi and:
- boot from eMMC fails again
- boot from USB works

Last try, after i am stuck (but I am really pessimistic):
- launch armbian kernel 4.4 which is working
- copy u-boot to spi :
launch armbian-config
    in menu : system > hardware > Install >    Install/update the bootloader on spi flash

In this case the board will use the 4.4 bootloader since it is in written in the spi and then boot the 5.x kernel

An other try is to use the ayufan u-boot if the problem comes from the bootloader

my board version is v2.1 2018-07-02 which is newer than yours

You also may try with nvme if you have one (usb works, perhaps nvme also works). The ssd nvme speed is higher than emmc speed. But ssd nvme 256G is around 30$-40$ and the pcie adapter card is around 10$ ... and is is not sure it will work ! I tried samsung evo, and pny xlr8 they work well with the pine64 pcie adapter. I am not sure it worth trying.
  Reply
I managed to build mainline 2021.07 boot and get it running on the rockpro64.  Unfortunately, I'm not smart enough to tie in your features with the mainline (SATA boot, HDMI console support, etc).  Any pointers while I try to learn this?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Flashed SPI, able to ping RP64 but not boot from sdcard/usb korefuji 2 241 08-26-2021, 11:41 AM
Last Post: LMM
  Device unable to boot Lunix33 7 1,014 07-05-2021, 08:25 PM
Last Post: t4_4t
  Booting my RockPro64 from NVMe drive PsySc0rpi0n 3 967 05-02-2021, 01:56 AM
Last Post: LMM
  First boot - no fan, no display... is it broken? rantoie 1 544 04-28-2021, 04:41 PM
Last Post: rantoie
  PXE boot - unable to login LMM 2 589 04-22-2021, 02:59 PM
Last Post: LMM
  PCIe Armbian and Ayufan for nvme ssd LMM 1 849 02-03-2021, 04:38 PM
Last Post: LMM
  Camera sensor support on MIPI lines abhimanyu_gr 0 578 01-22-2021, 09:23 AM
Last Post: abhimanyu_gr
  unable to boot from SDCard Charles Tarkowski 4 1,612 12-16-2020, 11:11 AM
Last Post: Charles Tarkowski
  Rockpro64 boot issues larsgn 14 9,022 10-21-2020, 07:54 AM
Last Post: quinterro
  fan continously runs on kernel 5.8 but I need to use 5. kernel for PCIe sata card GreyLinux 4 2,185 10-20-2020, 10:52 AM
Last Post: GreyLinux

Forum Jump:


Users browsing this thread: 2 Guest(s)